summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <tristan@gentoo.org>2012-07-08 00:20:49 +0000
committerTristan Heaven <tristan@gentoo.org>2012-07-08 00:20:49 +0000
commitb38130f13487467cd0478cc8527ff45bf0e2efbd (patch)
tree4ef4a4968b61c568b1b9f68990a7251699637539 /games-arcade
parentPatch to fix building with gcc-4.7 from Daniel Johnson, bug #423465 (diff)
downloadgentoo-2-b38130f13487467cd0478cc8527ff45bf0e2efbd.tar.gz
gentoo-2-b38130f13487467cd0478cc8527ff45bf0e2efbd.tar.bz2
gentoo-2-b38130f13487467cd0478cc8527ff45bf0e2efbd.zip
Fix makefile with a patch instead of sed, bug #424213
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/amphetamine/ChangeLog8
-rw-r--r--games-arcade/amphetamine/amphetamine-0.8.10.ebuild25
-rw-r--r--games-arcade/amphetamine/files/amphetamine-0.8.10-build.patch33
3 files changed, 49 insertions, 17 deletions
diff --git a/games-arcade/amphetamine/ChangeLog b/games-arcade/amphetamine/ChangeLog
index 7f3bce27327a..3f5a9d0733de 100644
--- a/games-arcade/amphetamine/ChangeLog
+++ b/games-arcade/amphetamine/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/amphetamine
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/amphetamine/ChangeLog,v 1.8 2010/01/07 21:47:36 josejx Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/amphetamine/ChangeLog,v 1.9 2012/07/08 00:20:49 tristan Exp $
+
+ 08 Jul 2012; Tristan Heaven <tristan@gentoo.org> amphetamine-0.8.10.ebuild,
+ +files/amphetamine-0.8.10-build.patch:
+ Fix makefile with a patch instead of sed, bug #424213
07 Jan 2010; Joseph Jezak <josejx@gentoo.org> amphetamine-0.8.10.ebuild:
Marked ppc stable for bug #294564.
diff --git a/games-arcade/amphetamine/amphetamine-0.8.10.ebuild b/games-arcade/amphetamine/amphetamine-0.8.10.ebuild
index 431caf2c56e5..fd2806d02037 100644
--- a/games-arcade/amphetamine/amphetamine-0.8.10.ebuild
+++ b/games-arcade/amphetamine/amphetamine-0.8.10.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/amphetamine/amphetamine-0.8.10.ebuild,v 1.9 2010/01/07 21:47:36 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/amphetamine/amphetamine-0.8.10.ebuild,v 1.10 2012/07/08 00:20:49 tristan Exp $
EAPI=2
-inherit eutils toolchain-funcs games
+inherit eutils games
DESCRIPTION="a cool Jump'n Run game offering some unique visual effects"
HOMEPAGE="http://homepage.hispeed.ch/loehrer/amph/amph.html"
@@ -18,18 +18,13 @@ IUSE=""
DEPEND="media-libs/libsdl[audio,video]
x11-libs/libXpm"
-src_prepare() {
- epatch "${FILESDIR}"/${P}-64bit.patch
- sed -i \
- -e "/^INSTALL_DIR /s:=.*:= ${GAMES_DATADIR}/${PN}:" \
- -e "/^CFLAGS /s:$: ${CFLAGS}:" \
- -e "/^CXXFLAGS /s:-O9.*:${CXXFLAGS}:" \
- -e "/^DEPENDFLAGS /s:-g ::" \
- -e "/^LINKER /s:$: ${LDFLAGS}:" \
- -e "s:gcc:$(tc-getCC):" \
- -e "s:g++:$(tc-getCXX):" \
- Makefile \
- || die "sed failed"
+PATCHES=(
+ "${FILESDIR}"/${P}-build.patch
+ "${FILESDIR}"/${P}-64bit.patch
+)
+
+src_compile() {
+ emake INSTALL_DIR="${GAMES_DATADIR}"/${PN} || die
}
src_install() {
diff --git a/games-arcade/amphetamine/files/amphetamine-0.8.10-build.patch b/games-arcade/amphetamine/files/amphetamine-0.8.10-build.patch
new file mode 100644
index 000000000000..2c0185f3ff01
--- /dev/null
+++ b/games-arcade/amphetamine/files/amphetamine-0.8.10-build.patch
@@ -0,0 +1,33 @@
+--- Makefile
++++ Makefile
+@@ -26,8 +26,8 @@
+
+ # makemake variables
+
+-LINKER := g++
+-DEPENDFLAGS := -g ${SEARCHDIRS}
++LINKER = $(CXX) $(CXXFLAGS)
++DEPENDFLAGS := ${SEARCHDIRS}
+ TOUCHHEADERS := ${MYCODEDIR}/*.h
+
+ # C
+@@ -37,8 +37,8 @@
+
+ # C++
+
+-CXX := g++
+-CXXFLAGS = ${DEPENDFLAGS} -O9 -funroll-loops -fomit-frame-pointer -ffast-math -Wcast-align
++CXX ?= g++
++CXXFLAGS += ${DEPENDFLAGS}
+
+ %.o : %.cpp
+ ${CXX} ${CPPFLAGS} -c $< ${CXXFLAGS} -o $@
+@@ -66,7 +66,7 @@
+ LOADLIBES := $(LOADLIBES) -lXpm -lXt
+ endif
+
+-LDFLAGS = -L/usr/lib -L/usr/local/lib -L/usr/X11R6/lib
++LDFLAGS += -L/usr/lib -L/usr/local/lib -L/usr/X11R6/lib
+
+ .PHONY : default
+ default : amph