summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-04-11 04:35:08 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-04-11 04:35:08 +0000
commit9387173692bdfc230d8ce3d84f4bde2333d3f9d8 (patch)
tree5481aac278306fe918160ef4e5a5e8c827d556be /games-arcade/pydance
parentforgot some pngs - digest fix (diff)
downloadgentoo-2-9387173692bdfc230d8ce3d84f4bde2333d3f9d8.tar.gz
gentoo-2-9387173692bdfc230d8ce3d84f4bde2333d3f9d8.tar.bz2
gentoo-2-9387173692bdfc230d8ce3d84f4bde2333d3f9d8.zip
version bump (bug #43921)
Diffstat (limited to 'games-arcade/pydance')
-rw-r--r--games-arcade/pydance/ChangeLog9
-rw-r--r--games-arcade/pydance/Manifest10
-rw-r--r--games-arcade/pydance/files/digest-pydance-1.0.11
-rw-r--r--games-arcade/pydance/pydance-1.0.1.ebuild55
4 files changed, 69 insertions, 6 deletions
diff --git a/games-arcade/pydance/ChangeLog b/games-arcade/pydance/ChangeLog
index 4db41f8a6951..c3745592afd1 100644
--- a/games-arcade/pydance/ChangeLog
+++ b/games-arcade/pydance/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-arcade/pydance
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/pydance/ChangeLog,v 1.6 2004/02/22 10:21:38 vapier Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/pydance/ChangeLog,v 1.7 2004/04/11 04:35:08 mr_bones_ Exp $
+
+*pydance-1.0.1 (10 Apr 2004)
+
+ 10 Apr 2004; Michael Sterrett <mr_bones_@gentoo.org> pydance-1.0.1.ebuild:
+ version bump (bug #43921)
*pydance-0.9.1 (22 Feb 2004)
diff --git a/games-arcade/pydance/Manifest b/games-arcade/pydance/Manifest
index eaefdf5ca425..113be92e4e99 100644
--- a/games-arcade/pydance/Manifest
+++ b/games-arcade/pydance/Manifest
@@ -1,7 +1,9 @@
-MD5 a2df103ba0040f5cf5a23b75757d5ca5 files/digest-pydance-0.9.1 66
-MD5 c237078ad2507ef504b365367eee93fc files/pydance 52
-MD5 09e7b27e71647e440714ef4ee6c503c0 files/digest-pydance-0.8.4 66
MD5 9bf6ca456e5d9a9e24831d8eec02ccec ChangeLog 2142
-MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 4c6e78854dc726d563232bc600fda04c pydance-0.9.1.ebuild 1319
+MD5 7a9e47040fd1a2afd8cbfd58ea4f2df1 pydance-1.0.1.ebuild 1327
+MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 00657e187af6349c9c61bb54e5225888 pydance-0.8.4.ebuild 1322
+MD5 a2df103ba0040f5cf5a23b75757d5ca5 files/digest-pydance-0.9.1 66
+MD5 c237078ad2507ef504b365367eee93fc files/pydance 52
+MD5 565f4f9b773036c350ffaee1db155fd9 files/digest-pydance-1.0.1 66
+MD5 09e7b27e71647e440714ef4ee6c503c0 files/digest-pydance-0.8.4 66
diff --git a/games-arcade/pydance/files/digest-pydance-1.0.1 b/games-arcade/pydance/files/digest-pydance-1.0.1
new file mode 100644
index 000000000000..eb719ef6797d
--- /dev/null
+++ b/games-arcade/pydance/files/digest-pydance-1.0.1
@@ -0,0 +1 @@
+MD5 9e08b9f8a2b8f75c2393378ef69241d7 pydance-1.0.1.tar.gz 5640158
diff --git a/games-arcade/pydance/pydance-1.0.1.ebuild b/games-arcade/pydance/pydance-1.0.1.ebuild
new file mode 100644
index 000000000000..094d1a55d09e
--- /dev/null
+++ b/games-arcade/pydance/pydance-1.0.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/pydance/pydance-1.0.1.ebuild,v 1.1 2004/04/11 04:35:08 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="pyDance is a DDR clone for linux written in Python"
+HOMEPAGE="http://www.icculus.org/pyddr/"
+SRC_URI="http://www.icculus.org/pyddr/${P}.tar.gz"
+
+LICENSE="X11"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+RDEPEND="dev-python/pygame
+ media-libs/libvorbis
+ media-libs/sdl-mixer"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+PDEPEND="games-arcade/pydance-songs"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i \
+ -e "s:/etc/:${GAMES_SYSCONFDIR}/:" \
+ constants.py docs/man/pydance.6 \
+ || die "sed failed"
+}
+
+src_install() {
+ local dir="${GAMES_DATADIR}/${PN}"
+
+ insinto ${dir}
+ doins *.py || die "doins failed"
+ cp -R {sound,images,utils,themes} "${D}${dir}/" || die "cp failed"
+
+ insinto ${GAMES_SYSCONFDIR}
+ newins pydance.posix.cfg pydance.cfg
+
+ games_make_wrapper pydance "python ./pydance.py" "${dir}"
+
+ dodoc BUGS CREDITS ChangeLog HACKING README TODO
+ dohtml docs/README.html
+ doman docs/man/*
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ einfo "If you want to use a DDR pad with pyDance,"
+ einfo "all you need to do is emerge the games-arcade/ddrmat kernel module."
+ echo
+}