summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-02-05 21:58:17 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-02-05 21:58:17 +0000
commit9ffa648aea829cd0211ee71cdd25bcc8a074114b (patch)
treee6075ce35332151bfd9ad0102ee3ffb57b07f121 /games-arcade/cob
parentversion bump; clean old (diff)
downloadgentoo-2-9ffa648aea829cd0211ee71cdd25bcc8a074114b.tar.gz
gentoo-2-9ffa648aea829cd0211ee71cdd25bcc8a074114b.tar.bz2
gentoo-2-9ffa648aea829cd0211ee71cdd25bcc8a074114b.zip
use epatch; add libsdl use deps
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-arcade/cob')
-rw-r--r--games-arcade/cob/ChangeLog6
-rw-r--r--games-arcade/cob/cob-0.9.ebuild15
2 files changed, 12 insertions, 9 deletions
diff --git a/games-arcade/cob/ChangeLog b/games-arcade/cob/ChangeLog
index 39c6f6b3045f..40e98f5bd9d0 100644
--- a/games-arcade/cob/ChangeLog
+++ b/games-arcade/cob/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-arcade/cob
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/cob/ChangeLog,v 1.11 2015/01/03 19:31:13 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/cob/ChangeLog,v 1.12 2015/02/05 21:58:17 mr_bones_ Exp $
+
+ 05 Feb 2015; Michael Sterrett <mr_bones_@gentoo.org> cob-0.9.ebuild:
+ use epatch; add libsdl use deps
03 Jan 2015; Tupone Alfredo <tupone@gentoo.org> cob-0.9.ebuild:
EAPI 5
@@ -35,4 +38,3 @@
12 Nov 2003; Michael Sterrett <mr_bones_@gentoo.org> cob-0.9.ebuild:
initial commit; ebuild supplied by flash3001 via bug 33223
-
diff --git a/games-arcade/cob/cob-0.9.ebuild b/games-arcade/cob/cob-0.9.ebuild
index fd475aa1f314..21ffe63dc91b 100644
--- a/games-arcade/cob/cob-0.9.ebuild
+++ b/games-arcade/cob/cob-0.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/cob/cob-0.9.ebuild,v 1.14 2015/01/03 19:31:13 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/cob/cob-0.9.ebuild,v 1.15 2015/02/05 21:58:17 mr_bones_ Exp $
EAPI=5
inherit eutils games
@@ -14,13 +14,14 @@ SLOT="0"
KEYWORDS="alpha ~amd64 ppc ~sparc x86 ~x86-fbsd"
IUSE=""
-DEPEND="media-libs/libsdl"
-RDEPEND="${DEPEND}"
+DEPEND="media-libs/libsdl[joystick,sound,video]"
+RDEPEND=${DEPEND}
-PATCHES=(
- "${FILESDIR}"/${P}-gcc43.patch
- "${FILESDIR}"/${P}-gcc44.patch
-)
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-gcc44.patch
+}
src_install() {
default