summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2014-09-25 20:50:13 +0000
committerAlfredo Tupone <tupone@gentoo.org>2014-09-25 20:50:13 +0000
commitb831408ec93e6d4a9d04dc7c019c675f61b2d5f8 (patch)
treedd3cf79878c587b448c7feeee465fd28a8d26886 /games-action
parentNew package dev-python/eliot (diff)
downloadgentoo-2-b831408ec93e6d4a9d04dc7c019c675f61b2d5f8.tar.gz
gentoo-2-b831408ec93e6d4a9d04dc7c019c675f61b2d5f8.tar.bz2
gentoo-2-b831408ec93e6d4a9d04dc7c019c675f61b2d5f8.zip
Fix build with media-libs/jpeg-9 Bug #520726
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0145142D)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/supertuxkart/ChangeLog6
-rw-r--r--games-action/supertuxkart/files/supertuxkart-0.8.1-jpeg9.patch11
-rw-r--r--games-action/supertuxkart/supertuxkart-0.8.1.ebuild4
3 files changed, 18 insertions, 3 deletions
diff --git a/games-action/supertuxkart/ChangeLog b/games-action/supertuxkart/ChangeLog
index 58cfa794e03d..5192b8dc1d30 100644
--- a/games-action/supertuxkart/ChangeLog
+++ b/games-action/supertuxkart/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/supertuxkart
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/supertuxkart/ChangeLog,v 1.43 2014/04/29 23:31:25 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/supertuxkart/ChangeLog,v 1.44 2014/09/25 20:50:13 tupone Exp $
+
+ 25 Sep 2014; Alfredo Tupone <tupone@gentoo.org> supertuxkart-0.8.1.ebuild,
+ +files/supertuxkart-0.8.1-jpeg9.patch:
+ Fix build with media-libs/jpeg-9 Bug #520726 by flameeyes@gentoo.org
29 Apr 2014; Julian Ospald <hasufell@gentoo.org> supertuxkart-0.8.1.ebuild,
+files/supertuxkart-0.8.1-mesa-10.x.patch:
diff --git a/games-action/supertuxkart/files/supertuxkart-0.8.1-jpeg9.patch b/games-action/supertuxkart/files/supertuxkart-0.8.1-jpeg9.patch
new file mode 100644
index 000000000000..3c120c9b22e2
--- /dev/null
+++ b/games-action/supertuxkart/files/supertuxkart-0.8.1-jpeg9.patch
@@ -0,0 +1,11 @@
+--- lib/irrlicht/source/Irrlicht/CImageLoaderJPG.cpp.old 2014-09-25 06:56:46.911153643 +0200
++++ lib/irrlicht/source/Irrlicht/CImageLoaderJPG.cpp 2014-09-25 06:55:52.817175916 +0200
+@@ -66,7 +66,7 @@
+ boolean CImageLoaderJPG::fill_input_buffer (j_decompress_ptr cinfo)
+ {
+ // DO NOTHING
+- return 1;
++ return TRUE;
+ }
+
+
diff --git a/games-action/supertuxkart/supertuxkart-0.8.1.ebuild b/games-action/supertuxkart/supertuxkart-0.8.1.ebuild
index 32fe3b170215..e54986c7aaa1 100644
--- a/games-action/supertuxkart/supertuxkart-0.8.1.ebuild
+++ b/games-action/supertuxkart/supertuxkart-0.8.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/supertuxkart/supertuxkart-0.8.1.ebuild,v 1.5 2014/04/29 23:31:25 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/supertuxkart/supertuxkart-0.8.1.ebuild,v 1.6 2014/09/25 20:50:13 tupone Exp $
EAPI=5
inherit gnome2-utils cmake-utils eutils games
@@ -41,7 +41,7 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/SuperTuxKart-${PV}
src_prepare() {
- epatch "${FILESDIR}"/${P}-{gentoo,icon-dest,irrlicht,desktopfile,mesa-10.x}.patch
+ epatch "${FILESDIR}"/${P}-{gentoo,icon-dest,irrlicht,desktopfile,mesa-10.x,jpeg9}.patch
# inconsistent handling of debug definition
# avoid using Debug build type