summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2012-09-01 18:42:37 +0000
committerAlfredo Tupone <tupone@gentoo.org>2012-09-01 18:42:37 +0000
commit8977da99183b2e49aec1ed764f4e7689cfd94937 (patch)
tree523cf64388bfe408ed9340bad3db31582eae693d /games-action
parentarm stable, bug #432646 (diff)
downloadgentoo-2-8977da99183b2e49aec1ed764f4e7689cfd94937.tar.gz
gentoo-2-8977da99183b2e49aec1ed764f4e7689cfd94937.tar.bz2
gentoo-2-8977da99183b2e49aec1ed764f4e7689cfd94937.zip
Fix some overflow. Bug #431800
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/d2x/ChangeLog8
-rw-r--r--games-action/d2x/d2x-0.2.5-r3.ebuild5
-rw-r--r--games-action/d2x/files/d2x-0.2.5-ovflw.patch27
3 files changed, 36 insertions, 4 deletions
diff --git a/games-action/d2x/ChangeLog b/games-action/d2x/ChangeLog
index 88c0bdc9a189..0d6a7f4f17bc 100644
--- a/games-action/d2x/ChangeLog
+++ b/games-action/d2x/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/d2x
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/ChangeLog,v 1.26 2011/07/08 11:10:06 ssuominen Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/ChangeLog,v 1.27 2012/09/01 18:42:36 tupone Exp $
+
+ 01 Sep 2012; Alfredo Tupone <tupone@gentoo.org> d2x-0.2.5-r3.ebuild,
+ +files/d2x-0.2.5-ovflw.patch:
+ Fix some overflow. Bug #431800 by Diego Elio Pettenò
08 Jul 2011; Samuli Suominen <ssuominen@gentoo.org> d2x-0.2.5-r3.ebuild:
Convert from "useq" to "use".
diff --git a/games-action/d2x/d2x-0.2.5-r3.ebuild b/games-action/d2x/d2x-0.2.5-r3.ebuild
index 32903111eda0..36107450cfaf 100644
--- a/games-action/d2x/d2x-0.2.5-r3.ebuild
+++ b/games-action/d2x/d2x-0.2.5-r3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/d2x-0.2.5-r3.ebuild,v 1.10 2011/07/08 11:10:06 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/d2x-0.2.5-r3.ebuild,v 1.11 2012/09/01 18:42:36 tupone Exp $
EAPI=2
inherit eutils flag-o-matic games
@@ -30,6 +30,7 @@ dir=${GAMES_DATADIR}/${PN}
src_prepare() {
epatch \
"${FILESDIR}/${PV}-shellscripts.patch" \
+ "${FILESDIR}"/${P}-ovflw.patch \
"${FILESDIR}/${P}-dofpcalcs-macro.patch"
sed -i \
diff --git a/games-action/d2x/files/d2x-0.2.5-ovflw.patch b/games-action/d2x/files/d2x-0.2.5-ovflw.patch
new file mode 100644
index 000000000000..a2873a8c3bf7
--- /dev/null
+++ b/games-action/d2x/files/d2x-0.2.5-ovflw.patch
@@ -0,0 +1,27 @@
+--- main/multi.h.old 2012-09-01 14:33:13.668620792 +0200
++++ main/multi.h 2012-09-01 14:33:25.043385055 +0200
+@@ -120,7 +120,7 @@
+
+ #define MAX_NET_CREATE_OBJECTS 40
+
+-#define MAX_MULTI_MESSAGE_LEN 120
++#define MAX_MULTI_MESSAGE_LEN 138
+
+ // Exported functions
+
+--- main/ai.c.old 2012-09-01 15:02:36.754081633 +0200
++++ main/ai.c 2012-09-01 20:16:07.846989673 +0200
+@@ -1885,8 +1885,11 @@
+ fread( &Last_gate_time, sizeof(fix), 1, fp );
+ fread( &Gate_interval, sizeof(fix), 1, fp );
+ fread( &Boss_dying_start_time, sizeof(fix), 1, fp );
+- fread( &Boss_dying, sizeof(int), 1, fp );
+- fread( &Boss_dying_sound_playing, sizeof(int), 1, fp );
++ int temp;
++ fread( &temp, sizeof(int), 1, fp );
++ Boss_dying = temp;
++ fread( &temp, sizeof(int), 1, fp );
++ Boss_dying_sound_playing = temp;
+ fread( &Boss_hit_time, sizeof(fix), 1, fp );
+ // -- MK, 10/21/95, unused! -- fread( &Boss_been_hit, sizeof(int), 1, fp );
+