summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-06-18 00:11:43 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-06-18 00:11:43 +0000
commit60be1255f4f0a5f889eb846e590cefac16c50636 (patch)
tree94913545473f08b0ea3638334225544d86410583 /games-action
parentadd missing test to IUSE (diff)
downloadgentoo-2-60be1255f4f0a5f889eb846e590cefac16c50636.tar.gz
gentoo-2-60be1255f4f0a5f889eb846e590cefac16c50636.tar.bz2
gentoo-2-60be1255f4f0a5f889eb846e590cefac16c50636.zip
old
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/teeworlds/ChangeLog8
-rw-r--r--games-action/teeworlds/files/teeworlds-0.5.2-gcc46.patch10
-rw-r--r--games-action/teeworlds/files/teeworlds-0.5.2-system-libs.patch53
-rw-r--r--games-action/teeworlds/files/teeworlds-0.5.2-wavpack.patch57
-rw-r--r--games-action/teeworlds/teeworlds-0.5.2.ebuild104
5 files changed, 7 insertions, 225 deletions
diff --git a/games-action/teeworlds/ChangeLog b/games-action/teeworlds/ChangeLog
index 0e70bf2f6402..d71f3ec344a7 100644
--- a/games-action/teeworlds/ChangeLog
+++ b/games-action/teeworlds/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-action/teeworlds
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/teeworlds/ChangeLog,v 1.8 2012/06/15 15:41:08 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/teeworlds/ChangeLog,v 1.9 2012/06/18 00:11:43 mr_bones_ Exp $
+
+ 18 Jun 2012; Michael Sterrett <mr_bones_@gentoo.org>
+ -files/teeworlds-0.5.2-gcc46.patch, -files/teeworlds-0.5.2-system-libs.patch,
+ -files/teeworlds-0.5.2-wavpack.patch, -teeworlds-0.5.2.ebuild,
+ teeworlds-0.6.1.ebuild:
+ old
15 Jun 2012; Michael Sterrett <mr_bones_@gentoo.org> teeworlds-0.6.1.ebuild:
use makeopts_jobs (bug #421173)
diff --git a/games-action/teeworlds/files/teeworlds-0.5.2-gcc46.patch b/games-action/teeworlds/files/teeworlds-0.5.2-gcc46.patch
deleted file mode 100644
index 06f9422a274e..000000000000
--- a/games-action/teeworlds/files/teeworlds-0.5.2-gcc46.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/game/server/entity.hpp.old 2012-03-26 10:32:17.189461453 +0200
-+++ src/game/server/entity.hpp 2012-03-26 10:32:52.176006440 +0200
-@@ -3,6 +3,7 @@
-
- #include <new>
- #include <base/vmath.hpp>
-+#include <cstddef>
-
- #define MACRO_ALLOC_HEAP() \
- public: \
diff --git a/games-action/teeworlds/files/teeworlds-0.5.2-system-libs.patch b/games-action/teeworlds/files/teeworlds-0.5.2-system-libs.patch
deleted file mode 100644
index 2ffb3d566054..000000000000
--- a/games-action/teeworlds/files/teeworlds-0.5.2-system-libs.patch
+++ /dev/null
@@ -1,53 +0,0 @@
---- default.bam.orig 2010-03-24 22:16:59.000000000 +0100
-+++ default.bam 2010-03-24 22:17:32.000000000 +0100
-@@ -7,6 +7,8 @@
- config:Add(OptFindCompiler())
- config:Add(OptTestCompileC("stackprotector", "int main(){return 0;}", "-fstack-protector -fstack-protector-all"))
- config:Add(OptFindLibrary("zlib", "zlib.h", false))
-+config:Add(OptFindLibrary("pnglite", "pnglite.h", false))
-+config:Add(OptFindLibrary("wavpack", "wavpack/wavpack.h", false))
- config:Add(SDL.OptFind("sdl", true))
- config:Finalize("config.bam")
-
-@@ -150,9 +152,6 @@
- settings.cc.includes:Add("src/engine/external/zlib")
- end
-
-- -- build the small libraries
-- wavpack = Compile(settings, Collect("src/engine/external/wavpack/*.c"))
-- pnglite = Compile(settings, Collect("src/engine/external/pnglite/*.c"))
-
- -- build game components
- engine_settings = settings:Copy()
-@@ -160,6 +159,31 @@
- client_settings = engine_settings:Copy()
- launcher_settings = engine_settings:Copy()
-
-+ -- compile pnglite if needed
-+ if config.pnglite.value == 1 then
-+ client_settings.link.libs:Add("pnglite")
-+ if config.pnglite.include_path then
-+ client_settings.cc.includes:Add(config.pnglite.include_path)
-+ end
-+ pnglite = {}
-+ else
-+ pnglite = Compile(settings, Collect("src/engine/external/pnglite/*.c"))
-+ client_settings.cc.includes:Add("src/engine/external/pnglite")
-+ end
-+
-+ -- compile wavpack if needed
-+ if config.wavpack.value == 1 then
-+ client_settings.link.libs:Add("wavpack")
-+ if config.wavpack.include_path then
-+ client_settings.cc.includes:Add(config.wavpack.include_path)
-+ end
-+ wavpack = {}
-+ else
-+ wavpack = Compile(settings, Collect("src/engine/external/wavpack/*.c"))
-+ client_settings.cc.includes:Add("src/engine/external")
-+ end
-+
-+
- if family == "unix" then
- if platform == "macosx" then
- client_settings.link.frameworks:Add("OpenGL")
diff --git a/games-action/teeworlds/files/teeworlds-0.5.2-wavpack.patch b/games-action/teeworlds/files/teeworlds-0.5.2-wavpack.patch
deleted file mode 100644
index 76a2b6a504cd..000000000000
--- a/games-action/teeworlds/files/teeworlds-0.5.2-wavpack.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-diff --git a/src/engine/client/ec_snd.c b/src/engine/client/ec_snd.c
-index 034dfb2..67e819c 100644
---- a/src/engine/client/ec_snd.c
-+++ b/src/engine/client/ec_snd.c
-@@ -359,19 +359,13 @@
- }
-
-
--static IOHANDLE file = NULL;
--
--static int read_data(void *buffer, int size)
--{
-- return io_read(file, buffer, size);
--}
--
- int snd_load_wv(const char *filename)
- {
- SAMPLE *snd;
- int sid = -1;
- char error[100];
- WavpackContext *context;
-+ char completefilename[512];
-
- /* don't waste memory on sound when we are stress testing */
- if(config.dbg_stress)
-@@ -381,19 +375,13 @@
- if(!sound_enabled)
- return 1;
-
-- file = engine_openfile(filename, IOFLAG_READ); /* TODO: use system.h stuff for this */
-- if(!file)
-- {
-- dbg_msg("sound/wv", "failed to open %s", filename);
-- return -1;
-- }
--
- sid = snd_alloc_id();
- if(sid < 0)
- return -1;
- snd = &samples[sid];
-
-- context = WavpackOpenFileInput(read_data, error);
-+ engine_getpath(completefilename, sizeof(completefilename), filename, IOFLAG_READ);
-+ context = WavpackOpenFileInput(completefilename, error, OPEN_2CH_MAX, 0);
- if (context)
- {
- int samples = WavpackGetNumSamples(context);
-@@ -448,9 +436,6 @@
- dbg_msg("sound/wv", "failed to open %s: %s", filename, error);
- }
-
-- io_close(file);
-- file = NULL;
--
- if(config.debug)
- dbg_msg("sound/wv", "loaded %s", filename);
-
diff --git a/games-action/teeworlds/teeworlds-0.5.2.ebuild b/games-action/teeworlds/teeworlds-0.5.2.ebuild
deleted file mode 100644
index 769d79c74c83..000000000000
--- a/games-action/teeworlds/teeworlds-0.5.2.ebuild
+++ /dev/null
@@ -1,104 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/teeworlds/teeworlds-0.5.2.ebuild,v 1.4 2012/03/26 08:50:04 tupone Exp $
-
-EAPI=2
-inherit eutils python games
-
-DESCRIPTION="Online multi-player platform 2D shooter"
-HOMEPAGE="http://www.teeworlds.com/"
-SRC_URI="http://www.teeworlds.com/files/${P}-src.tar.gz"
-
-LICENSE="ZLIB"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug dedicated"
-
-RDEPEND="
- !dedicated? ( media-libs/pnglite
- media-libs/libsdl[X,audio,opengl,video]
- media-sound/wavpack
- virtual/opengl
- x11-libs/libX11 )
- sys-libs/zlib"
-DEPEND="${RDEPEND}
- =dev-lang/python-2*
- <=dev-util/bam-0.2.0"
-
-S=${WORKDIR}/${P}-src
-
-pkg_setup() {
- python_set_active_version 2
- games_pkg_setup
-}
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-system-libs.patch \
- "${FILESDIR}"/${P}-gcc46.patch \
- "${FILESDIR}"/${P}-wavpack.patch
-
- # fix includes
- sed -i -e "s:.engine/external/pnglite/pnglite.h.:<pnglite.h>:" \
- src/engine/client/ec_gfx.c src/tools/dilate.c \
- src/tools/tileset_borderfix.c \
- || die "sed failed"
- sed -i -e "s:.engine/external/wavpack/wavpack.h.:<wavpack/wavpack.h>:" \
- src/engine/client/ec_snd.c || die "sed failed"
-
- # use ${GAMES_DATADIR} instead of ./data
- sed -i -e \
- "s:^\(#define DATA_DIR\) \"data\":\1 \"${GAMES_DATADIR}/${PN}\":" \
- src/engine/e_engine.c || die "sed failed"
-}
-
-src_configure() {
- bam config || die "bam config failed"
-}
-
-src_compile() {
- local myopt
-
- if use debug; then
- myopt=" server_debug"
- else
- myopt=" server_release"
- fi
- if ! use dedicated; then
- if use debug; then
- myopt+=" client_debug"
- else
- myopt+=" client_release"
- fi
- fi
-
- bam ${myopt} || die "bam failed"
-}
-
-src_install() {
- if use debug; then
- newgamesbin ${PN}_srv_d ${PN}_srv || die "newgamesbin failed"
- else
- dogamesbin ${PN}_srv || die "dogamesbin failed"
- fi
- if ! use dedicated; then
- if use debug; then
- newgamesbin ${PN}_d ${PN} || die "newgamesbin failed"
- else
- dogamesbin ${PN} || die "dogamesbin failed"
- fi
-
- doicon "${FILESDIR}"/${PN}.xpm || die "doicon failed"
- make_desktop_entry ${PN} Teeworlds
-
- insinto "${GAMES_DATADIR}"/${PN}
- doins -r data/* || die "doins failed"
- else
- insinto "${GAMES_DATADIR}"/${PN}/maps
- doins -r data/maps/* || die "doins failed"
- fi
-
- dodoc readme.txt || die "dodoc failed"
-
- prepgamesdirs
-}