summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-08-06 20:44:17 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-08-06 20:44:17 +0000
commit54bb6c6d823b13ee43aeab2abe236d1e214db1d7 (patch)
tree956b955e118a513911b4a6c3e2975bcccd9812e8 /games-action
parentStable for HPPA (bug #518032). (diff)
downloadgentoo-2-54bb6c6d823b13ee43aeab2abe236d1e214db1d7.tar.gz
gentoo-2-54bb6c6d823b13ee43aeab2abe236d1e214db1d7.tar.bz2
gentoo-2-54bb6c6d823b13ee43aeab2abe236d1e214db1d7.zip
version bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key BDEED020)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/super-hexagon/ChangeLog8
-rw-r--r--games-action/super-hexagon/super-hexagon-07252014.ebuild85
2 files changed, 92 insertions, 1 deletions
diff --git a/games-action/super-hexagon/ChangeLog b/games-action/super-hexagon/ChangeLog
index 0d94563dc60f..49e3a1462476 100644
--- a/games-action/super-hexagon/ChangeLog
+++ b/games-action/super-hexagon/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-action/super-hexagon
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/super-hexagon/ChangeLog,v 1.7 2014/03/18 18:16:23 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/super-hexagon/ChangeLog,v 1.8 2014/08/06 20:44:17 hasufell Exp $
+
+*super-hexagon-07252014 (06 Aug 2014)
+
+ 06 Aug 2014; Julian Ospald <hasufell@gentoo.org>
+ +super-hexagon-07252014.ebuild:
+ version bump
18 Mar 2014; Michael Sterrett <mr_bones_@gentoo.org> -super-hexagon-15.ebuild:
old
diff --git a/games-action/super-hexagon/super-hexagon-07252014.ebuild b/games-action/super-hexagon/super-hexagon-07252014.ebuild
new file mode 100644
index 000000000000..d2c893e279f9
--- /dev/null
+++ b/games-action/super-hexagon/super-hexagon-07252014.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/super-hexagon/super-hexagon-07252014.ebuild,v 1.1 2014/08/06 20:44:17 hasufell Exp $
+
+# we use bundled glew, cause slotting 1.6 does not give us
+# much benefit for one consumer
+
+EAPI=5
+
+inherit eutils unpacker games
+
+DESCRIPTION="A minimal action game by Terry Cavanagh, with music by Chipzel"
+HOMEPAGE="http://www.superhexagon.com/"
+SRC_URI="superhexagon-${PV}-bin"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="bundled-libs"
+RESTRICT="bindist fetch splitdebug"
+
+MYGAMEDIR=${GAMES_PREFIX_OPT}/${PN}
+QA_PREBUILT="${MYGAMEDIR#/}/x86/*
+ ${MYGAMEDIR#/}/x86_64/*"
+
+DEPEND="app-arch/unzip"
+RDEPEND="
+ virtual/glu
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libxcb
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXxf86vm
+ !bundled-libs? (
+ media-libs/freeglut
+ media-libs/libogg
+ media-libs/libvorbis
+ media-libs/openal
+ )"
+
+S=${WORKDIR}/data
+
+pkg_nofetch() {
+ einfo "Please buy & download ${SRC_URI} from:"
+ einfo " ${HOMEPAGE}"
+ einfo "and move it to ${DISTDIR}"
+ einfo
+}
+
+src_unpack() {
+ unpack_zip ${A}
+}
+
+src_prepare() {
+ einfo "removing ${ARCH} unrelated files"
+ rm -r $(usex amd64 "x86" "x86_64") || die
+
+ if ! use bundled-libs ; then
+ einfo "removing bundled-libs..."
+ cd $(usex amd64 "x86_64" "x86") || die
+ rm libglut.so* libogg.so* libopenal.so* libstdc++.so* \
+ libvorbis.so* libvorbisfile.so*
+ fi
+}
+
+src_install() {
+ local myarch=$(usex amd64 "x86_64" "x86")
+
+ insinto "${MYGAMEDIR}"
+ doins -r data ${myarch} SuperHexagon.png
+
+ dodoc Linux.README
+
+ newicon SuperHexagon.png ${PN}.png
+ make_desktop_entry ${PN}
+ games_make_wrapper ${PN} "./${myarch}/superhexagon.${myarch}" "${MYGAMEDIR}" "${MYGAMEDIR}/${myarch}"
+
+ fperms +x "${MYGAMEDIR}/${myarch}/superhexagon.${myarch}"
+ prepgamesdirs
+}