summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-03-02 01:25:21 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-03-02 01:25:21 +0000
commit44dc39fcda78d348345bfec3637bb910de0686c6 (patch)
tree5b41b1becf983b821371e72e75e288977a956a3c /games-action/supertuxkart
parentFixing fcc 4.3.3 / fortify_sources error. Patch from Ubuntu. Closes #260180 (diff)
downloadgentoo-2-44dc39fcda78d348345bfec3637bb910de0686c6.tar.gz
gentoo-2-44dc39fcda78d348345bfec3637bb910de0686c6.tar.bz2
gentoo-2-44dc39fcda78d348345bfec3637bb910de0686c6.zip
version bump
(Portage version: 2.1.6.7/cvs/Linux i686)
Diffstat (limited to 'games-action/supertuxkart')
-rw-r--r--games-action/supertuxkart/ChangeLog10
-rw-r--r--games-action/supertuxkart/supertuxkart-0.6.1a.ebuild59
2 files changed, 67 insertions, 2 deletions
diff --git a/games-action/supertuxkart/ChangeLog b/games-action/supertuxkart/ChangeLog
index 63353c619454..6ca04807c147 100644
--- a/games-action/supertuxkart/ChangeLog
+++ b/games-action/supertuxkart/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-action/supertuxkart
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/supertuxkart/ChangeLog,v 1.9 2008/03/10 08:51:20 mr_bones_ Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/supertuxkart/ChangeLog,v 1.10 2009/03/02 01:25:21 mr_bones_ Exp $
+
+*supertuxkart-0.6.1a (02 Mar 2009)
+
+ 02 Mar 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ +supertuxkart-0.6.1a.ebuild:
+ version bump
*supertuxkart-0.4 (10 Mar 2008)
diff --git a/games-action/supertuxkart/supertuxkart-0.6.1a.ebuild b/games-action/supertuxkart/supertuxkart-0.6.1a.ebuild
new file mode 100644
index 000000000000..1ee4f8d39a55
--- /dev/null
+++ b/games-action/supertuxkart/supertuxkart-0.6.1a.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/supertuxkart/supertuxkart-0.6.1a.ebuild,v 1.1 2009/03/02 01:25:21 mr_bones_ Exp $
+
+EAPI=2
+inherit autotools eutils games
+
+DESCRIPTION="A kart racing game starring Tux, the linux penguin (TuxKart fork)"
+HOMEPAGE="http://supertuxkart.sourceforge.net/"
+SRC_URI="mirror://sourceforge/supertuxkart/${P}.tar.bz2
+ mirror://gentoo/${PN}.png"
+
+LICENSE="GPL-3 CCPL-Attribution-ShareAlike-3.0 CCPL-Attribution-2.0 CCPL-Sampling-Plus-1.0 public-domain as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=media-libs/plib-1.8.4
+ virtual/opengl
+ virtual/glut
+ net-libs/enet
+ media-libs/libmikmod
+ media-libs/libvorbis
+ media-libs/openal
+ media-libs/libsdl"
+
+src_prepare() {
+ sed -i \
+ -e '/ENETTREE/d' \
+ -e '/src\/enet\/Makefile/d' \
+ configure.ac \
+ || die "sed failed"
+ sed -i \
+ -e '/SUBDIRS/s/doc//' \
+ -e '/pkgdata/d' \
+ Makefile.am \
+ || die "sed failed"
+ sed -i \
+ -e '/pkgdatadir/s:/games::' \
+ -e '/desktop/d' \
+ -e '/icon/d' \
+ $(find data -name Makefile.am) \
+ || die "sed failed"
+ sed -i \
+ -e '/bindir/d' \
+ -e '/AM_CPPFLAGS/s:/games::' \
+ src/Makefile.am \
+ || die "sed failed"
+ rm -rf src/enet
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ doicon "${DISTDIR}"/${PN}.png
+ make_desktop_entry ${PN} SuperTuxKart
+ dodoc AUTHORS ChangeLog README TODO
+ prepgamesdirs
+}