summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-01-11 14:41:08 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-01-11 14:41:08 +0000
commit860cdc33d169d0bebe1f5232d7ec9cb378288af6 (patch)
treefae3f4c0c5faabd8746acdfa4ac480d896942807 /games-action/spacetripper-demo
parentStable on sparc (diff)
downloadgentoo-2-860cdc33d169d0bebe1f5232d7ec9cb378288af6.tar.gz
gentoo-2-860cdc33d169d0bebe1f5232d7ec9cb378288af6.tar.bz2
gentoo-2-860cdc33d169d0bebe1f5232d7ec9cb378288af6.zip
Added modular X dependencies.
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'games-action/spacetripper-demo')
-rw-r--r--games-action/spacetripper-demo/ChangeLog8
-rw-r--r--games-action/spacetripper-demo/spacetripper-demo-1.ebuild32
2 files changed, 27 insertions, 13 deletions
diff --git a/games-action/spacetripper-demo/ChangeLog b/games-action/spacetripper-demo/ChangeLog
index b4627af8859d..218cb17abac0 100644
--- a/games-action/spacetripper-demo/ChangeLog
+++ b/games-action/spacetripper-demo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/spacetripper-demo
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/spacetripper-demo/ChangeLog,v 1.7 2005/09/21 20:27:11 wolf31o2 Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/spacetripper-demo/ChangeLog,v 1.8 2006/01/11 14:41:08 wolf31o2 Exp $
+
+ 11 Jan 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+ spacetripper-demo-1.ebuild:
+ Added modular X dependencies.
21 Sep 2005; Chris Gianelloni <wolf31o2@gentoo.org>
spacetripper-demo-1.ebuild:
diff --git a/games-action/spacetripper-demo/spacetripper-demo-1.ebuild b/games-action/spacetripper-demo/spacetripper-demo-1.ebuild
index 1b9a7386c691..0c72c7c13f80 100644
--- a/games-action/spacetripper-demo/spacetripper-demo-1.ebuild
+++ b/games-action/spacetripper-demo/spacetripper-demo-1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/spacetripper-demo/spacetripper-demo-1.ebuild,v 1.6 2005/09/21 20:27:11 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/spacetripper-demo/spacetripper-demo-1.ebuild,v 1.7 2006/01/11 14:41:08 wolf31o2 Exp $
inherit eutils games
@@ -14,16 +14,24 @@ SLOT="0"
KEYWORDS="-* ~amd64 x86"
IUSE=""
+RDEPEND="virtual/opengl
+ amd64? (
+ app-emulation/emul-linux-x86-xlibs
+ app-emulation/emul-linux-x86-soundlibs
+ app-emulation/emul-linux-x86-compat
+ app-emulation/emul-linux-x86-sdl )
+ x86? (
+ || (
+ (
+ x11-libs/libX11
+ x11-libs/libXext )
+ virtual/x11 ) )"
+
+GAMES_CHECK_LICENSE="yes"
+S=${WORKDIR}
dir=${GAMES_PREFIX_OPT}/${PN}
Ddir=${D}/${dir}
-S=${WORKDIR}
-
-pkg_setup() {
- check_license POMPOM
- games_pkg_setup
-}
-
src_unpack() {
unpack_makeself
}
@@ -31,6 +39,9 @@ src_unpack() {
src_install() {
exeinto "${dir}"
doexe bin/x86/*
+ # Remove libSDL since we use the system version and our version doesn't
+ # have TEXTRELs in it.
+ rm -f "${Ddir}"/libSDL-1.2.so.0.0.5
sed -i \
-e "s:XYZZY:${dir}:" "${Ddir}/${MY_P}" \
|| die "sed failed"
@@ -39,8 +50,7 @@ src_install() {
doins -r preview run styles || die "doins failed"
doins README license.txt icon.xpm
- dodir "${GAMES_BINDIR}"
- dosym "${dir}/${MY_P}" "${GAMES_BINDIR}/${PN}"
+ games_make_wrapper spacetripper-demo ./spacetripperdemo "${dir}" "${dir}"
prepgamesdirs
}