summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2009-06-03 14:17:13 +0000
committerAlfredo Tupone <tupone@gentoo.org>2009-06-03 14:17:13 +0000
commit3a68ff2c1dae6373aed6b5826bc89584a4f8ffa8 (patch)
tree59278369c4543ed3dde1b8ac834738ead057c47a /games-action/shootingstar
parentMarking quanta-3.5.10 ppc64 for bug 271889 (diff)
downloadgentoo-2-3a68ff2c1dae6373aed6b5826bc89584a4f8ffa8.tar.gz
gentoo-2-3a68ff2c1dae6373aed6b5826bc89584a4f8ffa8.tar.bz2
gentoo-2-3a68ff2c1dae6373aed6b5826bc89584a4f8ffa8.zip
Fix build with gcc-4.4.0 Bug #272374
(Portage version: 2.1.6.11/cvs/Linux x86_64)
Diffstat (limited to 'games-action/shootingstar')
-rw-r--r--games-action/shootingstar/ChangeLog8
-rw-r--r--games-action/shootingstar/files/shootingstar-1.2.0-gcc44.patch10
-rw-r--r--games-action/shootingstar/shootingstar-1.2.0.ebuild16
3 files changed, 25 insertions, 9 deletions
diff --git a/games-action/shootingstar/ChangeLog b/games-action/shootingstar/ChangeLog
index 164b9e67818d..4e12d9fd3609 100644
--- a/games-action/shootingstar/ChangeLog
+++ b/games-action/shootingstar/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/shootingstar
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/shootingstar/ChangeLog,v 1.5 2007/03/14 20:53:28 nyhm Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/shootingstar/ChangeLog,v 1.6 2009/06/03 14:17:13 tupone Exp $
+
+ 03 Jun 2009; Alfredo Tupone <tupone@gentoo.org>
+ +files/shootingstar-1.2.0-gcc44.patch, shootingstar-1.2.0.ebuild:
+ Fix build with gcc-4.4.0 Bug #272374 by Diego Petteno'
14 Mar 2007; Tristan Heaven <nyhm@gentoo.org> shootingstar-1.2.0.ebuild:
Install menu entry, bug #159764
diff --git a/games-action/shootingstar/files/shootingstar-1.2.0-gcc44.patch b/games-action/shootingstar/files/shootingstar-1.2.0-gcc44.patch
new file mode 100644
index 000000000000..179cf09ebda3
--- /dev/null
+++ b/games-action/shootingstar/files/shootingstar-1.2.0-gcc44.patch
@@ -0,0 +1,10 @@
+--- src/engine/dbg.cpp.old 2009-06-03 15:15:46.000000000 +0200
++++ src/engine/dbg.cpp 2009-06-03 16:09:19.000000000 +0200
+@@ -28,6 +28,7 @@
+ #include <vector>
+ #include <map>
+ #include <algorithm>
++#include <cstdio>
+
+ /**********************************************************************
+ * Implementation notes
diff --git a/games-action/shootingstar/shootingstar-1.2.0.ebuild b/games-action/shootingstar/shootingstar-1.2.0.ebuild
index d52c228828f1..b5ab1a9ac9cd 100644
--- a/games-action/shootingstar/shootingstar-1.2.0.ebuild
+++ b/games-action/shootingstar/shootingstar-1.2.0.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/shootingstar/shootingstar-1.2.0.ebuild,v 1.5 2007/03/14 20:53:28 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/shootingstar/shootingstar-1.2.0.ebuild,v 1.6 2009/06/03 14:17:13 tupone Exp $
+
+EAPI=2
inherit eutils games
@@ -18,12 +20,12 @@ DEPEND="virtual/opengl
media-libs/libsdl
media-libs/sdl-mixer
media-libs/sdl-image"
+RDEPEND="${DEPEND}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PV}-gcc34.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${PV}-gcc34.patch
+ "${FILESDIR}"/${P}-gcc44.patch
+)
src_install () {
emake DESTDIR="${D}" install || die "emake install failed"