summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-02-06 21:11:59 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-02-06 21:11:59 +0000
commitf2f61e8ddc40a6986f754c20051e862a2d202694 (patch)
tree285d24dca0b6973df0661007f9273ad0d8e68941 /games-action/d2x-rebirth
parentold (diff)
downloadgentoo-2-f2f61e8ddc40a6986f754c20051e862a2d202694.tar.gz
gentoo-2-f2f61e8ddc40a6986f754c20051e862a2d202694.tar.bz2
gentoo-2-f2f61e8ddc40a6986f754c20051e862a2d202694.zip
version bump wrt #167341
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-action/d2x-rebirth')
-rw-r--r--games-action/d2x-rebirth/ChangeLog10
-rw-r--r--games-action/d2x-rebirth/d2x-rebirth-0.57.3.ebuild90
-rw-r--r--games-action/d2x-rebirth/files/d2x-rebirth-0.57.3-flags.patch21
-rw-r--r--games-action/d2x-rebirth/metadata.xml10
4 files changed, 128 insertions, 3 deletions
diff --git a/games-action/d2x-rebirth/ChangeLog b/games-action/d2x-rebirth/ChangeLog
index 3912fc958d80..f0eb340d48a9 100644
--- a/games-action/d2x-rebirth/ChangeLog
+++ b/games-action/d2x-rebirth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-action/d2x-rebirth
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/d2x-rebirth/ChangeLog,v 1.4 2012/04/25 16:25:14 jlec Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/d2x-rebirth/ChangeLog,v 1.5 2013/02/06 21:11:58 hasufell Exp $
+
+*d2x-rebirth-0.57.3 (06 Feb 2013)
+
+ 06 Feb 2013; Julian Ospald <hasufell@gentoo.org> +d2x-rebirth-0.57.3.ebuild,
+ +files/d2x-rebirth-0.57.3-flags.patch:
+ version bump wrt #167341
25 Apr 2012; Justin Lecher <jlec@gentoo.org> d2x-rebirth-0.50.ebuild:
Drop unnessecary die
diff --git a/games-action/d2x-rebirth/d2x-rebirth-0.57.3.ebuild b/games-action/d2x-rebirth/d2x-rebirth-0.57.3.ebuild
new file mode 100644
index 000000000000..dd3277b8cd98
--- /dev/null
+++ b/games-action/d2x-rebirth/d2x-rebirth-0.57.3.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/d2x-rebirth/d2x-rebirth-0.57.3.ebuild,v 1.1 2013/02/06 21:11:58 hasufell Exp $
+
+EAPI=5
+
+inherit eutils scons-utils games
+
+DV=2
+MY_P=${PN}_v${PV}-src
+DESCRIPTION="Descent Rebirth - enhanced Descent ${DV} engine"
+HOMEPAGE="http://www.dxx-rebirth.com/"
+SRC_URI="mirror://sourceforge/dxx-rebirth/${MY_P}.tar.gz
+ opl3-musicpack? ( http://www.dxx-rebirth.com/download/dxx/res/d${DV}xr-opl3-music.zip )
+ sc55-musicpack? ( http://www.dxx-rebirth.com/download/dxx/res/d${DV}xr-sc55-music.zip )
+ linguas_de? ( http://www.dxx-rebirth.com/download/dxx/res/d${DV}xr-briefings-ger.zip )"
+
+LICENSE="D1X GPL-2 public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cdinstall debug demo ipv6 linguas_de +music opengl opl3-musicpack sc55-musicpack"
+REQUIRED_USE="?? ( opl3-musicpack sc55-musicpack )
+ opl3-musicpack? ( music )
+ sc55-musicpack? ( music )"
+
+RDEPEND="dev-games/physfs[hog,mvl,zip]
+ media-libs/libsdl[X,audio,joystick,opengl?,video]
+ music? (
+ media-libs/sdl-mixer[timidity,vorbis]
+ )
+ opengl? (
+ virtual/opengl
+ virtual/glu
+ )"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+PDEPEND="cdinstall? ( games-action/descent2-data )
+ demo? ( games-action/descent2-demodata )"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-flags.patch
+
+ DOCS=( {CHANGELOG,COPYING,INSTALL,README,RELEASE-NOTES}.txt )
+ edos2unix ${DOCS[@]}
+}
+
+src_compile() {
+ escons \
+ verbosebuild=1 \
+ sharepath="${GAMES_DATADIR}/d${DV}x" \
+ $(use_scons ipv6) \
+ $(use_scons music sdlmixer) \
+ $(use_scons debug) \
+ $(use_scons opengl) \
+ || die
+}
+
+src_install() {
+ dodoc ${DOCS[@]}
+
+ insinto "${GAMES_DATADIR}/d${DV}x"
+
+ # None of the following zip files need to be extracted.
+ use linguas_de && doins "${DISTDIR}"/d${DV}xr-briefings-ger.zip
+ use opl3-musicpack && doins "${DISTDIR}"/d${DV}xr-opl3-music.zip
+ use sc55-musicpack && doins "${DISTDIR}"/d${DV}xr-sc55-music.zip
+
+ doicon ${PN}.xpm
+
+ dogamesbin ${PN}
+ make_desktop_entry ${PN} "Descent ${DV} Rebirth"
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ if ! use cdinstall ; then
+ echo
+ elog "To play the full game enable USE=\"cdinstall\" or manually "
+ elog "copy the files to ${GAMES_DATADIR}/d${DV}x."
+ elog "See /usr/share/doc/${PF}/INSTALL.txt for details."
+ echo
+ fi
+}
diff --git a/games-action/d2x-rebirth/files/d2x-rebirth-0.57.3-flags.patch b/games-action/d2x-rebirth/files/d2x-rebirth-0.57.3-flags.patch
new file mode 100644
index 000000000000..48533768cf91
--- /dev/null
+++ b/games-action/d2x-rebirth/files/d2x-rebirth-0.57.3-flags.patch
@@ -0,0 +1,21 @@
+--- d2x-rebirth_v0.57.3-src/SConstruct
++++ d2x-rebirth_v0.57.3-src/SConstruct
+@@ -399,7 +399,6 @@
+ env.Append(CPPFLAGS = ['-g'])
+ else:
+ env.Append(CPPDEFINES = ['NDEBUG', 'RELEASE'])
+- env.Append(CPPFLAGS = ['-O2'])
+
+ # profiler?
+ if (profiler == 1):
+@@ -428,8 +427,9 @@
+ print '\n'
+
+ env.Append(CPPDEFINES = [('SHAREPATH', '\\"' + str(sharepath) + '\\"')])
++env.Append(LINKFLAGS = [str(lflags)])
+ # finally building program...
+-env.Program(target=str(target), source = common_sources, LIBS = libs, LINKFLAGS = str(lflags))
++env.Program(target=str(target), source = common_sources, LIBS = libs)
+ if (sys.platform != 'darwin'):
+ env.Install(BIN_DIR, str(target))
+ env.Alias('install', BIN_DIR)
diff --git a/games-action/d2x-rebirth/metadata.xml b/games-action/d2x-rebirth/metadata.xml
index bdc2e243eebd..b85dfd63b081 100644
--- a/games-action/d2x-rebirth/metadata.xml
+++ b/games-action/d2x-rebirth/metadata.xml
@@ -4,6 +4,14 @@
<herd>games</herd>
<use>
<flag name="awe32">Enable AWE32 support</flag>
- <flag name="mpu401">Enable MPU401 music support</flag>
+ <flag name="mpu401">Enable MPU401 music support</flag>
+ <flag name="demo">Install <pkg>games-action/descent2-demodata</pkg> as well</flag>
+ <flag name="music">Support for ingame music</flag>
+ <flag name="linguas_de">Provides German translations for the game's
+ briefings, robot descriptions, and outro of the original campaign</flag>
+ <flag name="opl3-musicpack">Include alternate version of the game's music, recorded
+ with the Yamaha YMF262 OPL3 soundchip</flag>
+ <flag name="sc55-musicpack">Include alternate version of the game's music, recorded
+ with the Roland Sound Canvas SC-55 MIDI module</flag>
</use>
</pkgmetadata>