summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2014-04-14 20:21:42 +0000
committerTom Wijsman <tomwij@gentoo.org>2014-04-14 20:21:42 +0000
commite983cf082c742e092681b54ca2cf278c76228802 (patch)
treed022151d9adbd118a6e481adc49edb5553f0dd6b /eclass
parentLinux patch 3.12.17 (diff)
downloadgentoo-2-e983cf082c742e092681b54ca2cf278c76228802.tar.gz
gentoo-2-e983cf082c742e092681b54ca2cf278c76228802.tar.bz2
gentoo-2-e983cf082c742e092681b54ca2cf278c76228802.zip
Temporarily fix up >=sys-kernel/git-sources-3.15_rc1.ebuild, bug #507656.
Diffstat (limited to 'eclass')
-rw-r--r--eclass/ChangeLog5
-rw-r--r--eclass/kernel-2.eclass29
2 files changed, 32 insertions, 2 deletions
diff --git a/eclass/ChangeLog b/eclass/ChangeLog
index 9fc825c26459..4503d281ee66 100644
--- a/eclass/ChangeLog
+++ b/eclass/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for eclass directory
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/ChangeLog,v 1.1205 2014/04/14 15:45:16 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/ChangeLog,v 1.1206 2014/04/14 20:21:42 tomwij Exp $
+
+ 14 Apr 2014; Tom Wijsman <TomWij@gentoo.org> kernel-2.eclass:
+ Temporarily fix up >=sys-kernel/git-sources-3.15_rc1.ebuild, bug #507656.
14 Apr 2014; Maxim Koltsov <maksbotan@gentoo.org> leechcraft.eclass:
Require at least gcc-4.8 for new LeechCraft packages
diff --git a/eclass/kernel-2.eclass b/eclass/kernel-2.eclass
index 83f84ef0da37..d30ed4b03187 100644
--- a/eclass/kernel-2.eclass
+++ b/eclass/kernel-2.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/kernel-2.eclass,v 1.294 2014/01/18 14:53:07 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/kernel-2.eclass,v 1.295 2014/04/14 20:21:42 tomwij Exp $
# Description: kernel.eclass rewrite for a clean base regarding the 2.6
# series of kernel with back-compatibility for 2.4
@@ -1038,6 +1038,33 @@ unipatch() {
if [ -z "${PATCH_DEPTH}" ]; then PATCH_DEPTH=0; fi
+ ####################################################################
+ # IMPORTANT: This is temporary code to support Linux git 3.15_rc1! #
+ # #
+ # The patch contains a removal of a symlink, followed by addition #
+ # of a file with the same name as the symlink in the same #
+ # location; this causes the dry-run to fail, filed bug #507656. #
+ # #
+ # https://bugs.gentoo.org/show_bug.cgi?id=507656 #
+ ####################################################################
+ if [[ ${PN} == "git-sources" ]] ; then
+ if [[ ${i} == *"/patch-3.15-rc1.patch" ]] ; then
+ ebegin "Applying ${i/*\//} (-p1)"
+ if [ $(patch -p1 --no-backup-if-mismatch -f < ${i} >> ${STDERR_T}) "$?" -eq 0 ]; then
+ eend 0
+ rm ${STDERR_T}
+ break
+ else
+ eend 1
+ eerror "Failed to apply patch ${i/*\//}"
+ eerror "Please attach ${STDERR_T} to any bug you may post."
+ eshopts_pop
+ die "Failed to apply ${i/*\//} on patch depth 1."
+ fi
+ fi
+ fi
+ ####################################################################
+
while [ ${PATCH_DEPTH} -lt 5 ]; do
echo "Attempting Dry-run:" >> ${STDERR_T}
echo "cmd: patch -p${PATCH_DEPTH} --no-backup-if-mismatch --dry-run -f < ${i}" >> ${STDERR_T}