summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-12-04 15:00:47 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-12-04 15:00:47 +0000
commitc2356e0b895db283f5205f66be9a73e980ef8f06 (patch)
tree755687a82b82f76ffeeae2daa56373e3f990e879 /eclass
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-c2356e0b895db283f5205f66be9a73e980ef8f06.tar.gz
gentoo-2-c2356e0b895db283f5205f66be9a73e980ef8f06.tar.bz2
gentoo-2-c2356e0b895db283f5205f66be9a73e980ef8f06.zip
Remove the libgcj pkg-config file when cross-compiling.
This solves the collision problem with sys-devel/gcc[gcj]; since the pkg-config does not seem to be used for cross-compiling this should be enough.
Diffstat (limited to 'eclass')
-rw-r--r--eclass/toolchain.eclass13
1 files changed, 9 insertions, 4 deletions
diff --git a/eclass/toolchain.eclass b/eclass/toolchain.eclass
index 27d21554b922..67ac91654922 100644
--- a/eclass/toolchain.eclass
+++ b/eclass/toolchain.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/toolchain.eclass,v 1.410 2009/10/19 01:49:36 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/toolchain.eclass,v 1.411 2009/12/04 15:00:47 flameeyes Exp $
#
# Maintainer: Toolchain Ninjas <toolchain@gentoo.org>
@@ -1920,11 +1920,16 @@ gcc_slot_java() {
[[ -f ${D}${PREFIX}/lib/libgcj.spec ]] && \
mv -f "${D}"${PREFIX}/lib/libgcj.spec "${D}"${LIBPATH}/libgcj.spec
- # SLOT up libgcj.pc (and let gcc-config worry about links)
local libgcj=$(find "${D}"${PREFIX}/lib/pkgconfig/ -name 'libgcj*.pc')
if [[ -n ${libgcj} ]] ; then
- sed -i "/^libdir=/s:=.*:=${LIBPATH}:" "${libgcj}"
- mv "${libgcj}" "${D}"/usr/lib/pkgconfig/libgcj-${GCC_PV}.pc || die
+ if is_crosscompile ; then
+ # Simply remove the libgcj.pc file for cross-compilers
+ rm "${libgcj}" || die
+ else
+ # SLOT up libgcj.pc (and let gcc-config worry about links)
+ sed -i "/^libdir=/s:=.*:=${LIBPATH}:" "${libgcj}"
+ mv "${libgcj}" "${D}"/usr/lib/pkgconfig/libgcj-${GCC_PV}.pc || die
+ fi
fi
# Rename jar because it could clash with Kaffe's jar if this gcc is