summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2006-04-01 15:58:29 +0000
committerMichael Cummings <mcummings@gentoo.org>2006-04-01 15:58:29 +0000
commit8720d20c3304a73ca28c44709ecb32c9798cd14b (patch)
tree2cfb3c5d89f500045d0af0b33aa3bfa26a3ae251 /eclass/perl-app.eclass
parentRestricted test feature (diff)
downloadgentoo-2-8720d20c3304a73ca28c44709ecb32c9798cd14b.tar.gz
gentoo-2-8720d20c3304a73ca28c44709ecb32c9798cd14b.tar.bz2
gentoo-2-8720d20c3304a73ca28c44709ecb32c9798cd14b.zip
Bug 128364, note that perldoc rules
Diffstat (limited to 'eclass/perl-app.eclass')
-rw-r--r--eclass/perl-app.eclass14
1 files changed, 9 insertions, 5 deletions
diff --git a/eclass/perl-app.eclass b/eclass/perl-app.eclass
index d7fc9d178a15..c8ced4b76f16 100644
--- a/eclass/perl-app.eclass
+++ b/eclass/perl-app.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/perl-app.eclass,v 1.1 2005/11/27 22:22:22 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/perl-app.eclass,v 1.2 2006/04/01 15:58:29 mcummings Exp $
#
# Author: Michael Cummings <mcummings@gentoo.org>
@@ -23,7 +23,12 @@ perl-app_src_prep() {
SRC_PREP="yes"
- if [ -f ${S}/Build.PL ] && [ "${USE_BUILDER}" == "yes" ]; then
+ if [ -f ${S}/Makefile.PL ]; then
+ einfo "Using ExtUtils::MakeMaker"
+ #perl Makefile.PL ${myconf} \
+ perl Makefile.PL ${myconf} INSTALLMAN3DIR='none'\
+ PREFIX=/usr INSTALLDIRS=vendor DESTDIR=${D}
+ elif [ -f ${S}/Build.PL ] && [ "${USE_BUILDER}" == "yes" ]; then
einfo "Using Module::Build"
if [ -z ${BUILDER_VER} ]; then
eerror
@@ -37,9 +42,8 @@ perl-app_src_prep() {
perl ${S}/Build.PL installdirs=vendor destdir=${D}
fi
else
- einfo "Using ExtUtils::MakeMaker"
- perl Makefile.PL ${myconf} \
- prefiX=/usr INSTALLDIRS=vendor DESTDIR=${D}
+ einfo "No Make or Build file detect..."
+ return
fi
}