summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-07-16 14:29:39 +0000
committerMichał Górny <mgorny@gentoo.org>2015-07-16 14:29:39 +0000
commitcb7fcc88a834100d0e3e798f40cc68c395f40e85 (patch)
tree13933731262b4e859b9737633de45d70b48ee597 /eclass/distutils-r1.eclass
parentStable on alpha, bug 551602 (diff)
downloadgentoo-2-cb7fcc88a834100d0e3e798f40cc68c395f40e85.tar.gz
gentoo-2-cb7fcc88a834100d0e3e798f40cc68c395f40e85.tar.bz2
gentoo-2-cb7fcc88a834100d0e3e798f40cc68c395f40e85.zip
Forbid also installing "examples" package, bug #555038.
Diffstat (limited to 'eclass/distutils-r1.eclass')
-rw-r--r--eclass/distutils-r1.eclass12
1 files changed, 8 insertions, 4 deletions
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index 575eba41444c..b3b15ba916c7 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/distutils-r1.eclass,v 1.114 2015/07/04 15:26:17 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/distutils-r1.eclass,v 1.115 2015/07/16 14:29:39 mgorny Exp $
# @ECLASS: distutils-r1
# @MAINTAINER:
@@ -549,9 +549,13 @@ distutils-r1_python_install() {
esetup.py install --root="${root}" "${args[@]}"
- if [[ -d ${root}$(python_get_sitedir)/tests ]]; then
- die "Package installs 'tests' package, file collisions likely."
- fi
+ local forbidden_package_names=( examples test tests )
+ local p
+ for p in "${forbidden_package_names[@]}"; do
+ if [[ -d ${root}$(python_get_sitedir)/${p} ]]; then
+ die "Package installs '${p}' package which is forbidden and likely a bug in the build system."
+ fi
+ done
if [[ -d ${root}/usr/$(get_libdir)/pypy/share ]]; then
eqawarn "Package installs 'share' in PyPy prefix, see bug #465546."
fi