summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2014-07-30 19:01:02 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2014-07-30 19:01:02 +0000
commitc147eeb6f56d85a2700cb905730e6c94cb44751c (patch)
treeb7754a8c85c033630428ea024fa5c89450c4ac6b /eclass/apache-2.eclass
parentamd64 stable for bug #518596. (diff)
downloadgentoo-2-c147eeb6f56d85a2700cb905730e6c94cb44751c.tar.gz
gentoo-2-c147eeb6f56d85a2700cb905730e6c94cb44751c.tar.bz2
gentoo-2-c147eeb6f56d85a2700cb905730e6c94cb44751c.zip
Handle grsec TPE to ensure apache can compile. $T is group-writable, owned by portage, and TPE blocks that.
Diffstat (limited to 'eclass/apache-2.eclass')
-rw-r--r--eclass/apache-2.eclass5
1 files changed, 4 insertions, 1 deletions
diff --git a/eclass/apache-2.eclass b/eclass/apache-2.eclass
index dc9fcf8e92a4..ad536e0618c6 100644
--- a/eclass/apache-2.eclass
+++ b/eclass/apache-2.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/apache-2.eclass,v 1.36 2014/05/22 13:58:46 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/apache-2.eclass,v 1.37 2014/07/30 19:01:02 robbat2 Exp $
# @ECLASS: apache-2.eclass
# @MAINTAINER:
@@ -448,6 +448,9 @@ apache-2_src_prepare() {
sed -i -e '/sinclude/d' configure.in
AT_M4DIR=build eautoreconf
+ # ${T} must be not group-writable, else grsec TPE will block it
+ chmod g-w "${T}"
+
# This package really should upgrade to using pcre's .pc file.
cat <<-\EOF >"${T}"/pcre-config
#!/bin/sh