summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2012-02-17 18:08:32 +0000
committerDavide Pesavento <pesa@gentoo.org>2012-02-17 18:08:32 +0000
commit9dbd885b70a04e636d1e378ab35c27aeb47dff03 (patch)
tree47b3b4aee01eb8e1b67319f60f8f7f15c7b386d0 /dev-vcs
parentStable on alpha, bug #401997 (diff)
downloadgentoo-2-9dbd885b70a04e636d1e378ab35c27aeb47dff03.tar.gz
gentoo-2-9dbd885b70a04e636d1e378ab35c27aeb47dff03.tar.bz2
gentoo-2-9dbd885b70a04e636d1e378ab35c27aeb47dff03.zip
Version bump (bug #396705), also fixes bug #373689. Install icon and desktop file (bug #271953). Remove old.
(Portage version: 2.2.0_alpha86/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/qgit/ChangeLog11
-rw-r--r--dev-vcs/qgit/metadata.xml4
-rw-r--r--dev-vcs/qgit/qgit-2.2.ebuild39
-rw-r--r--dev-vcs/qgit/qgit-2.4.ebuild30
4 files changed, 43 insertions, 41 deletions
diff --git a/dev-vcs/qgit/ChangeLog b/dev-vcs/qgit/ChangeLog
index 3d19456ded1c..e2803680b8a6 100644
--- a/dev-vcs/qgit/ChangeLog
+++ b/dev-vcs/qgit/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-vcs/qgit
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/qgit/ChangeLog,v 1.1 2011/02/10 21:35:11 ulm Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/qgit/ChangeLog,v 1.2 2012/02/17 18:08:32 pesa Exp $
+
+*qgit-2.4 (17 Feb 2012)
+
+ 17 Feb 2012; Davide Pesavento <pesa@gentoo.org> +qgit-2.4.ebuild,
+ -qgit-2.2.ebuild, metadata.xml:
+ Version bump (bug #396705), also fixes bug #373689. Install icon and desktop
+ file (bug #271953). Remove old.
10 Feb 2011; Ulrich Mueller <ulm@gentoo.org> +qgit-2.2.ebuild,
+qgit-2.3.ebuild, +qgit-2.3-r1.ebuild, +metadata.xml:
diff --git a/dev-vcs/qgit/metadata.xml b/dev-vcs/qgit/metadata.xml
index 289b41e5daab..e591418472cb 100644
--- a/dev-vcs/qgit/metadata.xml
+++ b/dev-vcs/qgit/metadata.xml
@@ -5,4 +5,8 @@
<email>jokey@gentoo.org</email>
<name>Markus Ullmann</name>
</maintainer>
+ <maintainer>
+ <email>pesa@gentoo.org</email>
+ <name>Davide Pesavento</name>
+ </maintainer>
</pkgmetadata>
diff --git a/dev-vcs/qgit/qgit-2.2.ebuild b/dev-vcs/qgit/qgit-2.2.ebuild
deleted file mode 100644
index 43d0cee08e71..000000000000
--- a/dev-vcs/qgit/qgit-2.2.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/qgit/qgit-2.2.ebuild,v 1.1 2011/02/10 21:35:11 ulm Exp $
-
-EAPI="1"
-
-inherit qt4
-
-MY_PV=${PV//_/}
-MY_P=${PN}-${MY_PV}
-
-DESCRIPTION="GUI interface for git/cogito SCM"
-HOMEPAGE="http://digilander.libero.it/mcostalba/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="2"
-KEYWORDS="amd64 ~ppc ~ppc64 x86"
-IUSE=""
-
-DEPEND="x11-libs/qt-gui:4"
-RDEPEND="${DEPEND}
- >=dev-vcs/git-1.5.3"
-
-S="${WORKDIR}/${PN}"
-
-src_compile() {
- eqmake4 || die "eqmake failed"
- emake || die "emake failed"
-}
-
-src_install() {
- newbin bin/qgit qgit4
- dodoc README
-}
-
-pkg_postinst() {
- elog "This is installed as qgit4 now so you can still use 1.5 series (Qt3-based)"
-}
diff --git a/dev-vcs/qgit/qgit-2.4.ebuild b/dev-vcs/qgit/qgit-2.4.ebuild
new file mode 100644
index 000000000000..489792f28a65
--- /dev/null
+++ b/dev-vcs/qgit/qgit-2.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/qgit/qgit-2.4.ebuild,v 1.1 2012/02/17 18:08:32 pesa Exp $
+
+EAPI=4
+
+inherit eutils qt4-r2
+
+DESCRIPTION="Qt4 GUI for git repositories"
+HOMEPAGE="http://libre.tibirna.org/projects/qgit/wiki/QGit"
+SRC_URI="http://dev.gentoo.org/~pesa/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+DEPEND="x11-libs/qt-gui:4"
+RDEPEND="${DEPEND}
+ >=dev-vcs/git-1.6
+"
+
+S=${WORKDIR}/redivivus
+
+src_install() {
+ newbin bin/qgit qgit4
+ newicon src/resources/qgit.png qgit4.png
+ make_desktop_entry qgit4 QGit qgit4
+ dodoc README
+}