summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2014-01-06 20:44:04 +0000
committerLars Wendler <polynomial-c@gentoo.org>2014-01-06 20:44:04 +0000
commit7c97037e3d27a956d53b97f4f818ea25e1c42350 (patch)
tree4626234c28b099d5c7bec4a4cd22eca860f83baf /dev-vcs
parentVersion bump. (diff)
downloadgentoo-2-7c97037e3d27a956d53b97f4f818ea25e1c42350.tar.gz
gentoo-2-7c97037e3d27a956d53b97f4f818ea25e1c42350.tar.bz2
gentoo-2-7c97037e3d27a956d53b97f4f818ea25e1c42350.zip
Renamed "webdav-serf" USE flag to "http"
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/subversion/ChangeLog6
-rw-r--r--dev-vcs/subversion/metadata.xml1
-rw-r--r--dev-vcs/subversion/subversion-1.8.5.ebuild14
3 files changed, 13 insertions, 8 deletions
diff --git a/dev-vcs/subversion/ChangeLog b/dev-vcs/subversion/ChangeLog
index 879b1feb0107..d6b8f0a4ae89 100644
--- a/dev-vcs/subversion/ChangeLog
+++ b/dev-vcs/subversion/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-vcs/subversion
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/subversion/ChangeLog,v 1.155 2014/01/06 19:32:54 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/subversion/ChangeLog,v 1.156 2014/01/06 20:44:04 polynomial-c Exp $
+
+ 06 Jan 2014; Lars Wendler <polynomial-c@gentoo.org> subversion-1.8.5.ebuild,
+ metadata.xml:
+ Renamed "webdav-serf" USE flag to "http".
*subversion-1.8.5 (06 Jan 2014)
diff --git a/dev-vcs/subversion/metadata.xml b/dev-vcs/subversion/metadata.xml
index 6f92b19ee433..4cda7ae93b59 100644
--- a/dev-vcs/subversion/metadata.xml
+++ b/dev-vcs/subversion/metadata.xml
@@ -9,6 +9,7 @@
<flag name="ctypes-python">Build and install Ctypes Python bindings</flag>
<flag name="dso">Enable runtime module search</flag>
<flag name="extras">Install extra scripts (examples, tools, hooks)</flag>
+ <flag name="http">Enable http support using <pkg>net-libs/serf</pkg></flag>
<flag name="webdav-neon">Enable WebDAV support using <pkg>net-libs/neon</pkg></flag>
<flag name="webdav-serf">Enable WebDAV support using <pkg>net-libs/serf</pkg></flag>
</use>
diff --git a/dev-vcs/subversion/subversion-1.8.5.ebuild b/dev-vcs/subversion/subversion-1.8.5.ebuild
index 49f9a86e1198..81538c3c9cae 100644
--- a/dev-vcs/subversion/subversion-1.8.5.ebuild
+++ b/dev-vcs/subversion/subversion-1.8.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/subversion/subversion-1.8.5.ebuild,v 1.1 2014/01/06 19:32:53 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/subversion/subversion-1.8.5.ebuild,v 1.2 2014/01/06 20:44:04 polynomial-c Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -18,7 +18,7 @@ S="${WORKDIR}/${MY_P}"
LICENSE="Subversion GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="apache2 berkdb ctypes-python debug doc +dso extras gnome-keyring java kde nls perl python ruby sasl test vim-syntax +webdav-serf"
+IUSE="apache2 berkdb ctypes-python debug doc +dso extras gnome-keyring +http java kde nls perl python ruby sasl test vim-syntax"
COMMON_DEPEND=">=dev-db/sqlite-3.7.12
>=dev-libs/apr-1.3:1
@@ -35,7 +35,7 @@ COMMON_DEPEND=">=dev-db/sqlite-3.7.12
ruby? ( >=dev-lang/ruby-1.9.3:1.9
dev-ruby/rubygems[ruby_targets_ruby19] )
sasl? ( dev-libs/cyrus-sasl )
- webdav-serf? ( >=net-libs/serf-1.2.1 )"
+ http? ( >=net-libs/serf-1.2.1 )"
RDEPEND="${COMMON_DEPEND}
apache2? ( www-servers/apache[apache2_modules_dav] )
java? ( >=virtual/jre-1.5 )
@@ -52,7 +52,7 @@ DEPEND="${COMMON_DEPEND}
java? ( >=virtual/jdk-1.5 )
kde? ( virtual/pkgconfig )
nls? ( sys-devel/gettext )
- webdav-serf? ( virtual/pkgconfig )"
+ http? ( virtual/pkgconfig )"
REQUIRED_USE="
ctypes-python? ( ${PYTHON_REQUIRED_USE} )
@@ -92,10 +92,10 @@ pkg_setup() {
java-pkg-opt-2_pkg_setup
- if ! use webdav-serf ; then
+ if ! use http ; then
ewarn "WebDAV support is disabled. You need WebDAV to"
ewarn "access repositories through the HTTP protocol."
- ewarn "Consider enabling \"webdav-serf\" USE flag"
+ ewarn "Consider enabling \"http\" USE flag"
echo -ne "\a"
fi
@@ -204,7 +204,7 @@ src_configure() {
$(use_with kde kwallet) \
$(use_enable nls) \
$(use_with sasl) \
- $(use_with webdav-serf serf "${EPREFIX}/usr") \
+ $(use_with http serf "${EPREFIX}/usr") \
${myconf} \
--with-apr="${EPREFIX}/usr/bin/apr-1-config" \
--with-apr-util="${EPREFIX}/usr/bin/apu-1-config" \