summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-08-10 19:07:01 +0000
committerTim Harder <radhermit@gentoo.org>2013-08-10 19:07:01 +0000
commit6d970483abd558877dfff8d5410170ce8fc0493c (patch)
tree280dd05badb6eb6b2367581085d45904d37ac48d /dev-vcs
parentconvert to multilib (diff)
downloadgentoo-2-6d970483abd558877dfff8d5410170ce8fc0493c.tar.gz
gentoo-2-6d970483abd558877dfff8d5410170ce8fc0493c.tar.bz2
gentoo-2-6d970483abd558877dfff8d5410170ce8fc0493c.zip
Version bump and fix pkgconfig dep.
(Portage version: 2.2.0_alpha196/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/tig/ChangeLog8
-rw-r--r--dev-vcs/tig/tig-1.1.ebuild9
-rw-r--r--dev-vcs/tig/tig-1.2.ebuild32
3 files changed, 44 insertions, 5 deletions
diff --git a/dev-vcs/tig/ChangeLog b/dev-vcs/tig/ChangeLog
index 0e1ab4251602..df4e03301de4 100644
--- a/dev-vcs/tig/ChangeLog
+++ b/dev-vcs/tig/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-vcs/tig
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tig/ChangeLog,v 1.21 2013/06/15 20:43:50 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tig/ChangeLog,v 1.22 2013/08/10 19:07:01 radhermit Exp $
+
+*tig-1.2 (10 Aug 2013)
+
+ 10 Aug 2013; Tim Harder <radhermit@gentoo.org> tig-1.1.ebuild,
+ +tig-1.2.ebuild:
+ Version bump and fix pkgconfig dep.
15 Jun 2013; Justin Lecher <jlec@gentoo.org> tig-1.1.ebuild, metadata.xml:
Build correctly with ncurses[tinfo]
diff --git a/dev-vcs/tig/tig-1.1.ebuild b/dev-vcs/tig/tig-1.1.ebuild
index 867626fdef6c..f83b5c58c8c4 100644
--- a/dev-vcs/tig/tig-1.1.ebuild
+++ b/dev-vcs/tig/tig-1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tig/tig-1.1.ebuild,v 1.4 2013/06/15 20:43:50 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tig/tig-1.1.ebuild,v 1.5 2013/08/10 19:07:01 radhermit Exp $
EAPI=4
@@ -15,9 +15,10 @@ SLOT="0"
KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE=""
-DEPEND="sys-libs/ncurses"
-RDEPEND="${DEPEND}
- virtual/pkgconfig
+CDEPEND="sys-libs/ncurses"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
dev-vcs/git"
src_configure() {
diff --git a/dev-vcs/tig/tig-1.2.ebuild b/dev-vcs/tig/tig-1.2.ebuild
new file mode 100644
index 000000000000..54841bd0937e
--- /dev/null
+++ b/dev-vcs/tig/tig-1.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tig/tig-1.2.ebuild,v 1.1 2013/08/10 19:07:01 radhermit Exp $
+
+EAPI=5
+
+inherit bash-completion-r1 toolchain-funcs
+
+DESCRIPTION="Tig: text mode interface for git"
+HOMEPAGE="http://jonas.nitro.dk/tig/"
+SRC_URI="http://jonas.nitro.dk/tig/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+
+CDEPEND="sys-libs/ncurses"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ dev-vcs/git"
+
+src_configure() {
+ econf CURSES_LIB="$($(tc-getPKG_CONFIG) --libs ncursesw)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-doc-man
+ dodoc BUGS NEWS
+ dohtml manual.html README.html
+ newbashcomp contrib/tig-completion.bash ${PN}
+}