summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-15 17:35:42 +0000
committerJustin Lecher <jlec@gentoo.org>2010-06-15 17:35:42 +0000
commit6450c0ef4a6cd7e96e4ed5fe3c8f0b02c9e09021 (patch)
tree014e24b2c7297199d95e0d3d0c5723dd12508d6e /dev-vcs/tig
parentold (diff)
downloadgentoo-2-6450c0ef4a6cd7e96e4ed5fe3c8f0b02c9e09021.tar.gz
gentoo-2-6450c0ef4a6cd7e96e4ed5fe3c8f0b02c9e09021.tar.bz2
gentoo-2-6450c0ef4a6cd7e96e4ed5fe3c8f0b02c9e09021.zip
QA, cleanup ebuilds, Version Bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs/tig')
-rw-r--r--dev-vcs/tig/ChangeLog8
-rw-r--r--dev-vcs/tig/tig-0.15.ebuild14
-rw-r--r--dev-vcs/tig/tig-0.16.ebuild26
3 files changed, 38 insertions, 10 deletions
diff --git a/dev-vcs/tig/ChangeLog b/dev-vcs/tig/ChangeLog
index bb53aecce0f5..1794b92362fb 100644
--- a/dev-vcs/tig/ChangeLog
+++ b/dev-vcs/tig/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-vcs/tig
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tig/ChangeLog,v 1.1 2010/06/15 16:07:36 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tig/ChangeLog,v 1.2 2010/06/15 17:35:42 jlec Exp $
+
+*tig-0.16 (15 Jun 2010)
+
+ 15 Jun 2010; Justin Lecher <jlec@gentoo.org> tig-0.15.ebuild,
+ +tig-0.16.ebuild:
+ QA, cleanup ebuilds, Version Bump
15 Jun 2010; Justin Lecher <jlec@gentoo.org> +tig-0.14.1.ebuild,
+tig-0.15.ebuild, +metadata.xml:
diff --git a/dev-vcs/tig/tig-0.15.ebuild b/dev-vcs/tig/tig-0.15.ebuild
index 398214595517..77717f91acae 100644
--- a/dev-vcs/tig/tig-0.15.ebuild
+++ b/dev-vcs/tig/tig-0.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tig/tig-0.15.ebuild,v 1.1 2010/06/15 16:07:36 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tig/tig-0.15.ebuild,v 1.2 2010/06/15 17:35:42 jlec Exp $
inherit bash-completion
@@ -17,15 +17,11 @@ DEPEND="sys-libs/ncurses"
RDEPEND="${DEPEND}
dev-vcs/git"
-src_compile() {
- econf CFLAGS="${CFLAGS}" || die "econf failed"
- emake CFLAGS="${CFLAGS}" || die "emake failed"
-}
src_install() {
- einstall || die "einstall failed"
- doman tig.1 tigrc.5
- dodoc manual.txt
- dohtml manual.html
+ emake DESTDIR="${D}" install || die "einstall failed"
+ doman tig.1 tigrc.5 || die
+ dodoc manual.txt || die
+ dohtml manual.html || die
dobashcompletion contrib/tig-completion.bash
}
diff --git a/dev-vcs/tig/tig-0.16.ebuild b/dev-vcs/tig/tig-0.16.ebuild
new file mode 100644
index 000000000000..8195651cd6b3
--- /dev/null
+++ b/dev-vcs/tig/tig-0.16.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tig/tig-0.16.ebuild,v 1.1 2010/06/15 17:35:42 jlec Exp $
+
+inherit bash-completion
+
+DESCRIPTION="Tig: text mode interface for git"
+HOMEPAGE="http://jonas.nitro.dk/tig/"
+SRC_URI="http://jonas.nitro.dk/tig/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}
+ dev-vcs/git"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "einstall failed"
+ doman tig.1 tigrc.5 || die
+ dodoc manual.txt || die
+ dohtml manual.html || die
+ dobashcompletion contrib/tig-completion.bash
+}