summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2012-10-01 09:04:47 +0000
committerDavide Pesavento <pesa@gentoo.org>2012-10-01 09:04:47 +0000
commit66159f761cc7369af51f2b2dd0240b6b071c8db5 (patch)
treea420e3992b558f605868d83d7851d65612d63ba0 /dev-vcs/qgit
parentVersion bump. (diff)
downloadgentoo-2-66159f761cc7369af51f2b2dd0240b6b071c8db5.tar.gz
gentoo-2-66159f761cc7369af51f2b2dd0240b6b071c8db5.tar.bz2
gentoo-2-66159f761cc7369af51f2b2dd0240b6b071c8db5.zip
Version bump.
(Portage version: 2.2.0_alpha134/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs/qgit')
-rw-r--r--dev-vcs/qgit/ChangeLog8
-rw-r--r--dev-vcs/qgit/qgit-2.5.ebuild30
2 files changed, 36 insertions, 2 deletions
diff --git a/dev-vcs/qgit/ChangeLog b/dev-vcs/qgit/ChangeLog
index e3326f9485c0..40cb8b8fa7fc 100644
--- a/dev-vcs/qgit/ChangeLog
+++ b/dev-vcs/qgit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-vcs/qgit
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/qgit/ChangeLog,v 1.8 2012/03/25 20:01:51 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/qgit/ChangeLog,v 1.9 2012/10/01 09:04:47 pesa Exp $
+
+*qgit-2.5 (01 Oct 2012)
+
+ 01 Oct 2012; Davide Pesavento <pesa@gentoo.org> +qgit-2.5.ebuild:
+ Version bump.
25 Mar 2012; Davide Pesavento <pesa@gentoo.org> -qgit-2.3-r1.ebuild,
-qgit-2.3.ebuild:
@@ -247,4 +252,3 @@
30 Oct 2005; Fernando J. Pereda <ferdy@gentoo.org> +metadata.xml,
+qgit-0.96.1.ebuild:
initial commit. fixes #110072
-
diff --git a/dev-vcs/qgit/qgit-2.5.ebuild b/dev-vcs/qgit/qgit-2.5.ebuild
new file mode 100644
index 000000000000..a2cf70d06818
--- /dev/null
+++ b/dev-vcs/qgit/qgit-2.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/qgit/qgit-2.5.ebuild,v 1.1 2012/10/01 09:04:47 pesa Exp $
+
+EAPI=4
+
+inherit eutils qt4-r2
+
+DESCRIPTION="Qt4 GUI for git repositories"
+HOMEPAGE="http://libre.tibirna.org/projects/qgit/wiki/QGit"
+SRC_URI="http://libre.tibirna.org/attachments/download/9/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+DEPEND="x11-libs/qt-gui:4"
+RDEPEND="${DEPEND}
+ >=dev-vcs/git-1.6
+"
+
+S=${WORKDIR}/redivivus
+
+src_install() {
+ newbin bin/qgit qgit4
+ newicon src/resources/qgit.png qgit4.png
+ make_desktop_entry qgit4 QGit qgit4
+ dodoc README
+}