summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-02-10 22:57:03 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-02-10 22:57:03 +0000
commit3de501bdfe7ff96f769cebf632924666406f8bb4 (patch)
treef9965c310d11704d0d577494005dc15b57e0eed8 /dev-vcs/hgview
parentRevert previous commit to python eclass, breaks any ebuild using PYTHON_DEPEN... (diff)
downloadgentoo-2-3de501bdfe7ff96f769cebf632924666406f8bb4.tar.gz
gentoo-2-3de501bdfe7ff96f769cebf632924666406f8bb4.tar.bz2
gentoo-2-3de501bdfe7ff96f769cebf632924666406f8bb4.zip
Version bump. Bug #402657
(Portage version: 2.2.0_alpha85/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs/hgview')
-rw-r--r--dev-vcs/hgview/ChangeLog9
-rw-r--r--dev-vcs/hgview/hgview-1.5.0.ebuild47
2 files changed, 54 insertions, 2 deletions
diff --git a/dev-vcs/hgview/ChangeLog b/dev-vcs/hgview/ChangeLog
index 921872ab1474..bd3016e388e0 100644
--- a/dev-vcs/hgview/ChangeLog
+++ b/dev-vcs/hgview/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-vcs/hgview
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hgview/ChangeLog,v 1.4 2011/03/03 21:39:34 arfrever Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hgview/ChangeLog,v 1.5 2012/02/10 22:57:03 hwoarang Exp $
+
+*hgview-1.5.0 (10 Feb 2012)
+
+ 10 Feb 2012; Markos Chandras <hwoarang@gentoo.org> +hgview-1.5.0.ebuild:
+ Version bump. Bug #402657
*hgview-1.2.1 (03 Mar 2011)
diff --git a/dev-vcs/hgview/hgview-1.5.0.ebuild b/dev-vcs/hgview/hgview-1.5.0.ebuild
new file mode 100644
index 000000000000..9a68d4ea84c2
--- /dev/null
+++ b/dev-vcs/hgview/hgview-1.5.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hgview/hgview-1.5.0.ebuild,v 1.1 2012/02/10 22:57:03 hwoarang Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.* *-jython"
+
+inherit distutils
+
+DESCRIPTION="PyQt4-based Mercurial log navigator"
+HOMEPAGE="http://www.logilab.org/project/hgview http://pypi.python.org/pypi/hgview"
+SRC_URI="http://ftp.logilab.org/pub/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="dev-python/docutils
+ dev-python/egenix-mx-base
+ dev-python/PyQt4[X]
+ dev-python/qscintilla-python
+ dev-vcs/mercurial
+ doc? ( app-text/asciidoc )"
+RDEPEND="${DEPEND}"
+
+PYTHON_MODNAME="hgext/hgview.py hgviewlib"
+
+src_prepare() {
+ distutils_src_prepare
+
+ # Fix mercurial extension install path.
+ if ! use doc; then
+ sed -e '/make -C doc/d' -i setup.py || die "sed failed"
+ sed -e '/share\/man\/man1/,+1 d' -i hgviewlib/__pkginfo__.py || die "sed failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ # Install the mercurial extension config.
+ insinto /etc/mercurial/hgrc.d || die "insinto failed"
+ doins "${FILESDIR}/hgview.rc" || die "doins failed"
+}