summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-01-21 16:09:57 +0000
committerIan Delaney <idella4@gentoo.org>2014-01-21 16:09:57 +0000
commit0bb31245bb2914a042a62566ea822ad86499717c (patch)
tree1a39378064e85474707e1969dba8817c30472d30 /dev-vcs/hg-git
parentWhitespace. (diff)
downloadgentoo-2-0bb31245bb2914a042a62566ea822ad86499717c.tar.gz
gentoo-2-0bb31245bb2914a042a62566ea822ad86499717c.tar.bz2
gentoo-2-0bb31245bb2914a042a62566ea822ad86499717c.zip
revbump; convert to distutils-r1, patch by Nikoli in Bug #497300, ack by djc
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-vcs/hg-git')
-rw-r--r--dev-vcs/hg-git/ChangeLog7
-rw-r--r--dev-vcs/hg-git/hg-git-0.5.0-r1.ebuild25
2 files changed, 31 insertions, 1 deletions
diff --git a/dev-vcs/hg-git/ChangeLog b/dev-vcs/hg-git/ChangeLog
index fb44c437dc87..a0617c3eec1e 100644
--- a/dev-vcs/hg-git/ChangeLog
+++ b/dev-vcs/hg-git/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-vcs/hg-git
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hg-git/ChangeLog,v 1.50 2014/01/06 09:54:27 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hg-git/ChangeLog,v 1.51 2014/01/21 16:09:57 idella4 Exp $
+
+*hg-git-0.5.0-r1 (21 Jan 2014)
+
+ 21 Jan 2014; Ian Delaney <idella4@gentoo.org> +hg-git-0.5.0-r1.ebuild:
+ revbump; convert to distutils-r1, patch by Nikoli in Bug #497300, ack by djc
*hg-git-0.5.0 (06 Jan 2014)
diff --git a/dev-vcs/hg-git/hg-git-0.5.0-r1.ebuild b/dev-vcs/hg-git/hg-git-0.5.0-r1.ebuild
new file mode 100644
index 000000000000..e102c9f2e951
--- /dev/null
+++ b/dev-vcs/hg-git/hg-git-0.5.0-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hg-git/hg-git-0.5.0-r1.ebuild,v 1.1 2014/01/21 16:09:57 idella4 Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="push to and pull from a Git repository using Mercurial"
+HOMEPAGE="http://hg-git.github.io https://pypi.python.org/pypi/hg-git"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="
+ >=dev-vcs/mercurial-1.9.3[${PYTHON_USEDEP}]
+ >=dev-python/dulwich-0.9.4[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"