summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-07-11 15:37:27 +0000
committerJustin Lecher <jlec@gentoo.org>2010-07-11 15:37:27 +0000
commit2161c35cfdb474f915f9843e290c0b73ae0f0abe (patch)
tree5e782150ca53127252a0863edbc4fd62cff3e4ef /dev-vcs/gitstats
parentold (diff)
downloadgentoo-2-2161c35cfdb474f915f9843e290c0b73ae0f0abe.tar.gz
gentoo-2-2161c35cfdb474f915f9843e290c0b73ae0f0abe.tar.bz2
gentoo-2-2161c35cfdb474f915f9843e290c0b73ae0f0abe.zip
Import from sunrise
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs/gitstats')
-rw-r--r--dev-vcs/gitstats/ChangeLog11
-rw-r--r--dev-vcs/gitstats/gitstats-100711.ebuild37
-rw-r--r--dev-vcs/gitstats/gitstats-9999.ebuild38
-rw-r--r--dev-vcs/gitstats/metadata.xml6
4 files changed, 92 insertions, 0 deletions
diff --git a/dev-vcs/gitstats/ChangeLog b/dev-vcs/gitstats/ChangeLog
new file mode 100644
index 000000000000..45b5414e9cb4
--- /dev/null
+++ b/dev-vcs/gitstats/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-vcs/gitstats
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitstats/ChangeLog,v 1.1 2010/07/11 15:37:27 jlec Exp $
+
+*gitstats-100711 (11 Jul 2010)
+*gitstats-9999 (11 Jul 2010)
+
+ 11 Jul 2010; Justin Lecher <jlec@gentoo.org> +gitstats-9999.ebuild,
+ +gitstats-100711.ebuild, +metadata.xml:
+ Import from sunrise
+
diff --git a/dev-vcs/gitstats/gitstats-100711.ebuild b/dev-vcs/gitstats/gitstats-100711.ebuild
new file mode 100644
index 000000000000..a777d3f4d0e3
--- /dev/null
+++ b/dev-vcs/gitstats/gitstats-100711.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitstats/gitstats-100711.ebuild,v 1.1 2010/07/11 15:37:27 jlec Exp $
+
+EAPI="2"
+
+PYTHON_DEPEND="2"
+
+inherit python
+
+DESCRIPTION="Statistics generator for git"
+HOMEPAGE="http://gitstats.sourceforge.net/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ sci-visualization/gnuplot[gd]
+ dev-vcs/git"
+DEPEND=""
+
+src_prepare() {
+ sed "s:basedir = os.path.dirname(os.path.abspath(__file__)):basedir = '/usr/share/gitstats':g" \
+ -i gitstats || die "failed to fix static files path"
+}
+
+src_compile() {
+ :;
+}
+
+src_install() {
+ emake PREFIX="${D}"/usr VERSION="${PV}" install || die
+ dodoc doc/{README,*.txt} || die "doc install failed"
+}
diff --git a/dev-vcs/gitstats/gitstats-9999.ebuild b/dev-vcs/gitstats/gitstats-9999.ebuild
new file mode 100644
index 000000000000..af8e345f751e
--- /dev/null
+++ b/dev-vcs/gitstats/gitstats-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitstats/gitstats-9999.ebuild,v 1.1 2010/07/11 15:37:27 jlec Exp $
+
+EAPI="2"
+
+PYTHON_DEPEND="2"
+
+inherit python git
+
+DESCRIPTION="Statistics generator for git"
+HOMEPAGE="http://gitstats.sourceforge.net/"
+SRC_URI=""
+EGIT_REPO_URI="git://repo.or.cz/${PN}.git"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="
+ sci-visualization/gnuplot[gd]
+ dev-vcs/git"
+DEPEND=""
+
+src_prepare() {
+ sed "s:basedir = os.path.dirname(os.path.abspath(__file__)):basedir = '/usr/share/gitstats':g" \
+ -i gitstats || die "failed to fix static files path"
+}
+
+src_compile() {
+ :;
+}
+
+src_install() {
+ emake PREFIX="${D}"/usr VERSION="${PV}" install || die
+ dodoc doc/{README,*.txt} || die "doc install failed"
+}
diff --git a/dev-vcs/gitstats/metadata.xml b/dev-vcs/gitstats/metadata.xml
new file mode 100644
index 000000000000..0cf9e5366572
--- /dev/null
+++ b/dev-vcs/gitstats/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer><email>jlec@gentoo.org</email></maintainer>
+</pkgmetadata>