summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2010-03-04 18:52:26 +0000
committerSebastian Pipping <sping@gentoo.org>2010-03-04 18:52:26 +0000
commit551f4e6ccf9ee3fe61e275f678737d4602d38621 (patch)
treee8cfa285d645b3d058b7e3857cd7d86578edd43a /dev-vcs/gitg/gitg-0.0.5.ebuild
parentSet SUPPORT_PYTHON_ABIS. Fix installation (bug #307515). (diff)
downloadgentoo-2-551f4e6ccf9ee3fe61e275f678737d4602d38621.tar.gz
gentoo-2-551f4e6ccf9ee3fe61e275f678737d4602d38621.tar.bz2
gentoo-2-551f4e6ccf9ee3fe61e275f678737d4602d38621.zip
dev-vcs/gitg: New package (was dev-util/gitg before)
(Portage version: 2.2_rc64/cvs/Linux i686, RepoMan options: --force)
Diffstat (limited to 'dev-vcs/gitg/gitg-0.0.5.ebuild')
-rw-r--r--dev-vcs/gitg/gitg-0.0.5.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-vcs/gitg/gitg-0.0.5.ebuild b/dev-vcs/gitg/gitg-0.0.5.ebuild
new file mode 100644
index 000000000000..8f47c8af2f08
--- /dev/null
+++ b/dev-vcs/gitg/gitg-0.0.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitg/gitg-0.0.5.ebuild,v 1.1 2010/03/04 18:52:26 sping Exp $
+
+EAPI="2"
+
+inherit gnome2
+
+DESCRIPTION="git repository viewer for GNOME"
+HOMEPAGE="http://trac.novowork.com/gitg/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.16
+ >=x11-libs/gtk+-2.16
+ >=x11-libs/gtksourceview-2.2
+ >=gnome-base/gconf-2.10
+ dev-util/git"
+
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.15
+ >=dev-util/intltool-0.35"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_prepare() {
+ # Fix intltoolize broken file, see <https://bugzilla.gnome.org/show_bug.cgi?id=577133>
+ sed "s:'\^\$\$lang\$\$':\^\$\$lang\$\$:g" -i "${S}/po/Makefile.in.in" || die "sed failed"
+}
+
+pkg_setup() {
+ G2CONF="${G2CONF} --disable-bundle"
+}