summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2007-05-01 07:44:03 +0000
committerChristian Heim <phreak@gentoo.org>2007-05-01 07:44:03 +0000
commitb2ea2e228a21b2309a86f833e8596836cfec87f0 (patch)
treeb1d140da450d18f6f6d80f3240c4ac316ac97f78 /dev-util
parentVersion bump. (diff)
downloadgentoo-2-b2ea2e228a21b2309a86f833e8596836cfec87f0.tar.gz
gentoo-2-b2ea2e228a21b2309a86f833e8596836cfec87f0.tar.bz2
gentoo-2-b2ea2e228a21b2309a86f833e8596836cfec87f0.zip
Fixing up FEATURES=test, backporting vapier's changes to quilt-0.45-r1.
(Portage version: 2.1.2.5)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/quilt/ChangeLog10
-rw-r--r--dev-util/quilt/quilt-0.45-r1.ebuild15
-rw-r--r--dev-util/quilt/quilt-0.46.ebuild10
3 files changed, 20 insertions, 15 deletions
diff --git a/dev-util/quilt/ChangeLog b/dev-util/quilt/ChangeLog
index cc06b15bfa94..dd60d25041c7 100644
--- a/dev-util/quilt/ChangeLog
+++ b/dev-util/quilt/ChangeLog
@@ -1,8 +1,12 @@
# ChangeLog for dev-util/quilt
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/quilt/ChangeLog,v 1.23 2007/03/12 19:02:59 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/quilt/ChangeLog,v 1.24 2007/05/01 07:44:03 phreak Exp $
- 12 Mar 2007; Raúl Porcel <armin76@gentoo.org> quilt-0.45-r1.ebuild:
+ 01 May 2007; Christian Heim <phreak@gentoo.org> quilt-0.45-r1.ebuild,
+ quilt-0.46.ebuild:
+ Fixing up FEATURES=test, backporting vapier's changes to quilt-0.45-r1.
+
+ 12 Mar 2007; Raúl Porcel <armin76@gentoo.org> quilt-0.45-r1.ebuild:
x86 stable
07 Mar 2007; Christian Heim <phreak@gentoo.org> quilt-0.42-r1.ebuild,
@@ -23,7 +27,7 @@
stripping bug; noone reported yet); also introduction a new USE flag, that
adds/removes the graphviz dependency.
- 22 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
+ 22 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
08 Dec 2006; Luca Barbato <lu_zero@gentoo.org> quilt-0.45.ebuild:
diff --git a/dev-util/quilt/quilt-0.45-r1.ebuild b/dev-util/quilt/quilt-0.45-r1.ebuild
index 9b5ce56267b8..8e5139dda951 100644
--- a/dev-util/quilt/quilt-0.45-r1.ebuild
+++ b/dev-util/quilt/quilt-0.45-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/quilt/quilt-0.45-r1.ebuild,v 1.3 2007/03/12 19:02:59 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/quilt/quilt-0.45-r1.ebuild,v 1.4 2007/05/01 07:44:03 phreak Exp $
inherit bash-completion eutils
@@ -17,14 +17,11 @@ RDEPEND="sys-apps/ed
dev-util/diffstat
graphviz? ( media-gfx/graphviz )"
-# The tests are somewhat broken while being run from within portage, work fine
-# if you run them manually
-RESTRICT="test"
-
pkg_setup() {
+ use graphviz && return 0
echo
- elog "If you intend to use the folding functionality (graphical illustration of the patch stack)"
- elog "then you'll need to remerge this package with USE=graphviz."
+ elog "If you intend to use the folding functionality (graphical illustration of the"
+ elog "patch stack) then you'll need to remerge this package with USE=graphviz."
echo
epause 5
}
@@ -35,6 +32,10 @@ src_unpack() {
# Add support for USE=graphviz
use graphviz || epatch "${FILESDIR}/${P}-no-graphviz.patch"
+
+ # Some tests are somewhat broken while being run from within portage, work
+ # fine if you run them manually
+ rm "${S}"/test/delete.test
}
src_install() {
diff --git a/dev-util/quilt/quilt-0.46.ebuild b/dev-util/quilt/quilt-0.46.ebuild
index 65a7ab9f5567..58c4c6869297 100644
--- a/dev-util/quilt/quilt-0.46.ebuild
+++ b/dev-util/quilt/quilt-0.46.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/quilt/quilt-0.46.ebuild,v 1.3 2007/03/26 20:03:49 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/quilt/quilt-0.46.ebuild,v 1.4 2007/05/01 07:44:03 phreak Exp $
inherit bash-completion eutils
@@ -17,10 +17,6 @@ RDEPEND="sys-apps/ed
dev-util/diffstat
graphviz? ( media-gfx/graphviz )"
-# The tests are somewhat broken while being run from within portage, work fine
-# if you run them manually
-RESTRICT="test"
-
pkg_setup() {
use graphviz && return 0
echo
@@ -36,6 +32,10 @@ src_unpack() {
# Add support for USE=graphviz
use graphviz || epatch "${FILESDIR}/${P}-no-graphviz.patch"
+
+ # Some tests are somewhat broken while being run from within portage, work
+ # fine if you run them manually
+ rm "${S}"/test/delete.test
}
src_install() {