summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2009-08-25 19:54:10 +0000
committerVictor Ostorga <vostorga@gentoo.org>2009-08-25 19:54:10 +0000
commit8100ba043caff94ff7ef6e7df054f8ddf0e2ae7c (patch)
tree6bf33833feea4fbf4c2cb581772d3a2650b45fb2 /dev-util
parentObsolete entry. (diff)
downloadgentoo-2-8100ba043caff94ff7ef6e7df054f8ddf0e2ae7c.tar.gz
gentoo-2-8100ba043caff94ff7ef6e7df054f8ddf0e2ae7c.tar.bz2
gentoo-2-8100ba043caff94ff7ef6e7df054f8ddf0e2ae7c.zip
Fixing build against gcc 4.4 #282676 , Respecting CXX variable
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/httpup/ChangeLog8
-rw-r--r--dev-util/httpup/files/httpup-0.3.2-gcc44.patch30
-rw-r--r--dev-util/httpup/httpup-0.3.2.ebuild12
3 files changed, 45 insertions, 5 deletions
diff --git a/dev-util/httpup/ChangeLog b/dev-util/httpup/ChangeLog
index 1bf075e4b4cb..af62ad44b9d5 100644
--- a/dev-util/httpup/ChangeLog
+++ b/dev-util/httpup/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/httpup
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/httpup/ChangeLog,v 1.5 2008/06/20 14:07:12 loki_val Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/httpup/ChangeLog,v 1.6 2009/08/25 19:54:09 vostorga Exp $
+
+ 25 Aug 2009; Víctor Ostorga <vostorga@gentoo.org> httpup-0.3.2.ebuild,
+ +files/httpup-0.3.2-gcc44.patch:
+ Fixing build against gcc 4.4 #282676 , Respecting CXX variable
20 Jun 2008; Peter Alfredsen <loki_val@gentoo.org>
+files/httpup-0.3.2-gcc43.patch, httpup-0.3.2.ebuild:
diff --git a/dev-util/httpup/files/httpup-0.3.2-gcc44.patch b/dev-util/httpup/files/httpup-0.3.2-gcc44.patch
new file mode 100644
index 000000000000..83f100c76589
--- /dev/null
+++ b/dev-util/httpup/files/httpup-0.3.2-gcc44.patch
@@ -0,0 +1,30 @@
+diff -NrU5 httpup-0.3.2.original/configparser.cpp httpup-0.3.2/configparser.cpp
+--- httpup-0.3.2.original/configparser.cpp 2009-08-25 20:01:59.000000000 -0600
++++ httpup-0.3.2/configparser.cpp 2009-08-25 20:02:20.000000000 -0600
+@@ -9,10 +9,11 @@
+ // (at your option) any later version.
+ ////////////////////////////////////////////////////////////////////////
+
+ #include <iostream>
+ #include <cstring>
++#include <cstdio>
+ #include "configparser.h"
+
+ using namespace std;
+
+ int ConfigParser::parseConfig(const std::string& fileName,
+diff -NrU5 httpup-0.3.2.original/fileutils.cpp httpup-0.3.2/fileutils.cpp
+--- httpup-0.3.2.original/fileutils.cpp 2009-08-25 20:01:59.000000000 -0600
++++ httpup-0.3.2/fileutils.cpp 2009-08-25 20:02:29.000000000 -0600
+@@ -8,10 +8,11 @@
+ // the Free Software Foundation; either version 2 of the License, or
+ // (at your option) any later version.
+ ////////////////////////////////////////////////////////////////////////
+
+ #include <sys/types.h>
++#include <cstdio>
+ #include <sys/stat.h>
+ #include <unistd.h>
+ #include <dirent.h>
+
+ #include "md5.h"
diff --git a/dev-util/httpup/httpup-0.3.2.ebuild b/dev-util/httpup/httpup-0.3.2.ebuild
index 6308e876052f..42e2cdb764fc 100644
--- a/dev-util/httpup/httpup-0.3.2.ebuild
+++ b/dev-util/httpup/httpup-0.3.2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/httpup/httpup-0.3.2.ebuild,v 1.3 2008/06/20 14:07:12 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/httpup/httpup-0.3.2.ebuild,v 1.4 2009/08/25 19:54:09 vostorga Exp $
-inherit eutils
+inherit eutils toolchain-funcs
DESCRIPTION="synchronisation tool for http file repositories"
HOMEPAGE="http://clc.berlios.de/projects/httpup/"
@@ -14,6 +14,7 @@ KEYWORDS="~amd64 ~x86 ~ppc"
IUSE=""
DEPEND="net-misc/curl"
+RDEPEND="${DEPEND}"
src_unpack() {
unpack ${A}
@@ -22,6 +23,11 @@ src_unpack() {
-e 's:g++:$(CXX) $(CFLAGS) $(LDFLAGS):' \
Makefile
epatch "${FILESDIR}"/${P}-gcc43.patch
+ epatch "${FILESDIR}"/${P}-gcc44.patch
+}
+
+src_compile() {
+ emake CXX="$(tc-getCXX)" || die "make failed"
}
src_install() {