summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-02-17 02:19:37 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-02-17 02:19:37 +0000
commit68ed2ddac0e0bb5706cbcacd2effa2e1094d0651 (patch)
tree23c8f6e149b5b9cae78068aa8d3429bdc057e58b /dev-util
parentVersion bump. (diff)
downloadgentoo-2-68ed2ddac0e0bb5706cbcacd2effa2e1094d0651.tar.gz
gentoo-2-68ed2ddac0e0bb5706cbcacd2effa2e1094d0651.tar.bz2
gentoo-2-68ed2ddac0e0bb5706cbcacd2effa2e1094d0651.zip
Backport upstream commits r11856 and r11904 to address bug #403179
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/valgrind/ChangeLog8
-rw-r--r--dev-util/valgrind/files/valgrind-3.6.1-fix-unhandled-opcode.patch82
-rw-r--r--dev-util/valgrind/valgrind-3.6.1-r3.ebuild108
3 files changed, 197 insertions, 1 deletions
diff --git a/dev-util/valgrind/ChangeLog b/dev-util/valgrind/ChangeLog
index c1587520534e..5a15f8b52fa3 100644
--- a/dev-util/valgrind/ChangeLog
+++ b/dev-util/valgrind/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/valgrind
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/ChangeLog,v 1.137 2012/02/17 01:46:44 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/ChangeLog,v 1.138 2012/02/17 02:19:37 blueness Exp $
+
+*valgrind-3.6.1-r3 (17 Feb 2012)
+
+ 17 Feb 2012; Anthony G. Basile <blueness@gentoo.org>
+ +valgrind-3.6.1-r3.ebuild, +files/valgrind-3.6.1-fix-unhandled-opcode.patch:
+ Backport upstream commits r11856 and r11904 to address bug #403179
17 Feb 2012; Anthony G. Basile <blueness@gentoo.org>
valgrind-3.7.0-r3.ebuild:
diff --git a/dev-util/valgrind/files/valgrind-3.6.1-fix-unhandled-opcode.patch b/dev-util/valgrind/files/valgrind-3.6.1-fix-unhandled-opcode.patch
new file mode 100644
index 000000000000..bb8ef9467d63
--- /dev/null
+++ b/dev-util/valgrind/files/valgrind-3.6.1-fix-unhandled-opcode.patch
@@ -0,0 +1,82 @@
+diff -Naur valgrind-3.6.1.orig/coregrind/m_debuginfo/debuginfo.c valgrind-3.6.1/coregrind/m_debuginfo/debuginfo.c
+--- valgrind-3.6.1.orig/coregrind/m_debuginfo/debuginfo.c 2010-10-20 16:19:43.000000000 -0400
++++ valgrind-3.6.1/coregrind/m_debuginfo/debuginfo.c 2012-02-16 21:10:53.000000000 -0500
+@@ -1958,6 +1958,14 @@
+ case Cop_Sub: return wL - wR;
+ case Cop_And: return wL & wR;
+ case Cop_Mul: return wL * wR;
++ case Cop_Shl: return wL << wR;
++ case Cop_Shr: return wL >> wR;
++ case Cop_Eq: return wL == wR ? 1 : 0;
++ case Cop_Ge: return (Word) wL >= (Word) wR ? 1 : 0;
++ case Cop_Gt: return (Word) wL > (Word) wR ? 1 : 0;
++ case Cop_Le: return (Word) wL <= (Word) wR ? 1 : 0;
++ case Cop_Lt: return (Word) wL < (Word) wR ? 1 : 0;
++ case Cop_Ne: return wL != wR ? 1 : 0;
+ default: goto unhandled;
+ }
+ /*NOTREACHED*/
+diff -Naur valgrind-3.6.1.orig/coregrind/m_debuginfo/priv_storage.h valgrind-3.6.1/coregrind/m_debuginfo/priv_storage.h
+--- valgrind-3.6.1.orig/coregrind/m_debuginfo/priv_storage.h 2010-10-20 16:19:43.000000000 -0400
++++ valgrind-3.6.1/coregrind/m_debuginfo/priv_storage.h 2012-02-16 21:10:49.000000000 -0500
+@@ -218,7 +218,15 @@
+ Cop_Add=0x321,
+ Cop_Sub,
+ Cop_And,
+- Cop_Mul
++ Cop_Mul,
++ Cop_Shl,
++ Cop_Shr,
++ Cop_Eq,
++ Cop_Ge,
++ Cop_Gt,
++ Cop_Le,
++ Cop_Lt,
++ Cop_Ne
+ }
+ CfiOp;
+
+diff -Naur valgrind-3.6.1.orig/coregrind/m_debuginfo/readdwarf.c valgrind-3.6.1/coregrind/m_debuginfo/readdwarf.c
+--- valgrind-3.6.1.orig/coregrind/m_debuginfo/readdwarf.c 2010-10-20 16:19:43.000000000 -0400
++++ valgrind-3.6.1/coregrind/m_debuginfo/readdwarf.c 2012-02-16 21:10:49.000000000 -0500
+@@ -2831,6 +2831,22 @@
+ op = Cop_And; opname = "and"; goto binop;
+ case DW_OP_mul:
+ op = Cop_Mul; opname = "mul"; goto binop;
++ case DW_OP_shl:
++ op = Cop_Shl; opname = "shl"; goto binop;
++ case DW_OP_shr:
++ op = Cop_Shr; opname = "shr"; goto binop;
++ case DW_OP_eq:
++ op = Cop_Eq; opname = "eq"; goto binop;
++ case DW_OP_ge:
++ op = Cop_Ge; opname = "ge"; goto binop;
++ case DW_OP_gt:
++ op = Cop_Gt; opname = "gt"; goto binop;
++ case DW_OP_le:
++ op = Cop_Le; opname = "le"; goto binop;
++ case DW_OP_lt:
++ op = Cop_Lt; opname = "lt"; goto binop;
++ case DW_OP_ne:
++ op = Cop_Ne; opname = "ne"; goto binop;
+ binop:
+ POP( ix );
+ POP( ix2 );
+diff -Naur valgrind-3.6.1.orig/coregrind/m_debuginfo/storage.c valgrind-3.6.1/coregrind/m_debuginfo/storage.c
+--- valgrind-3.6.1.orig/coregrind/m_debuginfo/storage.c 2010-10-20 16:19:43.000000000 -0400
++++ valgrind-3.6.1/coregrind/m_debuginfo/storage.c 2012-02-16 21:10:49.000000000 -0500
+@@ -595,6 +595,14 @@
+ case Cop_Sub: VG_(printf)("-"); break;
+ case Cop_And: VG_(printf)("&"); break;
+ case Cop_Mul: VG_(printf)("*"); break;
++ case Cop_Shl: VG_(printf)("<<"); break;
++ case Cop_Shr: VG_(printf)(">>"); break;
++ case Cop_Eq: VG_(printf)("=="); break;
++ case Cop_Ge: VG_(printf)(">="); break;
++ case Cop_Gt: VG_(printf)(">"); break;
++ case Cop_Le: VG_(printf)("<="); break;
++ case Cop_Lt: VG_(printf)("<"); break;
++ case Cop_Ne: VG_(printf)("!="); break;
+ default: vg_assert(0);
+ }
+ }
diff --git a/dev-util/valgrind/valgrind-3.6.1-r3.ebuild b/dev-util/valgrind/valgrind-3.6.1-r3.ebuild
new file mode 100644
index 000000000000..2e4b6e1b6fd0
--- /dev/null
+++ b/dev-util/valgrind/valgrind-3.6.1-r3.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/valgrind-3.6.1-r3.ebuild,v 1.1 2012/02/17 02:19:37 blueness Exp $
+
+EAPI=2
+inherit autotools eutils flag-o-matic toolchain-funcs multilib pax-utils
+
+DESCRIPTION="An open-source memory debugger for GNU/Linux"
+HOMEPAGE="http://www.valgrind.org"
+SRC_URI="http://www.valgrind.org/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="mpi qt4"
+
+DEPEND="mpi? ( virtual/mpi )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # Respect CFLAGS, LDFLAGS
+ sed -i -e '/^CPPFLAGS =/d' -e '/^CFLAGS =/d' -e '/^LDFLAGS =/d' \
+ mpi/Makefile.am || die
+
+ # Changing Makefile.all.am to disable SSP
+ sed -i -e 's:^AM_CFLAGS_BASE = :AM_CFLAGS_BASE = -fno-stack-protector :' \
+ Makefile.all.am || die
+
+ # Correct hard coded doc location
+ sed -i -e "s:doc/valgrind:doc/${PF}:" \
+ docs/Makefile.am || die
+
+ # Yet more local labels, this time for ppc32 & ppc64
+ epatch "${FILESDIR}"/${PN}-3.6.0-local-labels.patch
+
+ # Don't build in empty assembly files for other platforms or we'll get a QA
+ # warning about executable stacks.
+ epatch "${FILESDIR}"/${PN}-3.6.0-non-exec-stack.patch
+
+ # Fix up some suppressions that were not general enough for glibc versions
+ # with more than just a major and minor number.
+ epatch "${FILESDIR}"/${PN}-3.4.1-glibc-2.10.1.patch
+
+ # Remove automagic dependency on qt4
+ epatch "${FILESDIR}"/${PN}-3.6.1-user-enable-qt4.patch
+
+ # Allow valgrind to build against linux-3, bug #370857
+ epatch "${FILESDIR}"/${PN}-3.6.1-linux-3.patch
+
+ # Allow valgrind to build against glibc-2.14, bug #378157
+ epatch "${FILESDIR}"/${PN}-3.6.1-glibc-2.14.patch
+
+ # Back port of fix for bug #403179, https://bugs.kde.org/show_bug.cgi?id=277045
+ epatch "${FILESDIR}"/${PN}-3.6.1-fix-unhandled-opcode.patch
+
+ # Fix stricter use of dir variables, bugs #397429 and #403779
+ epatch "${FILESDIR}"/${PN}-3.6.1-automake-1.11.3.patch
+
+ # Regenerate autotools files
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+
+ # -fomit-frame-pointer "Assembler messages: Error: junk `8' after expression"
+ # while compiling insn_sse.c in none/tests/x86
+ # -fpie valgrind seemingly hangs when built with pie on
+ # amd64 (bug #102157)
+ # -fstack-protector more undefined references to __guard and __stack_smash_handler
+ # because valgrind doesn't link to glibc (bug #114347)
+ # -ggdb3 segmentation fault on startup
+ filter-flags -fomit-frame-pointer
+ filter-flags -fpie
+ filter-flags -fstack-protector
+ replace-flags -ggdb3 -ggdb2
+
+ if use amd64 || use ppc64; then
+ ! has_multilib_profile && myconf="${myconf} --enable-only64bit"
+ fi
+
+ # Don't use mpicc unless the user asked for it (bug #258832)
+ if ! use mpi; then
+ myconf="${myconf} --without-mpicc"
+ fi
+
+ if ! use qt4; then
+ myconf="${myconf} --disable-qtcore"
+ fi
+
+ econf ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS FAQ.txt NEWS README*
+
+ pax-mark m "${D}"/usr/$(get_libdir)/valgrind/*-*-linux
+}
+
+pkg_postinst() {
+ ewarn "Valgrind will not work if glibc does not have debug symbols."
+ ewarn "To fix this you can add splitdebug to FEATURES in make.conf"
+ ewarn "and remerge glibc. See:"
+ ewarn "https://bugs.gentoo.org/show_bug.cgi?id=214065"
+ ewarn "https://bugs.gentoo.org/show_bug.cgi?id=274771"
+ ewarn "https://bugs.gentoo.org/show_bug.cgi?id=388703"
+}