summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2014-08-20 18:38:29 +0000
committerDavide Pesavento <pesa@gentoo.org>2014-08-20 18:38:29 +0000
commit3c52991394ce3b18d86dbc29b638f17cc8f0105b (patch)
treec6dd09af70cc7207eddf18bb188fa2fbf9be53a1 /dev-util
parentVersion bump. (diff)
downloadgentoo-2-3c52991394ce3b18d86dbc29b638f17cc8f0105b.tar.gz
gentoo-2-3c52991394ce3b18d86dbc29b638f17cc8f0105b.tar.bz2
gentoo-2-3c52991394ce3b18d86dbc29b638f17cc8f0105b.zip
Version bumps.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 0xDADED6B2671CB57D!)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/eric/ChangeLog10
-rw-r--r--dev-util/eric/eric-4.5.24.ebuild (renamed from dev-util/eric/eric-4.5.17.ebuild)37
-rw-r--r--dev-util/eric/eric-5.3.8.ebuild106
-rw-r--r--dev-util/eric/eric-5.4.6.ebuild (renamed from dev-util/eric/eric-5.4.0_rc1.ebuild)19
4 files changed, 35 insertions, 137 deletions
diff --git a/dev-util/eric/ChangeLog b/dev-util/eric/ChangeLog
index e7583603d669..9f0415b4accb 100644
--- a/dev-util/eric/ChangeLog
+++ b/dev-util/eric/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-util/eric
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/ChangeLog,v 1.209 2014/08/03 15:55:28 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/ChangeLog,v 1.210 2014/08/20 18:38:29 pesa Exp $
+
+*eric-5.4.6 (20 Aug 2014)
+*eric-4.5.24 (20 Aug 2014)
+
+ 20 Aug 2014; Davide Pesavento <pesa@gentoo.org> +eric-4.5.24.ebuild,
+ +eric-5.4.6.ebuild, -eric-4.5.17.ebuild, -eric-5.3.8.ebuild,
+ -eric-5.4.0_rc1.ebuild:
+ Version bumps.
03 Aug 2014; Michał Górny <mgorny@gentoo.org> eric-5.4.0_rc1.ebuild:
Enable Python 3.3 & 3.4.
diff --git a/dev-util/eric/eric-4.5.17.ebuild b/dev-util/eric/eric-4.5.24.ebuild
index 9fcf5697b936..9f9f04ca1164 100644
--- a/dev-util/eric/eric-4.5.17.ebuild
+++ b/dev-util/eric/eric-4.5.24.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/eric-4.5.17.ebuild,v 1.1 2013/12/27 01:54:52 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/eric-4.5.24.ebuild,v 1.1 2014/08/20 18:38:29 pesa Exp $
EAPI=4
-PYTHON_DEPEND="2:2.6"
+PYTHON_DEPEND="2:2.7"
SUPPORT_PYTHON_ABIS="1"
-# 2.4 and 2.5 are restricted to avoid conditional dependency on dev-python/simplejson.
+# 2.4 and 2.5 are restricted to avoid conditional dependency on dev-python/simplejson
RESTRICT_PYTHON_ABIS="2.4 2.5 3.* *-jython 2.7-pypy-*"
PLOCALES="cs de en es fr it ru tr zh_CN"
@@ -17,10 +17,10 @@ DESCRIPTION="A full featured Python IDE using PyQt4 and QScintilla"
HOMEPAGE="http://eric-ide.python-projects.org/"
SLOT="4"
-MY_PV=${PV/_pre/-snapshot-}
+MY_PV=${PV/_rc/-RC}
MY_P=${PN}${SLOT}-${MY_PV}
-BASE_URI="mirror://sourceforge/eric-ide/${PN}${SLOT}/stable/${PV}"
+BASE_URI="mirror://sourceforge/eric-ide/${PN}${SLOT}/stable/${MY_PV}"
SRC_URI="${BASE_URI}/${MY_P}.tar.gz"
for L in ${PLOCALES}; do
SRC_URI+=" linguas_${L}? ( ${BASE_URI}/${PN}${SLOT}-i18n-${L/zh_CN/zh_CN.GB2312}-${MY_PV}.tar.gz )"
@@ -29,7 +29,7 @@ unset L
LICENSE="GPL-3"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="kde spell"
+IUSE="kde"
DEPEND="
>=dev-python/sip-4.12.4
@@ -40,10 +40,7 @@ DEPEND="
RDEPEND="${DEPEND}
>=dev-python/chardet-2.0.1
>=dev-python/coverage-3.0.1
- >=dev-python/pygments-1.3.1
-"
-PDEPEND="
- spell? ( dev-python/pyenchant )
+ >=dev-python/pygments-1.5
"
S=${WORKDIR}/${MY_P}
@@ -54,9 +51,11 @@ src_prepare() {
epatch "${FILESDIR}/eric-4.5-no-interactive.patch"
use kde || epatch "${FILESDIR}/eric-4.4-no-pykde.patch"
- # Delete internal copies of dev-python/chardet, dev-python/coverage,
- # dev-python/pygments and dev-python/simplejson.
+ # Delete internal copies of dev-python/chardet,
+ # dev-python/pygments and dev-python/simplejson
rm -fr eric/ThirdParty
+
+ # Delete internal copy of dev-python/coverage
rm -fr eric/DebugClients/Python{,3}/coverage
sed -i -e 's/from DebugClients\.Python3\?\.coverage/from coverage/' \
$(grep -lr 'from DebugClients\.Python3\?\.coverage' .) || die
@@ -74,24 +73,22 @@ src_install() {
python_execute_function installation
python_merge_intermediate_installation_images "${T}/images"
- doicon eric/icons/default/eric.png || die
+ doicon eric/icons/default/eric.png
make_desktop_entry "eric4 --nosplash" eric4 eric "Development;IDE;Qt"
}
pkg_postinst() {
python_mod_optimize eric4{,config.py,plugins}
- elog
- elog "If you want to use Eric with mod_python, have a look at"
- elog "\"${EROOT}$(python_get_sitedir -b -f)/eric4/patch_modpython.py\"."
- elog
elog "The following packages will give Eric extended functionality:"
+ elog " dev-python/cx_Freeze"
+ elog " dev-python/pyenchant"
elog " dev-python/pylint"
elog " dev-python/pysvn"
+ elog " dev-vcs/mercurial"
elog
elog "This version has a plugin interface with plugin-autofetch from"
- elog "the application itself. You may want to check those as well."
- elog
+ elog "the application itself. You may want to check that as well."
}
pkg_postrm() {
diff --git a/dev-util/eric/eric-5.3.8.ebuild b/dev-util/eric/eric-5.3.8.ebuild
deleted file mode 100644
index 104ece73a8c6..000000000000
--- a/dev-util/eric/eric-5.3.8.ebuild
+++ /dev/null
@@ -1,106 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/eric-5.3.8.ebuild,v 1.1 2013/11/24 22:54:02 pesa Exp $
-
-EAPI=4
-
-PYTHON_DEPEND="3:3.1"
-PYTHON_USE_WITH="sqlite"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.* *-jython 2.7-pypy-*"
-
-PLOCALES="cs de en es fr it ru tr zh_CN"
-
-inherit eutils l10n python
-
-DESCRIPTION="A full featured Python IDE using PyQt4 and QScintilla"
-HOMEPAGE="http://eric-ide.python-projects.org/"
-
-SLOT="5"
-MY_PV=${PV/_pre/-snapshot-}
-MY_P=${PN}${SLOT}-${MY_PV}
-
-BASE_URI="mirror://sourceforge/eric-ide/${PN}${SLOT}/stable/${PV}"
-SRC_URI="${BASE_URI}/${MY_P}.tar.gz"
-for L in ${PLOCALES}; do
- SRC_URI+=" linguas_${L}? ( ${BASE_URI}/${PN}${SLOT}-i18n-${L/zh_CN/zh_CN.GB2312}-${MY_PV}.tar.gz )"
-done
-unset L
-
-LICENSE="GPL-3"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="spell"
-
-DEPEND="
- >=dev-python/sip-4.12.4
- >=dev-python/PyQt4-4.9.6-r1[X,help,sql,svg,webkit]
- >=dev-python/qscintilla-python-2.6
-"
-RDEPEND="${DEPEND}
- >=dev-python/chardet-2.0.1
- >=dev-python/coverage-3.2
- >=dev-python/pygments-1.5
-"
-PDEPEND="
- spell? ( dev-python/pyenchant )
-"
-
-S=${WORKDIR}/${MY_P}
-
-PYTHON_VERSIONED_EXECUTABLES=("/usr/bin/.*")
-
-src_prepare() {
- # Avoid file collisions between different slots of Eric.
- sed -i -e 's/^Icon=eric$/&5/' eric/eric5.desktop || die
- sed -i -e 's/\([^[:alnum:]]\)eric\.png\([^[:alnum:]]\)/\1eric5.png\2/' \
- $(grep -lr 'eric\.png' .) || die
- mv eric/icons/default/eric{,5}.png || die
- mv eric/pixmaps/eric{,5}.png || die
- rm -f eric/APIs/Python/zope-*.api
- rm -f eric/APIs/Ruby/Ruby-*.api
-
- # Delete internal copies of dev-python/chardet,
- # dev-python/coverage and dev-python/pygments.
- rm -fr eric/ThirdParty
- rm -fr eric/DebugClients/Python{,3}/coverage
- sed -i -e 's/from DebugClients\.Python3\?\.coverage/from coverage/' \
- $(grep -lr 'from DebugClients\.Python3\?\.coverage' .) || die
-
- # Fix desktop files (bug 458092).
- sed -i -e '/^Categories=/s:Python:X-&:' eric/eric5{,_webbrowser}.desktop || die
-}
-
-src_install() {
- installation() {
- "$(PYTHON)" install.py \
- -z \
- -b "${EPREFIX}/usr/bin" \
- -i "${T}/images/${PYTHON_ABI}" \
- -d "${EPREFIX}$(python_get_sitedir)" \
- -c
- }
- python_execute_function installation
- python_merge_intermediate_installation_images "${T}/images"
-
- doicon eric/icons/default/eric5.png || die
-}
-
-pkg_postinst() {
- python_mod_optimize -x "/eric5/(DebugClients/Python|UtilitiesPython2)/" eric5{,config.py,plugins}
-
- elog
- elog "If you want to use Eric with mod_python, have a look at"
- elog "\"${EROOT}$(python_get_sitedir -b -f)/eric5/patch_modpython.py\"."
- elog
- elog "The following packages will give Eric extended functionality:"
- elog " dev-python/pylint"
- elog " dev-python/pysvn"
- elog
- elog "This version has a plugin interface with plugin-autofetch from"
- elog "the application itself. You may want to check those as well."
- elog
-}
-
-pkg_postrm() {
- python_mod_cleanup eric5{,config.py,plugins}
-}
diff --git a/dev-util/eric/eric-5.4.0_rc1.ebuild b/dev-util/eric/eric-5.4.6.ebuild
index 7e0cec6eaf3c..3a9a7bd590da 100644
--- a/dev-util/eric/eric-5.4.0_rc1.ebuild
+++ b/dev-util/eric/eric-5.4.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/eric-5.4.0_rc1.ebuild,v 1.2 2014/08/03 15:55:28 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/eric-5.4.6.ebuild,v 1.1 2014/08/20 18:38:29 pesa Exp $
EAPI=5
@@ -26,7 +26,7 @@ unset L
LICENSE="GPL-3"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="spell"
+IUSE=""
DEPEND="
${PYTHON_DEPS}
@@ -39,15 +39,12 @@ RDEPEND="${DEPEND}
>=dev-python/coverage-3.2[${PYTHON_USEDEP}]
>=dev-python/pygments-1.6[${PYTHON_USEDEP}]
"
-PDEPEND="
- spell? ( dev-python/pyenchant[${PYTHON_USEDEP}] )
-"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
S=${WORKDIR}/${MY_P}
src_prepare() {
- # Avoid file collisions between different slots of Eric.
+ # Avoid file collisions between different slots of Eric
sed -i -e 's/^Icon=eric$/&5/' eric/eric5.desktop || die
sed -i -e 's/\([^[:alnum:]]\)eric\.png\([^[:alnum:]]\)/\1eric5.png\2/' \
$(grep -lr 'eric\.png' .) || die
@@ -56,14 +53,15 @@ src_prepare() {
rm -f eric/APIs/Python/zope-*.api
rm -f eric/APIs/Ruby/Ruby-*.api
- # Delete internal copies of dev-python/chardet,
- # dev-python/coverage and dev-python/pygments.
+ # Delete internal copies of dev-python/chardet and dev-python/pygments
rm -fr eric/ThirdParty/{CharDet,Pygments}
+
+ # Delete internal copy of dev-python/coverage
rm -fr eric/DebugClients/Python{,3}/coverage
sed -i -e 's/from DebugClients\.Python3\?\.coverage/from coverage/' \
$(grep -lr 'from DebugClients\.Python3\?\.coverage' .) || die
- # Fix desktop files (bug 458092).
+ # Fix desktop files (bug 458092)
sed -i -e '/^Categories=/s:Python:X-&:' eric/eric5{,_webbrowser}.desktop || die
}
@@ -85,10 +83,11 @@ src_install() {
pkg_postinst() {
elog "The following packages will give Eric extended functionality:"
elog " dev-python/cx_Freeze"
+ elog " dev-python/pyenchant"
elog " dev-python/pylint"
elog " dev-python/pysvn"
elog " dev-vcs/mercurial"
elog
elog "This version has a plugin interface with plugin-autofetch from"
- elog "the application itself. You may want to check those as well."
+ elog "the application itself. You may want to check that as well."
}