summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaurice van der Pot <griffon26@gentoo.org>2007-07-17 17:44:15 +0000
committerMaurice van der Pot <griffon26@gentoo.org>2007-07-17 17:44:15 +0000
commit276c4066bead46a2749b507323aa7834d64cd025 (patch)
tree028d0b1b028541fa757a5a08b5fecef5116765e4 /dev-util
parentStable on sparc wrt #185649 (diff)
downloadgentoo-2-276c4066bead46a2749b507323aa7834d64cd025.tar.gz
gentoo-2-276c4066bead46a2749b507323aa7834d64cd025.tar.bz2
gentoo-2-276c4066bead46a2749b507323aa7834d64cd025.zip
Added support for glibc-2.6 to valgrind (bug #185551)
(Portage version: 2.1.3_rc5)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/valgrind/ChangeLog7
-rw-r--r--dev-util/valgrind/files/valgrind-3.2.3-glibc-2.6.patch269
-rw-r--r--dev-util/valgrind/valgrind-3.2.3.ebuild4
3 files changed, 278 insertions, 2 deletions
diff --git a/dev-util/valgrind/ChangeLog b/dev-util/valgrind/ChangeLog
index c192c5c303cf..246b6330752b 100644
--- a/dev-util/valgrind/ChangeLog
+++ b/dev-util/valgrind/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/valgrind
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/ChangeLog,v 1.77 2007/05/05 18:11:03 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/ChangeLog,v 1.78 2007/07/17 17:44:15 griffon26 Exp $
+
+ 17 Jul 2007; Maurice van der Pot <griffon26@gentoo.org>
+ +files/valgrind-3.2.3-glibc-2.6.patch, valgrind-3.2.3.ebuild:
+ Added support for glibc-2.6, which closes bug 185551 reported by
+ Billy DeVincentis <billydv1@verizon.net>
05 May 2007; nixnut <nixnut@gentoo.org> valgrind-3.2.3.ebuild:
Stable on ppc wrt bug 176707
diff --git a/dev-util/valgrind/files/valgrind-3.2.3-glibc-2.6.patch b/dev-util/valgrind/files/valgrind-3.2.3-glibc-2.6.patch
new file mode 100644
index 000000000000..867ad0e0db07
--- /dev/null
+++ b/dev-util/valgrind/files/valgrind-3.2.3-glibc-2.6.patch
@@ -0,0 +1,269 @@
+diff -ruN valgrind-3.2.3/configure.in valgrind-3.2.3-fixed/configure.in
+--- valgrind-3.2.3/configure.in 2007-07-17 19:32:42.956775000 +0200
++++ valgrind-3.2.3-fixed/configure.in 2007-07-17 19:34:18.042194471 +0200
+@@ -359,6 +359,16 @@
+ ],
+ glibc="2.5")
+
++AC_EGREP_CPP([GLIBC_26], [
++#include <features.h>
++#ifdef __GNU_LIBRARY__
++ #if (__GLIBC__ == 2 && __GLIBC_MINOR__ == 6)
++ GLIBC_26
++ #endif
++#endif
++],
++glibc="2.6")
++
+ AC_MSG_CHECKING([the glibc version])
+
+ case "${glibc}" in
+@@ -386,9 +396,15 @@
+ DEFAULT_SUPP="glibc-2.5.supp ${DEFAULT_SUPP}"
+ ;;
+
++ 2.6)
++ AC_MSG_RESULT(2.6 family)
++ AC_DEFINE([GLIBC_2_6], 1, [Define to 1 if you're using glibc 2.6.x])
++ DEFAULT_SUPP="glibc-2.6.supp ${DEFAULT_SUPP}"
++ ;;
++
+ *)
+ AC_MSG_RESULT(unsupported version)
+- AC_MSG_ERROR([Valgrind requires glibc version 2.2 - 2.5])
++ AC_MSG_ERROR([Valgrind requires glibc version 2.2 - 2.6])
+ ;;
+ esac
+
+diff -ruN valgrind-3.2.3/glibc-2.6.supp valgrind-3.2.3-fixed/glibc-2.6.supp
+--- valgrind-3.2.3/glibc-2.6.supp 1970-01-01 01:00:00.000000000 +0100
++++ valgrind-3.2.3-fixed/glibc-2.6.supp 2007-07-17 19:34:18.042194471 +0200
+@@ -0,0 +1,216 @@
++
++##----------------------------------------------------------------------##
++
++# Errors to suppress by default with glibc 2.4.x
++
++# Format of this file is:
++# {
++# name_of_suppression
++# tool_name:supp_kind
++# (optional extra info for some suppression types)
++# caller0 name, or /name/of/so/file.so
++# caller1 name, or ditto
++# (optionally: caller2 name)
++# (optionally: caller3 name)
++# }
++#
++# For Memcheck, the supp_kinds are:
++#
++# Param Value1 Value2 Value4 Value8 Value16
++# Free Addr1 Addr2 Addr4 Addr8 Addr16
++# Cond (previously known as Value0)
++#
++# and the optional extra info is:
++# if Param: name of system call param
++# if Free: name of free-ing fn)
++
++{
++ dl-hack1
++ Memcheck:Cond
++ fun:_dl_start
++ fun:_start
++}
++
++{
++ dl-hack2
++ Memcheck:Cond
++ obj:/lib*/ld-2.6*.so
++ obj:/lib*/ld-2.6*.so
++ obj:/lib*/ld-2.6*.so
++ obj:/lib*/ld-2.6*.so
++}
++
++{
++ dl-hack3
++ Memcheck:Cond
++ obj:/lib*/ld-2.6*so*
++ obj:/lib*/ld-2.6*so*
++ obj:/lib*/ld-2.6*so*
++}
++
++##----------------------------------------------------------------------##
++{
++ glibc-2.5.x-on-SUSE-10.2-(PPC)-1
++ Memcheck:Cond
++ fun:_dl_start_final
++ fun:_dl_start
++ fun:_start
++}
++{
++ glibc-2.5.x-on-SUSE-10.2-(PPC)-2a
++ Memcheck:Cond
++ fun:index
++ obj:*ld-2.6.*.so
++}
++{
++ glibc-2.5.x-on-SuSE-10.2-(PPC)-2b
++ Memcheck:Addr4
++ fun:index
++ fun:expand_dynamic_string_token
++}
++{
++ glibc-2.5.5-on-SuSE-10.2-(PPC)-2c
++ Memcheck:Addr4
++ fun:index
++ obj:*ld-2.6.*.so
++}
++{
++ glibc-2.3.5-on-SuSE-10.1-(PPC)-3
++ Memcheck:Addr4
++ fun:*wordcopy_fwd_dest_aligned*
++ fun:mem*cpy
++ obj:*lib*2.6.*.so
++}
++
++##----------------------------------------------------------------------##
++## Various structure padding things on SUSE 10.2
++##
++{
++ X11-64bit-padding-1a
++ Memcheck:Param
++ write(buf)
++ fun:__write_nocancel
++ obj:/usr/lib*/libX11.so*
++ obj:/usr/lib*/libX11.so*
++ fun:X*
++}
++{
++ X11-64bit-padding-1b
++ Memcheck:Param
++ write(buf)
++ fun:__write_nocancel
++ obj:/usr/lib*/libX11.so*
++ obj:/usr/lib*/libX11.so*
++ fun:_X*
++}
++{
++ X11-64bit-padding-1c
++ Memcheck:Param
++ write(buf)
++ fun:__write_nocancel
++ obj:/usr/lib*/libX11.so*
++ obj:/usr/lib*/libX11.so*
++ obj:/usr/lib*/libX11.so*
++}
++{
++ X11-64bit-padding-1d
++ Memcheck:Param
++ write(buf)
++ fun:__write_nocancel
++ obj:/usr/lib*/libICE.so*
++ obj:/usr/lib*/libICE.so*
++ obj:/usr/lib*/libICE.so*
++}
++{
++ X11-64bit-padding-2a
++ Memcheck:Param
++ writev(vector[...])
++ fun:do_writev
++ obj:/usr/lib*/libX11.so*
++ obj:/usr/lib*/libX11.so*
++ obj:/usr/lib*/libX11.so*
++}
++{
++ X11-64bit-padding-2b
++ Memcheck:Param
++ writev(vector[...])
++ fun:do_writev
++ fun:writev
++ obj:/usr/lib*/libX11.so*
++ obj:/usr/lib*/libX11.so*
++}
++
++{
++ glibc24-64bit-padding-1a
++ Memcheck:Param
++ socketcall.sendto(msg)
++ fun:send
++ fun:get_mapping
++ fun:__nscd_get_map_ref
++ fun:nscd*
++}
++{
++ glibc24-64bit-padding-1b
++ Memcheck:Param
++ socketcall.sendto(msg)
++ fun:__sendto_nocancel
++ obj:/*libc-2.6.so
++ obj:/*libc-2.6.so
++ obj:/*libc-2.6.so
++}
++{
++ glibc24-64bit-padding-1c
++ Memcheck:Param
++ socketcall.send(msg)
++ fun:send
++ fun:__nscd_get_map_ref
++ fun:nscd_get*_r
++ fun:*nscd*
++ obj:/*libc-2.6.so
++}
++
++
++{
++ X11-64bit-padding-3a
++ Memcheck:Param
++ write(buf)
++ obj:/*libpthread-2.4.so*
++ obj:/usr/lib*/libX11.so*
++ obj:/usr/lib*/libX11.so*
++ obj:/usr/lib*/libX11.so*
++}
++
++{
++ X11-64bit-padding-4a
++ Memcheck:Param
++ socketcall.sendto(msg)
++ fun:send
++ obj:/*libc-2.6.so
++ obj:/*libc-2.6.so
++ obj:/*libc-2.6.so
++}
++{
++ X11-64bit-padding-4b
++ Memcheck:Param
++ socketcall.send(msg)
++ fun:send
++ obj:/*libc-2.6.so
++ obj:/*libc-2.6.so
++ obj:/*libc-2.6.so
++}
++
++##----------------------------------------------------------------------##
++# MontaVista Linux 4.0.1 on ppc32
++{
++ MVL-401-linuxthreads-pthread_create
++ Memcheck:Param
++ write(buf)
++ fun:pthread_create
++}
++{
++ MVL-401-linuxthreads-pthread_create
++ Memcheck:Param
++ write(buf)
++ obj:/lib/libpthread-0.10.so
++ fun:pthread_create
++}
+diff -ruN valgrind-3.2.3/Makefile.am valgrind-3.2.3-fixed/Makefile.am
+--- valgrind-3.2.3/Makefile.am 2007-01-02 15:52:30.000000000 +0100
++++ valgrind-3.2.3-fixed/Makefile.am 2007-07-17 19:35:03.672794808 +0200
+@@ -17,7 +17,7 @@
+ DIST_SUBDIRS = $(SUBDIRS)
+
+ SUPP_FILES = \
+- glibc-2.2.supp glibc-2.3.supp glibc-2.4.supp glibc-2.5.supp \
++ glibc-2.2.supp glibc-2.3.supp glibc-2.4.supp glibc-2.5.supp glibc-2.6.supp \
+ xfree-3.supp xfree-4.supp
+
+ dist_val_DATA = $(SUPP_FILES) default.supp
diff --git a/dev-util/valgrind/valgrind-3.2.3.ebuild b/dev-util/valgrind/valgrind-3.2.3.ebuild
index f93859f7ad8b..49d5470f76f3 100644
--- a/dev-util/valgrind/valgrind-3.2.3.ebuild
+++ b/dev-util/valgrind/valgrind-3.2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/valgrind-3.2.3.ebuild,v 1.7 2007/06/25 21:59:52 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/valgrind-3.2.3.ebuild,v 1.8 2007/07/17 17:44:15 griffon26 Exp $
inherit autotools eutils flag-o-matic toolchain-funcs
@@ -43,6 +43,8 @@ src_unpack() {
epatch "${FILESDIR}/valgrind-3.2.1-only64bit.patch"
fi
+ epatch "${FILESDIR}/${P}-glibc-2.6.patch"
+
# Regenerate autotools files
eautoreconf
}