summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-03-29 11:57:19 +0000
committerMichał Górny <mgorny@gentoo.org>2014-03-29 11:57:19 +0000
commite28df93e776922806591a22afa58ab91ef7e3c16 (patch)
tree41748ca965625c75053c977ccb9abfa6168715d1 /dev-util/squashdelta
parentBump to the release. (diff)
downloadgentoo-2-e28df93e776922806591a22afa58ab91ef7e3c16.tar.gz
gentoo-2-e28df93e776922806591a22afa58ab91ef7e3c16.tar.bz2
gentoo-2-e28df93e776922806591a22afa58ab91ef7e3c16.zip
Bump to the release.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-util/squashdelta')
-rw-r--r--dev-util/squashdelta/ChangeLog7
-rw-r--r--dev-util/squashdelta/squashdelta-0.1.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-util/squashdelta/ChangeLog b/dev-util/squashdelta/ChangeLog
index 4026edc06524..368a43c8d5c1 100644
--- a/dev-util/squashdelta/ChangeLog
+++ b/dev-util/squashdelta/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/squashdelta
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/squashdelta/ChangeLog,v 1.2 2014/03/24 17:34:28 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/squashdelta/ChangeLog,v 1.3 2014/03/29 11:57:19 mgorny Exp $
+
+*squashdelta-0.1 (29 Mar 2014)
+
+ 29 Mar 2014; Michał Górny <mgorny@gentoo.org> +squashdelta-0.1.ebuild:
+ Bump to the release.
24 Mar 2014; Michał Górny <mgorny@gentoo.org> squashdelta-9999.ebuild:
Enable LZO by default since it is going to be used by Gentoo, and require at
diff --git a/dev-util/squashdelta/squashdelta-0.1.ebuild b/dev-util/squashdelta/squashdelta-0.1.ebuild
new file mode 100644
index 000000000000..52a0bf640b88
--- /dev/null
+++ b/dev-util/squashdelta/squashdelta-0.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/squashdelta/squashdelta-0.1.ebuild,v 1.1 2014/03/29 11:57:19 mgorny Exp $
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="Efficient (partially uncompressed) SquashFS binary delta tool"
+HOMEPAGE="https://bitbucket.org/mgorny/squashdelta/"
+SRC_URI="mirror://bitbucket/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+# uses public-domain murmurhash3
+LICENSE="BSD public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="lz4 +lzo"
+
+COMMON_DEPEND="
+ lz4? ( app-arch/lz4:0= )
+ lzo? ( dev-libs/lzo:2= )"
+RDEPEND="${COMMON_DEPEND}
+ dev-util/xdelta:3"
+DEPEND=${COMMON_DEPEND}
+
+# SquashDelta does not make much sense without a compression algo.
+REQUIRED_USE="|| ( lz4 lzo )"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable lz4)
+ $(use_enable lzo)
+ )
+
+ autotools-utils_src_configure
+}