summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2008-11-17 15:58:10 +0000
committerTiziano Müller <dev-zero@gentoo.org>2008-11-17 15:58:10 +0000
commit5622d9a9c36babaa80f9d6e42164b88b1aaeb4dd (patch)
tree2ec1f2288a9444cff36b49c6101973ff00f6fcbd /dev-util/source-highlight
parentadditional ebuild cleanup for minor mistakes. use_enable in global scope, nee... (diff)
downloadgentoo-2-5622d9a9c36babaa80f9d6e42164b88b1aaeb4dd.tar.gz
gentoo-2-5622d9a9c36babaa80f9d6e42164b88b1aaeb4dd.tar.bz2
gentoo-2-5622d9a9c36babaa80f9d6e42164b88b1aaeb4dd.zip
Version bump.
(Portage version: 2.2_rc14/cvs/Linux 2.6.27.5 x86_64)
Diffstat (limited to 'dev-util/source-highlight')
-rw-r--r--dev-util/source-highlight/ChangeLog8
-rw-r--r--dev-util/source-highlight/source-highlight-2.11.ebuild32
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-util/source-highlight/ChangeLog b/dev-util/source-highlight/ChangeLog
index 822e827d04fb..800e73173277 100644
--- a/dev-util/source-highlight/ChangeLog
+++ b/dev-util/source-highlight/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/source-highlight
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/source-highlight/ChangeLog,v 1.33 2008/07/21 06:20:36 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/source-highlight/ChangeLog,v 1.34 2008/11/17 15:58:10 dev-zero Exp $
+
+*source-highlight-2.11 (17 Nov 2008)
+
+ 17 Nov 2008; Tiziano Müller <dev-zero@gentoo.org>
+ +source-highlight-2.11.ebuild:
+ Version bump.
*source-highlight-2.10 (21 Jul 2008)
diff --git a/dev-util/source-highlight/source-highlight-2.11.ebuild b/dev-util/source-highlight/source-highlight-2.11.ebuild
new file mode 100644
index 000000000000..145864d25bca
--- /dev/null
+++ b/dev-util/source-highlight/source-highlight-2.11.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/source-highlight/source-highlight-2.11.ebuild,v 1.1 2008/11/17 15:58:10 dev-zero Exp $
+
+inherit bash-completion
+
+DESCRIPTION="Generate highlighted source code as an (x)html document"
+HOMEPAGE="http://www.gnu.org/software/src-highlite/source-highlight.html"
+SRC_URI="mirror://gnu/src-highlite/${P}.tar.gz"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~mips ~ppc ~x86"
+SLOT="0"
+IUSE="doc"
+
+DEPEND=">=dev-libs/boost-1.34.1
+ dev-util/ctags"
+RDEPEND="${DEPEND}"
+
+src_install () {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dobashcompletion source-highlight-bash-completion
+
+ # That's not how we want it
+ rm -fr "${D}/usr/share/doc" "${D}/etc"
+ dodoc AUTHORS ChangeLog CREDITS NEWS README THANKS TODO.txt
+
+ if use doc ; then
+ cd "${S}/doc"
+ dohtml *.{html,css,java}
+ fi
+}