summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-03-30 18:24:43 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-03-30 18:24:43 +0000
commit19db7b78b78cabb66d5bd29767c31186ce88c8a8 (patch)
tree5222e24c97d986314017dc11527f1b76baa02635 /dev-util/skipfish
parentuzbl-9999: various improvements, bug #310375. new vim-syntax USE. all version... (diff)
downloadgentoo-2-19db7b78b78cabb66d5bd29767c31186ce88c8a8.tar.gz
gentoo-2-19db7b78b78cabb66d5bd29767c31186ce88c8a8.tar.bz2
gentoo-2-19db7b78b78cabb66d5bd29767c31186ce88c8a8.zip
Version bump by Alex Legler.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/skipfish')
-rw-r--r--dev-util/skipfish/ChangeLog8
-rw-r--r--dev-util/skipfish/skipfish-1.27_beta.ebuild53
2 files changed, 60 insertions, 1 deletions
diff --git a/dev-util/skipfish/ChangeLog b/dev-util/skipfish/ChangeLog
index b55f016c4816..92b2279c015a 100644
--- a/dev-util/skipfish/ChangeLog
+++ b/dev-util/skipfish/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/skipfish
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/skipfish/ChangeLog,v 1.3 2010/03/26 19:46:58 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/skipfish/ChangeLog,v 1.4 2010/03/30 18:24:43 ssuominen Exp $
+
+*skipfish-1.27_beta (30 Mar 2010)
+
+ 30 Mar 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +skipfish-1.27_beta.ebuild:
+ Version bump by Alex Legler.
*skipfish-1.26_beta (26 Mar 2010)
diff --git a/dev-util/skipfish/skipfish-1.27_beta.ebuild b/dev-util/skipfish/skipfish-1.27_beta.ebuild
new file mode 100644
index 000000000000..e1847807d37d
--- /dev/null
+++ b/dev-util/skipfish/skipfish-1.27_beta.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/skipfish/skipfish-1.27_beta.ebuild,v 1.1 2010/03/30 18:24:43 ssuominen Exp $
+
+EAPI=2
+inherit toolchain-funcs
+
+DESCRIPTION="A fully automated, active web application security reconnaissance tool"
+HOMEPAGE="http://code.google.com/p/skipfish/"
+SRC_URI="http://${PN}.googlecode.com/files/${P/_beta/b}.tgz"
+
+LICENSE="Apache-2.0 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="dev-libs/openssl
+ net-dns/libidn
+ sys-libs/zlib"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ sed -i \
+ -e '/CFLAGS_GEN/s:-g -ggdb::' \
+ -e '/CFLAGS_OPT/s:-O3::' \
+ Makefile || die
+
+ sed -i \
+ -e "/ASSETS_DIR/s:assets:/usr/share/doc/${PF}/html:" \
+ config.h || die
+}
+
+src_compile() {
+ tc-export CC
+
+ local _debug
+ use debug && _debug=debug
+
+ emake ${_debug} || die
+}
+
+src_install() {
+ dobin ${PN} || die
+ doman ${PN}.1 || die
+
+ insinto /usr/share/${PN}/dictionaries
+ doins dictionaries/*.wl || die
+
+ dohtml assets/* || die
+
+ dodoc ChangeLog dictionaries/README-FIRST README
+}