summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-04-12 02:55:26 +0000
committerJeroen Roovers <jer@gentoo.org>2011-04-12 02:55:26 +0000
commitc83a6d61bd6eaea2a8c73b8660f2c15e555e0a9c (patch)
tree5689b5d96d0872cb8d4c62d4c5e3d185d17c03cb /dev-util/shc
parentold (diff)
downloadgentoo-2-c83a6d61bd6eaea2a8c73b8660f2c15e555e0a9c.tar.gz
gentoo-2-c83a6d61bd6eaea2a8c73b8660f2c15e555e0a9c.tar.bz2
gentoo-2-c83a6d61bd6eaea2a8c73b8660f2c15e555e0a9c.zip
Version bump. Add quoting. Remove anti-stripping sed script since we do not use install anyway. Move tc-getCC call to where it will be used.
(Portage version: 2.2.0_alpha29/cvs/Linux i686)
Diffstat (limited to 'dev-util/shc')
-rw-r--r--dev-util/shc/ChangeLog10
-rw-r--r--dev-util/shc/shc-3.8.7.ebuild35
2 files changed, 43 insertions, 2 deletions
diff --git a/dev-util/shc/ChangeLog b/dev-util/shc/ChangeLog
index 3ced4740461e..9ba6a820a194 100644
--- a/dev-util/shc/ChangeLog
+++ b/dev-util/shc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/shc
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/shc/ChangeLog,v 1.16 2010/08/30 22:22:02 xmw Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/shc/ChangeLog,v 1.17 2011/04/12 02:55:26 jer Exp $
+
+*shc-3.8.7 (12 Apr 2011)
+
+ 12 Apr 2011; Jeroen Roovers <jer@gentoo.org> +shc-3.8.7.ebuild:
+ Version bump. Add quoting. Remove anti-stripping sed script since we do not
+ use install anyway. Move tc-getCC call to where it will be used.
30 Aug 2010; Michael Weber (xmw) <xmw@gentoo.org> shc-3.8.3.ebuild:
Respect LDFLAGS, do not strip by intall -s, fixes bug 335333
diff --git a/dev-util/shc/shc-3.8.7.ebuild b/dev-util/shc/shc-3.8.7.ebuild
new file mode 100644
index 000000000000..fc4fedd10beb
--- /dev/null
+++ b/dev-util/shc/shc-3.8.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/shc/shc-3.8.7.ebuild,v 1.1 2011/04/12 02:55:26 jer Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+DESCRIPTION="A (shell-) script compiler/scrambler"
+HOMEPAGE="http://www.datsi.fi.upm.es/~frosal"
+SRC_URI="http://www.datsi.fi.upm.es/~frosal/sources/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~ppc ~sparc ~x86"
+IUSE=""
+
+RESTRICT="test"
+
+src_prepare() {
+ # respect LDFLAGS
+ sed -i Makefile -e 's:$(CC) $(CFLAGS):& $(LDFLAGS):' || die
+}
+
+src_compile() {
+ ## the "test"-target leads to an access-violation -> so we skip it
+ ## as it's only for demonstration purposes anyway.
+ emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" shc || die
+}
+
+src_install() {
+ dobin shc || die
+ doman shc.1 || die
+ dodoc shc.README CHANGES || die
+}