summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarien Zwart <marienz@gentoo.org>2007-02-19 21:08:15 +0000
committerMarien Zwart <marienz@gentoo.org>2007-02-19 21:08:15 +0000
commit9113248f75a317e2305671f0dc62cd10a5669dd5 (patch)
tree97a9e2a8c154605de77ac3a450cfca47d912b614 /dev-util/pkgcore-checks/pkgcore-checks-0.3.2.ebuild
parentBump & cleanup (diff)
downloadgentoo-2-9113248f75a317e2305671f0dc62cd10a5669dd5.tar.gz
gentoo-2-9113248f75a317e2305671f0dc62cd10a5669dd5.tar.bz2
gentoo-2-9113248f75a317e2305671f0dc62cd10a5669dd5.zip
Version bump.
(Portage version: 2.1.2-r9)
Diffstat (limited to 'dev-util/pkgcore-checks/pkgcore-checks-0.3.2.ebuild')
-rw-r--r--dev-util/pkgcore-checks/pkgcore-checks-0.3.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/pkgcore-checks/pkgcore-checks-0.3.2.ebuild b/dev-util/pkgcore-checks/pkgcore-checks-0.3.2.ebuild
new file mode 100644
index 000000000000..e1fdd92aec6e
--- /dev/null
+++ b/dev-util/pkgcore-checks/pkgcore-checks-0.3.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgcore-checks/pkgcore-checks-0.3.2.ebuild,v 1.1 2007/02/19 21:08:15 marienz Exp $
+
+inherit distutils eutils
+
+DESCRIPTION="pkgcore developmental repoman replacement"
+HOMEPAGE="http://www.pkgcore.org/"
+SRC_URI="http://www.pkgcore.org/releases/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=sys-apps/pkgcore-0.2.3
+ >=dev-lang/python-2.4"
+DEPEND=">=dev-lang/python-2.4"
+
+DOCS="NEWS AUTHORS"
+
+src_test() {
+ "${python}" setup.py test || die "tests returned non zero"
+}
+
+pkg_postinst() {
+ einfo "updating pkgcore plugin cache"
+ pplugincache pkgcore_checks.plugins pkgcore.plugins
+}