summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2010-07-15 14:50:44 +0000
committerFabio Erculiani <lxnay@gentoo.org>2010-07-15 14:50:44 +0000
commit929215e5c6fd4ccedc8a0ef212159437b80b5e66 (patch)
treece2e5521e5167838a88ab6d9c7a2c473bf44b2c8 /dev-util/molecule
parentVersion bump (diff)
downloadgentoo-2-929215e5c6fd4ccedc8a0ef212159437b80b5e66.tar.gz
gentoo-2-929215e5c6fd4ccedc8a0ef212159437b80b5e66.tar.bz2
gentoo-2-929215e5c6fd4ccedc8a0ef212159437b80b5e66.zip
version bump to 0.9.10.20
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/molecule')
-rw-r--r--dev-util/molecule/ChangeLog8
-rw-r--r--dev-util/molecule/molecule-0.9.10.20.ebuild37
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-util/molecule/ChangeLog b/dev-util/molecule/ChangeLog
index 1ea89084986d..aadcdb360069 100644
--- a/dev-util/molecule/ChangeLog
+++ b/dev-util/molecule/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/molecule
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/molecule/ChangeLog,v 1.8 2010/07/12 14:32:39 lxnay Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/molecule/ChangeLog,v 1.9 2010/07/15 14:50:44 lxnay Exp $
+
+*molecule-0.9.10.20 (15 Jul 2010)
+
+ 15 Jul 2010; Fabio Erculiani <lxnay@gentoo.org>
+ +molecule-0.9.10.20.ebuild:
+ version bump to 0.9.10.20
*molecule-0.9.10.11 (12 Jul 2010)
diff --git a/dev-util/molecule/molecule-0.9.10.20.ebuild b/dev-util/molecule/molecule-0.9.10.20.ebuild
new file mode 100644
index 000000000000..4b1fed9e4c31
--- /dev/null
+++ b/dev-util/molecule/molecule-0.9.10.20.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/molecule/molecule-0.9.10.20.ebuild,v 1.1 2010/07/15 14:50:44 lxnay Exp $
+
+EAPI="2"
+PYTHON_DEPEND="*"
+
+inherit multilib python
+
+DESCRIPTION="Release metatool used for creating Sabayon (and Gentoo) releases"
+HOMEPAGE="http://www.sabayon.org"
+SRC_URI="http://distfiles.sabayon.org/dev-util/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-util/intltool
+ sys-devel/gettext"
+RDEPEND="net-misc/rsync
+ sys-fs/squashfs-tools
+ virtual/cdrtools"
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="/usr/$(get_libdir)" \
+ PREFIX="/usr" SYSCONFDIR="/etc" install \
+ || die "emake install failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize "/usr/$(get_libdir)/molecule"
+}
+
+pkg_postrm() {
+ python_mod_cleanup "/usr/$(get_libdir)/molecule"
+}