summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-12-28 12:33:07 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-12-28 12:33:07 +0000
commit8d9c75b30fd7153264defb52deb74cc08ae22333 (patch)
tree308ff12d023fcd08273275270138eb15b2d18c40 /dev-util/kdevplatform
parentMarked ~hppa too. (diff)
downloadgentoo-2-8d9c75b30fd7153264defb52deb74cc08ae22333.tar.gz
gentoo-2-8d9c75b30fd7153264defb52deb74cc08ae22333.tar.bz2
gentoo-2-8d9c75b30fd7153264defb52deb74cc08ae22333.zip
Version bump. Drop older.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/kdevplatform')
-rw-r--r--dev-util/kdevplatform/ChangeLog8
-rw-r--r--dev-util/kdevplatform/kdevplatform-0.9.97.ebuild (renamed from dev-util/kdevplatform/kdevplatform-0.9.96.ebuild)39
2 files changed, 32 insertions, 15 deletions
diff --git a/dev-util/kdevplatform/ChangeLog b/dev-util/kdevplatform/ChangeLog
index 4d9e9c042f44..8366db7f88d8 100644
--- a/dev-util/kdevplatform/ChangeLog
+++ b/dev-util/kdevplatform/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/kdevplatform
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/kdevplatform/ChangeLog,v 1.15 2009/12/10 18:25:05 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/kdevplatform/ChangeLog,v 1.16 2009/12/28 12:33:07 scarabeus Exp $
+
+*kdevplatform-0.9.97 (28 Dec 2009)
+
+ 28 Dec 2009; Tomáš Chvátal <scarabeus@gentoo.org>
+ -kdevplatform-0.9.96.ebuild, +kdevplatform-0.9.97.ebuild:
+ Version bump. Drop older.
10 Dec 2009; Christian Faulhammer <fauli@gentoo.org>
kdevplatform-0.9.95.ebuild:
diff --git a/dev-util/kdevplatform/kdevplatform-0.9.96.ebuild b/dev-util/kdevplatform/kdevplatform-0.9.97.ebuild
index 262842127fc6..2f7924d91075 100644
--- a/dev-util/kdevplatform/kdevplatform-0.9.96.ebuild
+++ b/dev-util/kdevplatform/kdevplatform-0.9.97.ebuild
@@ -1,15 +1,21 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/kdevplatform/kdevplatform-0.9.96.ebuild,v 1.3 2009/11/22 04:51:02 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/kdevplatform/kdevplatform-0.9.97.ebuild,v 1.1 2009/12/28 12:33:07 scarabeus Exp $
EAPI="2"
-inherit kde4-base versionator
+KMNAME="extragear/sdk"
+inherit kde4-base
-KDEVELOP_PV="$(($(get_major_version)+3)).$(get_after_major_version)"
+if [[ ${PV} == *9999* ]]; then
+ KDEVELOP_PV="9999"
+else
+ inherit versionator
+ KDEVELOP_PV="$(($(get_major_version)+3)).$(get_after_major_version)"
+fi
DESCRIPTION="KDE development support libraries and apps"
HOMEPAGE="http://www.kdevelop.org/"
-SRC_URI="mirror://kde/unstable/kdevelop/${KDEVELOP_PV}/src/${P}.tar.bz2"
+[[ ${PV} != *9999* ]] && SRC_URI="mirror://kde/unstable/kdevelop/${KDEVELOP_PV}/src/${P}.tar.bz2"
LICENSE="GPL-2 LGPL-2"
KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
@@ -19,33 +25,38 @@ SLOT="4"
IUSE="cvs debug mercurial subversion"
DEPEND="
- >=dev-libs/boost-1.35.0
+ dev-libs/boost
subversion? ( >=dev-util/subversion-1.3 )
"
# Moved to playground for now
# bazaar? ( dev-util/bzr )
# git? ( dev-util/git )
+# block - some plugins moved to kdevplatform from kdevelop
RDEPEND="${DEPEND}
+ !<dev-util/kdevelop-${KDEVELOP_PV}
cvs? ( dev-util/cvs )
mercurial? ( dev-util/mercurial )
- !<dev-util/kdevelop-3.9.96:4
"
+src_prepare() {
+ kde4-base_src_prepare
+
+ # FindKDevPlatform.cmake is installed by kdelibs
+ sed -i \
+ -e '/^add_subdirectory(modules)/s/^/#DONOTINSTALL/' \
+ cmake/CMakeLists.txt || die
+}
+
# Moved to playground for now
# $(cmake-utils_use_build bazaar)
# $(cmake-utils_use_build git)
src_configure() {
- mycmakeargs="${mycmakeargs}
+ mycmakeargs=(
$(cmake-utils_use_build cvs)
$(cmake-utils_use_build mercurial)
$(cmake-utils_use_build subversion)
- $(cmake-utils_use_with subversion SubversionLibrary)"
+ $(cmake-utils_use_with subversion SubversionLibrary)
+ )
kde4-base_src_configure
}
-
-src_install() {
- kde4-base_src_install
-
- rm "${D}/${PREFIX}"/share/apps/cmake/modules/FindKDevPlatform.cmake
-}