summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2004-07-02 21:17:32 +0000
committerSeemant Kulleen <seemant@gentoo.org>2004-07-02 21:17:32 +0000
commit88d061c800fcff3047c92a6b367e763150cd0cb8 (patch)
tree61c08bd6a167a6378867b21fceb90a6458dcdf26 /dev-util/global/global-4.7.2.ebuild
parent~amd64 (Manifest recommit) (diff)
downloadgentoo-2-88d061c800fcff3047c92a6b367e763150cd0cb8.tar.gz
gentoo-2-88d061c800fcff3047c92a6b367e763150cd0cb8.tar.bz2
gentoo-2-88d061c800fcff3047c92a6b367e763150cd0cb8.zip
version bump -- this works with our sort
Diffstat (limited to 'dev-util/global/global-4.7.2.ebuild')
-rw-r--r--dev-util/global/global-4.7.2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-util/global/global-4.7.2.ebuild b/dev-util/global/global-4.7.2.ebuild
new file mode 100644
index 000000000000..e48925ad653d
--- /dev/null
+++ b/dev-util/global/global-4.7.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/global/global-4.7.2.ebuild,v 1.1 2004/07/02 21:17:32 seemant Exp $
+
+IUSE="ssl postgres"
+
+DESCRIPTION="Global can find the locations of specified object in C, C++, Yacc, Java and assembler source files."
+HOMEPAGE="http://www.gnu.org/software/global/"
+SRC_URI="ftp://ftp.gnu.org/gnu/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~mips"
+
+DEPEND=">=sys-libs/glibc-2.2
+ postgres? ( >=dev-db/postgresql-7.1 )
+ ssl? ( >=dev-libs/openssl-0.9.6-r1 )"
+
+src_compile() {
+ local myconf
+
+ if use postgres; then
+ myconf="--with-postgres=/usr"
+ if use ssl; then
+ # Patch configure to add -lssl when using postgresql and ssl
+ sed -i 's/-lcrypt/-lcrypt -lssl/' configure || die 'sed failed'
+ fi
+ fi
+
+ econf || die "econf failed"
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ insinto /etc
+ doins gtags.conf
+ dodoc AUTHORS COPYING INSTALL LICENSE NEWS README THANKS
+ insinto /usr/share/${PN}
+ doins gtags.el gtags.pl globash.rc
+}