summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-07-11 20:57:08 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-07-11 20:57:08 +0000
commit1d11124937c511ea6e3f8fe4452ab346d816a8e5 (patch)
treed7df1efc57d8eafb91a92f3cd65d4f9db141ed47 /dev-util/gitosis-gentoo
parentAdd ~ia64/sparc stable (diff)
downloadgentoo-2-1d11124937c511ea6e3f8fe4452ab346d816a8e5.tar.gz
gentoo-2-1d11124937c511ea6e3f8fe4452ab346d816a8e5.tar.bz2
gentoo-2-1d11124937c511ea6e3f8fe4452ab346d816a8e5.zip
Minor version bump: New version ignore comments and excess whitespace in SSH keys. Allows commenting of keydir contents.
(Portage version: 2.2_rc1/cvs/Linux 2.6.26-rc4-00103-g1beee8d x86_64)
Diffstat (limited to 'dev-util/gitosis-gentoo')
-rw-r--r--dev-util/gitosis-gentoo/ChangeLog9
-rw-r--r--dev-util/gitosis-gentoo/gitosis-gentoo-0.2_p20080711.ebuild40
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-util/gitosis-gentoo/ChangeLog b/dev-util/gitosis-gentoo/ChangeLog
index 6a6a64f4d1fe..186eaeec8eff 100644
--- a/dev-util/gitosis-gentoo/ChangeLog
+++ b/dev-util/gitosis-gentoo/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/gitosis-gentoo
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gitosis-gentoo/ChangeLog,v 1.1 2008/04/04 07:22:43 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gitosis-gentoo/ChangeLog,v 1.2 2008/07/11 20:57:08 robbat2 Exp $
+
+*gitosis-gentoo-0.2_p20080711 (11 Jul 2008)
+
+ 11 Jul 2008; Robin H. Johnson <robbat2@gentoo.org>
+ +gitosis-gentoo-0.2_p20080711.ebuild:
+ Minor version bump: New version ignore comments and excess whitespace in
+ SSH keys. Allows commenting of keydir contents.
*gitosis-gentoo-0.2_p20080203 (04 Apr 2008)
diff --git a/dev-util/gitosis-gentoo/gitosis-gentoo-0.2_p20080711.ebuild b/dev-util/gitosis-gentoo/gitosis-gentoo-0.2_p20080711.ebuild
new file mode 100644
index 000000000000..cbfab4c251eb
--- /dev/null
+++ b/dev-util/gitosis-gentoo/gitosis-gentoo-0.2_p20080711.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gitosis-gentoo/gitosis-gentoo-0.2_p20080711.ebuild,v 1.1 2008/07/11 20:57:08 robbat2 Exp $
+
+inherit distutils
+
+DESCRIPTION="gitosis -- software for hosting git repositories, Gentoo fork"
+HOMEPAGE="http://git.overlays.gentoo.org/gitweb/?p=proj/gitosis-gentoo.git"
+# This is a snapshot taken from the Gentoo overlays gitweb.
+MY_PV="20080711-800ac5b58a60de070a10cafce609f28fc2905691"
+MY_P="${PN}-${MY_PV}"
+SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE=""
+DEPEND=">=dev-util/git-1.5.3.6
+ >=dev-python/setuptools-0.6_rc5"
+RDEPEND="${DEPEND}
+ !dev-util/gitosis"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="example.conf gitweb.conf lighttpd-gitweb.conf TODO.rst"
+
+pkg_setup() {
+ enewgroup git
+ enewuser git -1 /bin/sh /var/spool/gitosis git
+}
+
+src_install() {
+ distutils_src_install
+ keepdir /var/spool/gitosis
+ fowners git:git /var/spool/gitosis
+}
+
+# We should handle more of this, but it requires the input of an SSH public key
+# from the user, and they may want to set up more configuration first.
+#pkg_config() {
+#}