summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2014-10-08 00:27:21 +0000
committerDavide Pesavento <pesa@gentoo.org>2014-10-08 00:27:21 +0000
commit1f9b2b34a0a928ef8ffccff4a4db49fd58cdfd74 (patch)
tree86ae6fdabc33d2b604e07a1f94ece145c8bbb7a6 /dev-util/eric
parentbump (diff)
downloadgentoo-2-1f9b2b34a0a928ef8ffccff4a4db49fd58cdfd74.tar.gz
gentoo-2-1f9b2b34a0a928ef8ffccff4a4db49fd58cdfd74.tar.bz2
gentoo-2-1f9b2b34a0a928ef8ffccff4a4db49fd58cdfd74.zip
Bump
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key 0xDADED6B2671CB57D!)
Diffstat (limited to 'dev-util/eric')
-rw-r--r--dev-util/eric/ChangeLog9
-rw-r--r--dev-util/eric/eric-4.5.25.ebuild96
-rw-r--r--dev-util/eric/eric-5.4.7.ebuild93
3 files changed, 197 insertions, 1 deletions
diff --git a/dev-util/eric/ChangeLog b/dev-util/eric/ChangeLog
index 00606703192a..ae3fb8a7b131 100644
--- a/dev-util/eric/ChangeLog
+++ b/dev-util/eric/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/eric
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/ChangeLog,v 1.212 2014/09/23 19:22:33 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/ChangeLog,v 1.213 2014/10/08 00:27:21 pesa Exp $
+
+*eric-5.4.7 (08 Oct 2014)
+*eric-4.5.25 (08 Oct 2014)
+
+ 08 Oct 2014; Davide Pesavento <pesa@gentoo.org> +eric-4.5.25.ebuild,
+ +eric-5.4.7.ebuild:
+ Bump
23 Sep 2014; Dirkjan Ochtman <djc@gentoo.org> metadata.xml:
Remove python, not a python library
diff --git a/dev-util/eric/eric-4.5.25.ebuild b/dev-util/eric/eric-4.5.25.ebuild
new file mode 100644
index 000000000000..7426ad2f9e8c
--- /dev/null
+++ b/dev-util/eric/eric-4.5.25.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/eric-4.5.25.ebuild,v 1.1 2014/10/08 00:27:21 pesa Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.7"
+SUPPORT_PYTHON_ABIS="1"
+# 2.4 and 2.5 are restricted to avoid conditional dependency on dev-python/simplejson
+RESTRICT_PYTHON_ABIS="2.4 2.5 3.* *-jython 2.7-pypy-*"
+
+PLOCALES="cs de en es fr it ru tr zh_CN"
+
+inherit eutils l10n python
+
+DESCRIPTION="A full featured Python IDE using PyQt4 and QScintilla"
+HOMEPAGE="http://eric-ide.python-projects.org/"
+
+SLOT="4"
+MY_PV=${PV/_rc/-RC}
+MY_P=${PN}${SLOT}-${MY_PV}
+
+BASE_URI="mirror://sourceforge/eric-ide/${PN}${SLOT}/stable/${MY_PV}"
+SRC_URI="${BASE_URI}/${MY_P}.tar.gz"
+for L in ${PLOCALES}; do
+ SRC_URI+=" linguas_${L}? ( ${BASE_URI}/${PN}${SLOT}-i18n-${L/zh_CN/zh_CN.GB2312}-${MY_PV}.tar.gz )"
+done
+unset L
+
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="kde"
+
+DEPEND="
+ >=dev-python/sip-4.12.4
+ >=dev-python/PyQt4-4.9.6-r1[X,help,svg,webkit]
+ >=dev-python/qscintilla-python-2.3
+ kde? ( kde-base/pykde4 )
+"
+RDEPEND="${DEPEND}
+ >=dev-python/chardet-2.0.1
+ >=dev-python/coverage-3.0.1
+ >=dev-python/pygments-1.5
+"
+
+S=${WORKDIR}/${MY_P}
+
+PYTHON_VERSIONED_EXECUTABLES=("/usr/bin/.*")
+
+src_prepare() {
+ epatch "${FILESDIR}/eric-4.5-no-interactive.patch"
+ use kde || epatch "${FILESDIR}/eric-4.4-no-pykde.patch"
+
+ # Delete internal copies of dev-python/chardet,
+ # dev-python/pygments and dev-python/simplejson
+ rm -fr eric/ThirdParty
+
+ # Delete internal copy of dev-python/coverage
+ rm -fr eric/DebugClients/Python{,3}/coverage
+ sed -i -e 's/from DebugClients\.Python3\?\.coverage/from coverage/' \
+ $(grep -lr 'from DebugClients\.Python3\?\.coverage' .) || die
+}
+
+src_install() {
+ installation() {
+ "$(PYTHON)" install.py \
+ -z \
+ -b "${EPREFIX}/usr/bin" \
+ -i "${T}/images/${PYTHON_ABI}" \
+ -d "${EPREFIX}$(python_get_sitedir)" \
+ -c
+ }
+ python_execute_function installation
+ python_merge_intermediate_installation_images "${T}/images"
+
+ doicon eric/icons/default/eric.png
+ make_desktop_entry "eric4 --nosplash" eric4 eric "Development;IDE;Qt"
+}
+
+pkg_postinst() {
+ python_mod_optimize eric4{,config.py,plugins}
+
+ elog "The following packages will give Eric extended functionality:"
+ elog " dev-python/cx_Freeze"
+ elog " dev-python/pyenchant"
+ elog " dev-python/pylint"
+ elog " dev-python/pysvn"
+ elog " dev-vcs/mercurial"
+ elog
+ elog "This version has a plugin interface with plugin-autofetch from"
+ elog "the application itself. You may want to check that as well."
+}
+
+pkg_postrm() {
+ python_mod_cleanup eric4{,config.py,plugins}
+}
diff --git a/dev-util/eric/eric-5.4.7.ebuild b/dev-util/eric/eric-5.4.7.ebuild
new file mode 100644
index 000000000000..16e5a3ca568a
--- /dev/null
+++ b/dev-util/eric/eric-5.4.7.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/eric-5.4.7.ebuild,v 1.1 2014/10/08 00:27:21 pesa Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python3_{3,4} )
+PYTHON_REQ_USE="sqlite,xml"
+PLOCALES="cs de en es fr it ru tr zh_CN"
+
+inherit eutils l10n python-single-r1
+
+DESCRIPTION="A full featured Python IDE using PyQt4 and QScintilla"
+HOMEPAGE="http://eric-ide.python-projects.org/"
+
+SLOT="5"
+MY_PV=${PV/_rc/-RC}
+MY_P=${PN}${SLOT}-${MY_PV}
+
+BASE_URI="mirror://sourceforge/eric-ide/${PN}${SLOT}/stable/${MY_PV}"
+SRC_URI="${BASE_URI}/${MY_P}.tar.gz"
+for L in ${PLOCALES}; do
+ SRC_URI+=" linguas_${L}? ( ${BASE_URI}/${PN}${SLOT}-i18n-${L/zh_CN/zh_CN.GB2312}-${MY_PV}.tar.gz )"
+done
+unset L
+
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ ${PYTHON_DEPS}
+ >=dev-python/sip-4.14.3[${PYTHON_USEDEP}]
+ >=dev-python/PyQt4-4.10[${PYTHON_USEDEP},X,help,sql,svg,webkit]
+ >=dev-python/qscintilla-python-2.7.1[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}
+ >=dev-python/chardet-2.0.1[${PYTHON_USEDEP}]
+ >=dev-python/coverage-3.2[${PYTHON_USEDEP}]
+ >=dev-python/pygments-1.6[${PYTHON_USEDEP}]
+"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ # Avoid file collisions between different slots of Eric
+ sed -i -e 's/^Icon=eric$/&5/' eric/eric5.desktop || die
+ sed -i -e 's/\([^[:alnum:]]\)eric\.png\([^[:alnum:]]\)/\1eric5.png\2/' \
+ $(grep -lr 'eric\.png' .) || die
+ mv eric/icons/default/eric{,5}.png || die
+ mv eric/pixmaps/eric{,5}.png || die
+ rm -f eric/APIs/Python/zope-*.api
+ rm -f eric/APIs/Ruby/Ruby-*.api
+
+ # Delete internal copies of dev-python/chardet and dev-python/pygments
+ rm -fr eric/ThirdParty/{CharDet,Pygments}
+
+ # Delete internal copy of dev-python/coverage
+ rm -fr eric/DebugClients/Python{,3}/coverage
+ sed -i -e 's/from DebugClients\.Python3\?\.coverage/from coverage/' \
+ $(grep -lr 'from DebugClients\.Python3\?\.coverage' .) || die
+
+ # Fix desktop files (bug 458092)
+ sed -i -e '/^Categories=/s:Python:X-&:' eric/eric5{,_webbrowser}.desktop || die
+}
+
+src_install() {
+ "${PYTHON}" install.py \
+ -b "${EPREFIX}/usr/bin" \
+ -d "$(python_get_sitedir)" \
+ -i "${D}" \
+ -c \
+ -z \
+ || die
+
+ python_optimize
+
+ doicon eric/icons/default/eric5.png
+ dodoc changelog THANKS
+}
+
+pkg_postinst() {
+ elog "The following packages will give Eric extended functionality:"
+ elog " dev-python/cx_Freeze"
+ elog " dev-python/pyenchant"
+ elog " dev-python/pylint"
+ elog " dev-python/pysvn"
+ elog " dev-vcs/mercurial"
+ elog
+ elog "This version has a plugin interface with plugin-autofetch from"
+ elog "the application itself. You may want to check that as well."
+}