summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-12-04 12:52:57 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-12-04 12:52:57 +0000
commit4b9b2fd14e9a0f705aa3e98178c5e2b627c4cf9f (patch)
treeed7d193bfa080dc5061b2ecda7a1d9a793513669 /dev-util/ddd
parentunmask x86 (diff)
downloadgentoo-2-4b9b2fd14e9a0f705aa3e98178c5e2b627c4cf9f.tar.gz
gentoo-2-4b9b2fd14e9a0f705aa3e98178c5e2b627c4cf9f.tar.bz2
gentoo-2-4b9b2fd14e9a0f705aa3e98178c5e2b627c4cf9f.zip
bug fix
Diffstat (limited to 'dev-util/ddd')
-rw-r--r--dev-util/ddd/ChangeLog11
-rw-r--r--dev-util/ddd/ddd-3.3.1-r3.ebuild66
-rw-r--r--dev-util/ddd/files/ddd-3.3.1-detect-hipot.patch28
-rw-r--r--dev-util/ddd/files/ddd-3.3.1-link-libstdc++.patch11
-rw-r--r--dev-util/ddd/files/digest-ddd-3.3.1-r32
5 files changed, 117 insertions, 1 deletions
diff --git a/dev-util/ddd/ChangeLog b/dev-util/ddd/ChangeLog
index 8dc46e876ead..85f713f37c22 100644
--- a/dev-util/ddd/ChangeLog
+++ b/dev-util/ddd/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-util/ddd
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-util/ddd/ChangeLog,v 1.3 2002/07/29 13:15:27 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ddd/ChangeLog,v 1.4 2002/12/04 12:52:57 azarah Exp $
+
+*ddd-3.3.1-r3 (05 Dec 2002)
+
+ 05 Dec 2002; Martin Schlemmer <azarah@gentoo.org> :
+
+ Fix detection of double hipot(double, double), added
+ ddd-3.3.1-detect-hipot.patch. Fix not linking to libstdc++,
+ ddd-3.3.1-link-libstdc++.patch. Fix sandbox errors (need to
+ pass 'tooldir=...' to 'make install'), closing bug #4614.
*ddd-3.3.1-r2 (29 Jul 2002)
diff --git a/dev-util/ddd/ddd-3.3.1-r3.ebuild b/dev-util/ddd/ddd-3.3.1-r3.ebuild
new file mode 100644
index 000000000000..5157d317daf2
--- /dev/null
+++ b/dev-util/ddd/ddd-3.3.1-r3.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ddd/ddd-3.3.1-r3.ebuild,v 1.1 2002/12/04 12:52:57 azarah Exp $
+
+IUSE=""
+
+inherit eutils
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="GNU DDD is a graphical front-end for command-line debuggers"
+HOMEPAGE="http://www.gnu.org/software/ddd"
+SRC_URI="ftp://ftp.easynet.be/gnu/ddd/${P}.tar.gz
+ ftp://ftp.easynet.be/gnu/ddd/${P}-html-manual.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2 LGPL-2.1 FDL-1.1"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64"
+
+DEPEND="virtual/x11
+ >=sys-devel/gdb-4.16
+ >=x11-libs/openmotif-2.1.30"
+
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/ddd
+ epatch ${FILESDIR}/ddd-3.3.1-gcc3-gentoo.patch
+
+ # Fix detection of double hipot(double, double)
+ # <azarah@gentoo.org> 05 Dec 2002
+ epatch ${FILESDIR}/ddd-3.3.1-detect-hipot.patch
+ # Fix not linking to libstdc++
+ # <azarah@gentoo.org> 05 Dec 2002
+ epatch ${FILESDIR}/ddd-3.3.1-link-libstdc++.patch
+}
+
+src_compile() {
+ CXXFLAGS="${CXXFLAGS} -Wno-deprecated"
+ econf || die
+ emake || die
+}
+
+src_install () {
+ dodir /usr/lib
+ # If using internal libiberty.a, need to pass
+ # $tooldir to 'make install', else we get
+ # sandbox errors ... bug #4614.
+ # <azarah@gentoo.org> 05 Dec 2002
+ einstall tooldir=${D}/usr || die
+
+ # This one is from binutils
+ if [ -f ${D}/usr/lib/libiberty.a ]
+ then
+ rm -f ${D}/usr/lib/libiberty.a
+ fi
+ # Remove empty dir ...
+ rmdir ${D}/usr/lib || :
+
+ mv ${S}/doc/README ${S}/doc/README-DOC
+ dodoc ANNOUNCE AUTHORS BUGS COPYING* CREDITS INSTALL NEWS* NICKNAMES \
+ OPENBUGS PROBLEMS README* TIPS TODO
+
+ mv ${S}/doc/* ${D}/usr/share/doc/${PF}
+}
+
diff --git a/dev-util/ddd/files/ddd-3.3.1-detect-hipot.patch b/dev-util/ddd/files/ddd-3.3.1-detect-hipot.patch
new file mode 100644
index 000000000000..28e9b9517f38
--- /dev/null
+++ b/dev-util/ddd/files/ddd-3.3.1-detect-hipot.patch
@@ -0,0 +1,28 @@
+--- ddd-3.3.1/ddd/configure.orig 2002-12-04 09:44:09.000000000 +0200
++++ ddd-3.3.1/ddd/configure 2002-12-04 10:45:04.000000000 +0200
+@@ -13282,13 +13282,14 @@
+ /* System header to define __stub macros and hopefully few prototypes,
+ which can conflict with char $ac_func(); below. */
+ #include <assert.h>
++#include <math.h>
+ /* Override any gcc2 internal prototype to avoid an error. */
+ #ifdef __cplusplus
+ extern "C"
+ #endif
+ /* We use char because int might match the return type of a gcc2
+ builtin and then its argument prototype would still apply. */
+-char $ac_func();
++/* char $ac_func(); */
+
+ int main() {
+
+@@ -13298,7 +13299,8 @@
+ #if defined (__stub_$ac_func) || defined (__stub___$ac_func)
+ choke me
+ #else
+-$ac_func();
++double x = 0, y =0;
++x = $ac_func(x, y);
+ #endif
+
+ ; return 0; }
diff --git a/dev-util/ddd/files/ddd-3.3.1-link-libstdc++.patch b/dev-util/ddd/files/ddd-3.3.1-link-libstdc++.patch
new file mode 100644
index 000000000000..075269af6523
--- /dev/null
+++ b/dev-util/ddd/files/ddd-3.3.1-link-libstdc++.patch
@@ -0,0 +1,11 @@
+--- ddd-3.3.1/ddd/Makefile.in.orig 2002-12-04 12:42:54.000000000 +0200
++++ ddd-3.3.1/ddd/Makefile.in 2002-12-04 12:43:18.000000000 +0200
+@@ -684,7 +684,7 @@
+ CXXCOMPILE = $(CXX) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CXXFLAGS) $(CXXFLAGS)
+ LTCXXCOMPILE = $(LIBTOOL) --mode=compile $(CXX) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CXXFLAGS) $(CXXFLAGS)
+ CXXLD = $(CXX)
+-CXXLINK = $(LIBTOOL) --mode=link $(CXXLD) $(AM_CXXFLAGS) $(CXXFLAGS) $(LDFLAGS) -o $@
++CXXLINK = $(LIBTOOL) --mode=link $(CXXLD) $(AM_CXXFLAGS) $(CXXFLAGS) $(LDFLAGS) $(CXXLIBS) -o $@
+ CFLAGS = @CFLAGS@
+ COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+ LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
diff --git a/dev-util/ddd/files/digest-ddd-3.3.1-r3 b/dev-util/ddd/files/digest-ddd-3.3.1-r3
new file mode 100644
index 000000000000..12b848a8cb9a
--- /dev/null
+++ b/dev-util/ddd/files/digest-ddd-3.3.1-r3
@@ -0,0 +1,2 @@
+MD5 38589618d7cd02a03d062bb116bbf1d2 ddd-3.3.1.tar.gz 5820713
+MD5 e74807d11ae6caaa2f3ef82791384ce0 ddd-3.3.1-html-manual.tar.gz 5129744