summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2010-03-06 16:25:25 +0000
committerFabian Groffen <grobian@gentoo.org>2010-03-06 16:25:25 +0000
commitb46333e9a177387ca43cd5a36c6ddeb95e15f181 (patch)
treeabe0a4b90be4bc238570240aa33e01de18dd5fe8 /dev-util/cvsps
parentalpha/ia64/sparc/x86 stable wrt #299765 and add unapplied patch wrt bug #303345 (diff)
downloadgentoo-2-b46333e9a177387ca43cd5a36c6ddeb95e15f181.tar.gz
gentoo-2-b46333e9a177387ca43cd5a36c6ddeb95e15f181.tar.bz2
gentoo-2-b46333e9a177387ca43cd5a36c6ddeb95e15f181.zip
Revbump for Prefix patches, transferred Prefix keywords, bug #307939
(Portage version: 2.2.00.15738-prefix/cvs/Darwin powerpc)
Diffstat (limited to 'dev-util/cvsps')
-rw-r--r--dev-util/cvsps/ChangeLog10
-rw-r--r--dev-util/cvsps/cvsps-2.1-r1.ebuild36
-rw-r--r--dev-util/cvsps/files/cvsps-2.1-solaris.patch131
3 files changed, 175 insertions, 2 deletions
diff --git a/dev-util/cvsps/ChangeLog b/dev-util/cvsps/ChangeLog
index 4515c1225137..c47894592598 100644
--- a/dev-util/cvsps/ChangeLog
+++ b/dev-util/cvsps/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/cvsps
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cvsps/ChangeLog,v 1.26 2008/06/10 18:17:10 armin76 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cvsps/ChangeLog,v 1.27 2010/03/06 16:25:24 grobian Exp $
+
+*cvsps-2.1-r1 (06 Mar 2010)
+
+ 06 Mar 2010; Fabian Groffen <grobian@gentoo.org> +cvsps-2.1-r1.ebuild,
+ +files/cvsps-2.1-solaris.patch:
+ Revbump for Prefix patches, transferred Prefix keywords, bug #307939
10 Jun 2008; Raúl Porcel <armin76@gentoo.org> cvsps-2.1.ebuild:
ia64 stable
diff --git a/dev-util/cvsps/cvsps-2.1-r1.ebuild b/dev-util/cvsps/cvsps-2.1-r1.ebuild
new file mode 100644
index 000000000000..1798243c8957
--- /dev/null
+++ b/dev-util/cvsps/cvsps-2.1-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cvsps/cvsps-2.1-r1.ebuild,v 1.1 2010/03/06 16:25:24 grobian Exp $
+
+inherit eutils
+
+MY_P="${P/_/}"
+DESCRIPTION="Generates patchset information from a CVS repository"
+HOMEPAGE="http://www.cobite.com/cvsps/"
+SRC_URI="http://www.cobite.com/cvsps/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="sys-libs/zlib"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-build.patch
+ epatch "${FILESDIR}"/${P}-solaris.patch
+ # no configure around
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ sed -i -e '/^LDLIBS+=/s/$/ -lsocket/' Makefile || die
+ fi
+}
+
+src_install() {
+ dobin cvsps || die
+ doman cvsps.1
+ dodoc README CHANGELOG
+}
diff --git a/dev-util/cvsps/files/cvsps-2.1-solaris.patch b/dev-util/cvsps/files/cvsps-2.1-solaris.patch
new file mode 100644
index 000000000000..3e063fd9248b
--- /dev/null
+++ b/dev-util/cvsps/files/cvsps-2.1-solaris.patch
@@ -0,0 +1,131 @@
+Modified version of
+http://cvs.openpkg.org/fileview?f=openpkg-src/cvsps/cvsps.patch&v=1.13
+
+Index: cache.c
+--- cache.c.orig 2008-04-02 03:18:44 +0200
++++ cache.c 2008-04-02 09:10:25 +0200
+@@ -361,7 +361,7 @@
+
+ strcpy(buff, p_buff);
+
+- while ((s = strsep(&p, ";")))
++ while ((s = my_strsep(&p, ";")))
+ {
+ char * c = strchr(s, ':');
+
+Index: cvs_direct.c
+--- cvs_direct.c.orig 2008-04-02 03:18:44 +0200
++++ cvs_direct.c 2008-04-02 09:10:25 +0200
+@@ -92,12 +92,12 @@
+
+ strcpy_a(root, p_root, PATH_MAX);
+
+- tok = strsep(&p, ":");
++ tok = my_strsep(&p, ":");
+
+ /* if root string looks like :pserver:... then the first token will be empty */
+ if (strlen(tok) == 0)
+ {
+- char * method = strsep(&p, ":");
++ char * method = my_strsep(&p, ":");
+ if (strcmp(method, "pserver") == 0)
+ {
+ ctx = open_ctx_pserver(ctx, p);
+@@ -185,14 +185,14 @@
+
+ strcpy_a(root, p_root, PATH_MAX);
+
+- tok = strsep(&p, ":");
++ tok = my_strsep(&p, ":");
+ if (strlen(tok) == 0 || !p)
+ {
+ debug(DEBUG_APPERROR, "parse error on third token");
+ goto out_free_err;
+ }
+
+- tok2 = strsep(&tok, "@");
++ tok2 = my_strsep(&tok, "@");
+ if (!strlen(tok2) || (!tok || !strlen(tok)))
+ {
+ debug(DEBUG_APPERROR, "parse error on user@server in pserver");
+@@ -272,7 +272,7 @@
+ strcpy_a(root, p_root, PATH_MAX);
+
+ /* if there's a ':', it's remote */
+- tok = strsep(&p, ":");
++ tok = my_strsep(&p, ":");
+
+ if (p)
+ {
+@@ -281,7 +281,7 @@
+ if (!cvs_rsh)
+ cvs_rsh = "rsh";
+
+- tok2 = strsep(&tok, "@");
++ tok2 = my_strsep(&tok, "@");
+
+ if (tok)
+ snprintf(execcmd, PATH_MAX, "%s -l %s %s %s server", cvs_rsh, tok2, tok, cvs_server);
+@@ -776,7 +776,7 @@
+ static int parse_patch_arg(char * arg, char ** str)
+ {
+ char *tok, *tok2 = "";
+- tok = strsep(str, " ");
++ tok = my_strsep(str, " ");
+ if (!tok)
+ return 0;
+
+@@ -796,7 +796,7 @@
+ /* see if command wants two args and they're separated by ' ' */
+ if (tok[2] == 0 && strchr("BdDFgiorVxYz", tok[1]))
+ {
+- tok2 = strsep(str, " ");
++ tok2 = my_strsep(str, " ");
+ if (!tok2)
+ {
+ debug(DEBUG_APPERROR, "diff_opts parse_error: argument %s requires two arguments", tok);
+Index: util.c
+--- util.c.orig 2008-04-02 03:18:44 +0200
++++ util.c 2008-04-02 09:10:25 +0200
+@@ -316,3 +316,31 @@
+ exit(1);
+ }
+ }
++
++char *my_strsep(char **stringp, const char *delim)
++{
++ char *s;
++ const char *spanp;
++ int c, sc;
++ char *tok;
++
++ if ((s = *stringp) == NULL)
++ return NULL;
++ for (tok = s;;) {
++ c = *s++;
++ spanp = delim;
++ do {
++ if ((sc = *spanp++) == c) {
++ if (c == 0)
++ s = NULL;
++ else
++ s[-1] = 0;
++ *stringp = s;
++ return tok;
++ }
++ } while (sc != 0);
++ }
++ /* NOTREACHED */
++ return NULL;
++}
++
+Index: util.h
+--- util.h.orig 2008-04-02 03:18:44 +0200
++++ util.h 2008-04-02 09:15:35 +0200
+@@ -24,5 +24,6 @@
+ void timing_stop(const char *);
+ int my_system(const char *);
+ int escape_filename(char *, int, const char *);
++char *my_strsep(char **, const char *);
+
+ #endif /* UTIL_H */