summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Duft <mduft@gentoo.org>2010-10-29 12:05:41 +0000
committerMarkus Duft <mduft@gentoo.org>2010-10-29 12:05:41 +0000
commita6f9e7c5ed1a1929eb1595862b4944ae2d3651e8 (patch)
tree062b2a8c8764ce78131c6ef5119fce4107314479 /dev-util/confix
parentStable on amd64 wrt bug #342847 (diff)
downloadgentoo-2-a6f9e7c5ed1a1929eb1595862b4944ae2d3651e8.tar.gz
gentoo-2-a6f9e7c5ed1a1929eb1595862b4944ae2d3651e8.tar.bz2
gentoo-2-a6f9e7c5ed1a1929eb1595862b4944ae2d3651e8.zip
added new version, update live ebuild
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'dev-util/confix')
-rw-r--r--dev-util/confix/ChangeLog8
-rw-r--r--dev-util/confix/confix-2.3.5.ebuild64
-rw-r--r--dev-util/confix/confix-9999.ebuild55
3 files changed, 101 insertions, 26 deletions
diff --git a/dev-util/confix/ChangeLog b/dev-util/confix/ChangeLog
index ca71c48c653a..5b409e193ba3 100644
--- a/dev-util/confix/ChangeLog
+++ b/dev-util/confix/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/confix
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/confix/ChangeLog,v 1.15 2010/10/11 12:45:54 haubi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/confix/ChangeLog,v 1.16 2010/10/29 12:05:41 mduft Exp $
+
+*confix-2.3.5 (29 Oct 2010)
+
+ 29 Oct 2010; Markus Duft <mduft@gentoo.org> +confix-2.3.5.ebuild,
+ confix-9999.ebuild:
+ add new version, update/fix live ebuild
11 Oct 2010; Michael Haubenwallner <haubi@gentoo.org>
confix-2.1.0-r4.ebuild:
diff --git a/dev-util/confix/confix-2.3.5.ebuild b/dev-util/confix/confix-2.3.5.ebuild
new file mode 100644
index 000000000000..2bffb6bbb711
--- /dev/null
+++ b/dev-util/confix/confix-2.3.5.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/confix/confix-2.3.5.ebuild,v 1.1 2010/10/29 12:05:41 mduft Exp $
+
+EAPI=3
+
+inherit distutils
+
+DESCRIPTION="Confix: A Build Tool on Top of GNU Automake"
+HOMEPAGE="http://confix.sourceforge.net"
+SRC_URI="mirror://sourceforge/confix/Confix-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~x86 ~ppc-aix ~hppa-hpux ~ia64-hpux ~x86-interix ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="dev-lang/python"
+RDEPEND="${DEPEND}
+ sys-devel/automake
+ sys-devel/libtool
+ sys-devel/autoconf-archive
+ dev-util/confix-wrapper
+"
+
+S="${WORKDIR}/Confix-${PV}"
+PYTHON_MODNAME="libconfix tests"
+
+src_prepare() {
+ # find jni-include dirs on hpux.
+ epatch "${FILESDIR}"/2.1.0/jni-hpux.patch
+ # add .exe extension to TESTS
+ epatch "${FILESDIR}"/2.3.0/exeext.patch
+ # use external autoconf archive
+ epatch "${FILESDIR}"/2.3.0/ext-ac-archive.patch
+ # link local libraries first.
+ epatch "${FILESDIR}"/2.3.0/local-libs-first.patch
+ # don't use automake 1.9, but any newer too...
+ epatch "${FILESDIR}"/2.3.0/new-automake.patch
+}
+
+pkg_preinst() {
+ local RV=2.3.0
+
+ if has_version "<dev-util/confix-${RV}"; then
+ einfo "After merging ${P} you might have to remerge all packages built"
+ einfo "with <dev-util/confix-${RV} in your EPREFIX to get all the"
+ einfo "repo files useable with current ${PN}".
+ ewarn
+ ewarn "Use this command (copy&paste) to identify packages built with confix"
+ ewarn "needing a remerge in your particular instance of Gentoo Prefix:"
+ ewarn
+ # use 'echo' to get this command from here:
+ ewarn "( cd \$(portageq envvar EPREFIX)/var/db/pkg || exit 1;" \
+ "pattern=\$(cd ../../.. && echo \$(ls -d" \
+ "usr/share/confix*/repo | grep -v confix-${RV}) |" \
+ "sed -e 's, ,|,g'); if [[ -z \${pattern} ]]; then echo" \
+ "'No more packages were built with broken Confix.'; exit 0;" \
+ "fi; emerge --ask --oneshot \$(grep -lE \"(\${pattern})\"" \
+ "*/*/CONTENTS | sed -e 's,^,>=,;s,/CONTENTS,,')" \
+ ")"
+ ewarn
+ fi
+}
diff --git a/dev-util/confix/confix-9999.ebuild b/dev-util/confix/confix-9999.ebuild
index ad9a40ec151e..2ed6f3ce3097 100644
--- a/dev-util/confix/confix-9999.ebuild
+++ b/dev-util/confix/confix-9999.ebuild
@@ -1,14 +1,13 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/confix/confix-9999.ebuild,v 1.4 2010/07/13 11:57:23 mduft Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/confix/confix-9999.ebuild,v 1.5 2010/10/29 12:05:41 mduft Exp $
-EAPI=2
+EAPI=3
inherit eutils distutils subversion
DESCRIPTION="Confix: A Build Tool on Top of GNU Automake"
HOMEPAGE="http://confix.sourceforge.net"
-
ESVN_REPO_URI="https://confix.svn.sourceforge.net/svnroot/confix/confix/trunk"
ESVN_PROJECT="${PN}"
@@ -30,30 +29,36 @@ PYTHON_MODNAME="libconfix tests"
src_prepare() {
# find jni-include dirs on hpux.
epatch "${FILESDIR}"/2.1.0/jni-hpux.patch
- # hack to ignore duplicate files in rescan
-# does not apply to trunk anymore
-# epatch "${FILESDIR}"/2.1.0/CALL_RESCAN_HACK.patch
# add .exe extension to TESTS
epatch "${FILESDIR}"/2.3.0/exeext.patch
# use external autoconf archive
epatch "${FILESDIR}"/2.3.0/ext-ac-archive.patch
- # enable SET_FILE_PROPERTIES(file, { 'PRIVATE_CINCLUDE', 1 })
-# does not apply to trunk anymore
-# epatch "${FILESDIR}"/2.1.0/private-headers.patch
- # enable fast installation rules.
-# does not apply to trunk anymore
-# epatch "${FILESDIR}"/2.1.0/fast-install.patch
-
- # need to store repos in exact versioned share/confix-PV/repo
- sed -i -e "s,\<confix2\>,confix-${PV}," \
- libconfix/plugins/automake/repo_automake.py \
- libconfix/core/machinery/repo.py \
- libconfix/plugins/cmake/consts.py \
- || die "cannot adjust repo dir"
-
- # adjust version-printing to have same version as share/confix-PV/repo,
- # to ease revdep-rebuild-alike scripts for rebuilding confix-packages.
- sed -i -e "/^CONFIX_VERSION[ ]*=/s,.*,CONFIX_VERSION = '${PV}'," \
- libconfix/core/utils/const.py \
- || die "cannot adjust confix version"
+ # link local libraries first.
+ epatch "${FILESDIR}"/2.3.0/local-libs-first.patch
+ # don't use automake 1.9, but any newer too...
+ epatch "${FILESDIR}"/2.3.0/new-automake.patch
+}
+
+pkg_preinst() {
+ local RV=2.3.0
+
+ if has_version "<dev-util/confix-${RV}"; then
+ einfo "After merging ${P} you might have to remerge all packages built"
+ einfo "with <dev-util/confix-${RV} in your EPREFIX to get all the"
+ einfo "repo files useable with current ${PN}".
+ ewarn
+ ewarn "Use this command (copy&paste) to identify packages built with confix"
+ ewarn "needing a remerge in your particular instance of Gentoo Prefix:"
+ ewarn
+ # use 'echo' to get this command from here:
+ ewarn "( cd \$(portageq envvar EPREFIX)/var/db/pkg || exit 1;" \
+ "pattern=\$(cd ../../.. && echo \$(ls -d" \
+ "usr/share/confix*/repo | grep -v confix-${RV}) |" \
+ "sed -e 's, ,|,g'); if [[ -z \${pattern} ]]; then echo" \
+ "'No more packages were built with broken Confix.'; exit 0;" \
+ "fi; emerge --ask --oneshot \$(grep -lE \"(\${pattern})\"" \
+ "*/*/CONTENTS | sed -e 's,^,>=,;s,/CONTENTS,,')" \
+ ")"
+ ewarn
+ fi
}