summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2007-11-25 05:49:27 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2007-11-25 05:49:27 +0000
commit57394722300273fd3b9d0429513fb7b031ba0f99 (patch)
treeab099b3d2f52d4e87b0c17b7c9ccf9807ed36f30 /dev-util/catalyst
parentVersion bump (diff)
downloadgentoo-2-57394722300273fd3b9d0429513fb7b031ba0f99.tar.gz
gentoo-2-57394722300273fd3b9d0429513fb7b031ba0f99.tar.bz2
gentoo-2-57394722300273fd3b9d0429513fb7b031ba0f99.zip
Version bump to 2.0.5_pre6 for testing. This version adds support for N32 on MIPS and also initial icecream cluster compiler support. Closing bug #197917 and bug #200095.
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-util/catalyst')
-rw-r--r--dev-util/catalyst/ChangeLog10
-rw-r--r--dev-util/catalyst/catalyst-2.0.5_pre6.ebuild75
-rw-r--r--dev-util/catalyst/files/digest-catalyst-2.0.5_pre63
3 files changed, 87 insertions, 1 deletions
diff --git a/dev-util/catalyst/ChangeLog b/dev-util/catalyst/ChangeLog
index 599eea581076..37d4e288bdc3 100644
--- a/dev-util/catalyst/ChangeLog
+++ b/dev-util/catalyst/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-util/catalyst
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.175 2007/11/13 22:54:39 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.176 2007/11/25 05:49:26 wolf31o2 Exp $
+
+*catalyst-2.0.5_pre6 (25 Nov 2007)
+
+ 25 Nov 2007; Chris Gianelloni <wolf31o2@gentoo.org>
+ +catalyst-2.0.5_pre6.ebuild:
+ Version bump to 2.0.5_pre6 for testing. This version adds support for N32 on
+ MIPS and also initial icecream cluster compiler support. Closing bug #197917
+ and bug #200095.
*catalyst-2.0.5_pre5 (13 Nov 2007)
diff --git a/dev-util/catalyst/catalyst-2.0.5_pre6.ebuild b/dev-util/catalyst/catalyst-2.0.5_pre6.ebuild
new file mode 100644
index 000000000000..37a9e4add231
--- /dev/null
+++ b/dev-util/catalyst/catalyst-2.0.5_pre6.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0.5_pre6.ebuild,v 1.1 2007/11/25 05:49:26 wolf31o2 Exp $
+
+inherit eutils
+
+DESCRIPTION="Gentoo Linux official release metatool"
+HOMEPAGE="http://www.gentoo.org/proj/en/releng/catalyst"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentoo.org/~wolf31o2/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+RESTRICT=""
+IUSE="ccache"
+
+DEPEND=""
+RDEPEND="dev-lang/python
+ app-crypt/shash
+ virtual/cdrtools
+ ccache? ( dev-util/ccache )
+ ia64? ( sys-fs/dosfstools )
+ kernel_linux? ( app-misc/zisofs-tools >=sys-fs/squashfs-tools-2.1 )"
+
+pkg_setup() {
+ if use ccache ; then
+ einfo "Enabling ccache support for catalyst."
+ else
+ ewarn "By default, ccache support for catalyst is disabled."
+ ewarn "If this is not what you intended,"
+ ewarn "then you should add ccache to your USE."
+ fi
+ echo
+ einfo "The template spec files are now installed by default. You can find"
+ einfo "them under /usr/share/doc/${PF}/examples"
+ einfo "and they are considered to be the authorative source of information"
+ einfo "on catalyst."
+}
+
+src_install() {
+ insinto /usr/lib/${PN}/arch
+ doins arch/* || die "copying arch/*"
+ insinto /usr/lib/${PN}/modules
+ doins modules/* || die "copying modules/*"
+ insinto /usr/lib/${PN}/livecd/cdtar
+ doins livecd/cdtar/* || die "copying cdtar/*"
+ insinto /usr/lib/${PN}/livecd/files
+ doins livecd/files/* || die "copying files/*"
+ for x in targets/*; do
+ exeinto /usr/lib/${PN}/$x
+ doexe $x/* || die "copying ${x}"
+ done
+ exeinto /usr/lib/${PN}
+ doexe catalyst || die "copying catalyst"
+ dodir /usr/bin
+ dosym /usr/lib/${PN}/catalyst /usr/bin/catalyst
+ insinto /etc/catalyst
+ doins files/catalyst.conf files/catalystrc || die "copying configuration"
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/* || die
+ dodoc README ChangeLog ChangeLog.old AUTHORS
+ doman files/catalyst.1
+ # Here is where we actually enable ccache
+ use ccache && \
+ dosed 's:options="autoresume kern:options="autoresume ccache kern:' \
+ /etc/catalyst/catalyst.conf
+}
+
+pkg_postinst() {
+ einfo "You can find more information about catalyst by checking out the"
+ einfo "catalyst project page at:"
+ einfo "http://www.gentoo.org/proj/en/releng/catalyst/index.xml"
+ echo
+}
diff --git a/dev-util/catalyst/files/digest-catalyst-2.0.5_pre6 b/dev-util/catalyst/files/digest-catalyst-2.0.5_pre6
new file mode 100644
index 000000000000..a39bfd042388
--- /dev/null
+++ b/dev-util/catalyst/files/digest-catalyst-2.0.5_pre6
@@ -0,0 +1,3 @@
+MD5 4a977cd4ab7c66787fe80c041cc63e4f catalyst-2.0.5_pre6.tar.bz2 788870
+RMD160 048db9fe8c110ac2137d1082405d4de3d2d3a746 catalyst-2.0.5_pre6.tar.bz2 788870
+SHA256 caa04f22e8e3aa03f6a0094650facd47ea212fd6da800d674c025fb93b286838 catalyst-2.0.5_pre6.tar.bz2 788870