summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-10-24 09:20:57 +0000
committerMike Frysinger <vapier@gentoo.org>2009-10-24 09:20:57 +0000
commit68a83af60768f680ce31720daa9490e9fd1b078c (patch)
tree47c113898a96873e95ca139073275d847434a882 /dev-util/boost-build
parentSmall dep fix for USE=fam (diff)
downloadgentoo-2-68a83af60768f680ce31720daa9490e9fd1b078c.tar.gz
gentoo-2-68a83af60768f680ce31720daa9490e9fd1b078c.tar.bz2
gentoo-2-68a83af60768f680ce31720daa9490e9fd1b078c.zip
Add missing `die` check to tarball unpack.
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/boost-build')
-rw-r--r--dev-util/boost-build/ChangeLog8
-rw-r--r--dev-util/boost-build/boost-build-1.35.0-r2.ebuild4
-rw-r--r--dev-util/boost-build/boost-build-1.36.0.ebuild4
-rw-r--r--dev-util/boost-build/boost-build-1.37.0.ebuild4
-rw-r--r--dev-util/boost-build/boost-build-1.39.0.ebuild4
-rw-r--r--dev-util/boost-build/boost-build-1.40.0.ebuild4
6 files changed, 17 insertions, 11 deletions
diff --git a/dev-util/boost-build/ChangeLog b/dev-util/boost-build/ChangeLog
index f11356d2b37d..8bbdfb09b89d 100644
--- a/dev-util/boost-build/ChangeLog
+++ b/dev-util/boost-build/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/boost-build
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/ChangeLog,v 1.40 2009/10/23 13:19:31 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/ChangeLog,v 1.41 2009/10/24 09:20:57 vapier Exp $
+
+ 24 Oct 2009; Mike Frysinger <vapier@gentoo.org>
+ boost-build-1.35.0-r2.ebuild, boost-build-1.36.0.ebuild,
+ boost-build-1.37.0.ebuild, boost-build-1.39.0.ebuild,
+ boost-build-1.40.0.ebuild:
+ Add missing `die` check to tarball unpack.
23 Oct 2009; Jeroen Roovers <jer@gentoo.org> boost-build-1.35.0-r2.ebuild:
Stable for HPPA (bug #288723).
diff --git a/dev-util/boost-build/boost-build-1.35.0-r2.ebuild b/dev-util/boost-build/boost-build-1.35.0-r2.ebuild
index c03a7f67083d..45d14023fff8 100644
--- a/dev-util/boost-build/boost-build-1.35.0-r2.ebuild
+++ b/dev-util/boost-build/boost-build-1.35.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/boost-build-1.35.0-r2.ebuild,v 1.5 2009/10/23 13:19:31 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/boost-build-1.35.0-r2.ebuild,v 1.6 2009/10/24 09:20:57 vapier Exp $
EAPI="2"
@@ -24,7 +24,7 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/boost_${MY_PV}/tools"
src_unpack() {
- tar xjpf "${DISTDIR}/${A}" boost_${MY_PV}/tools/{jam,build/v2}
+ tar xjpf "${DISTDIR}/${A}" boost_${MY_PV}/tools/{jam,build/v2} || die
}
src_prepare() {
diff --git a/dev-util/boost-build/boost-build-1.36.0.ebuild b/dev-util/boost-build/boost-build-1.36.0.ebuild
index 85b6a98ce589..11388de9f1fb 100644
--- a/dev-util/boost-build/boost-build-1.36.0.ebuild
+++ b/dev-util/boost-build/boost-build-1.36.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/boost-build-1.36.0.ebuild,v 1.2 2009/03/24 04:34:42 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/boost-build-1.36.0.ebuild,v 1.3 2009/10/24 09:20:57 vapier Exp $
EAPI="2"
@@ -25,7 +25,7 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/boost_${MY_PV}/tools"
src_unpack() {
- tar xjpf "${DISTDIR}/${A}" boost_${MY_PV}/tools/{jam,build/v2}
+ tar xjpf "${DISTDIR}/${A}" boost_${MY_PV}/tools/{jam,build/v2} || die
}
src_prepare() {
diff --git a/dev-util/boost-build/boost-build-1.37.0.ebuild b/dev-util/boost-build/boost-build-1.37.0.ebuild
index ec9a5f04cebe..d64405d50389 100644
--- a/dev-util/boost-build/boost-build-1.37.0.ebuild
+++ b/dev-util/boost-build/boost-build-1.37.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/boost-build-1.37.0.ebuild,v 1.2 2009/03/24 04:34:42 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/boost-build-1.37.0.ebuild,v 1.3 2009/10/24 09:20:57 vapier Exp $
EAPI="2"
@@ -25,7 +25,7 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/boost_${MY_PV}/tools"
src_unpack() {
- tar xjpf "${DISTDIR}/${A}" boost_${MY_PV}/tools/{jam,build/v2}
+ tar xjpf "${DISTDIR}/${A}" boost_${MY_PV}/tools/{jam,build/v2} || die
}
src_prepare() {
diff --git a/dev-util/boost-build/boost-build-1.39.0.ebuild b/dev-util/boost-build/boost-build-1.39.0.ebuild
index 45d36c617eac..8a628b77a769 100644
--- a/dev-util/boost-build/boost-build-1.39.0.ebuild
+++ b/dev-util/boost-build/boost-build-1.39.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/boost-build-1.39.0.ebuild,v 1.1 2009/07/16 09:33:38 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/boost-build-1.39.0.ebuild,v 1.2 2009/10/24 09:20:57 vapier Exp $
EAPI="2"
@@ -25,7 +25,7 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/boost_${MY_PV}/tools"
src_unpack() {
- tar xjpf "${DISTDIR}/${A}" boost_${MY_PV}/tools/{jam,build/v2}
+ tar xjpf "${DISTDIR}/${A}" boost_${MY_PV}/tools/{jam,build/v2} || die
}
src_prepare() {
diff --git a/dev-util/boost-build/boost-build-1.40.0.ebuild b/dev-util/boost-build/boost-build-1.40.0.ebuild
index 6e5c2628b4f0..edd0cf466a3b 100644
--- a/dev-util/boost-build/boost-build-1.40.0.ebuild
+++ b/dev-util/boost-build/boost-build-1.40.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/boost-build-1.40.0.ebuild,v 1.1 2009/10/21 12:47:47 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/boost-build-1.40.0.ebuild,v 1.2 2009/10/24 09:20:57 vapier Exp $
EAPI="2"
@@ -25,7 +25,7 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/boost_${MY_PV}/tools"
src_unpack() {
- tar xjpf "${DISTDIR}/${A}" boost_${MY_PV}/tools/{jam,build/v2}
+ tar xjpf "${DISTDIR}/${A}" boost_${MY_PV}/tools/{jam,build/v2} || die
}
src_prepare() {