summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2011-02-15 23:07:52 +0000
committerChristoph Junghans <ottxor@gentoo.org>2011-02-15 23:07:52 +0000
commit78ecf6c3b8478740d370cc7dd9998229675c9320 (patch)
tree6ce64257b9fecc11354b3f702be3dc0c9e276700 /dev-tex/latexmk
parentMask xorg-server-1.7 and friends for removal in 30 days. (diff)
downloadgentoo-2-78ecf6c3b8478740d370cc7dd9998229675c9320.tar.gz
gentoo-2-78ecf6c3b8478740d370cc7dd9998229675c9320.tar.bz2
gentoo-2-78ecf6c3b8478740d370cc7dd9998229675c9320.zip
version bump
(Portage version: 2.1.9.25/cvs/Linux i686)
Diffstat (limited to 'dev-tex/latexmk')
-rw-r--r--dev-tex/latexmk/ChangeLog10
-rw-r--r--dev-tex/latexmk/files/completion.bash-245
-rw-r--r--dev-tex/latexmk/latexmk-422e.ebuild29
3 files changed, 82 insertions, 2 deletions
diff --git a/dev-tex/latexmk/ChangeLog b/dev-tex/latexmk/ChangeLog
index 55cb668fcb84..8c0321afa4e6 100644
--- a/dev-tex/latexmk/ChangeLog
+++ b/dev-tex/latexmk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-tex/latexmk
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/latexmk/ChangeLog,v 1.21 2010/12/01 21:12:27 grobian Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/latexmk/ChangeLog,v 1.22 2011/02/15 23:07:52 ottxor Exp $
+
+*latexmk-422e (15 Feb 2011)
+
+ 15 Feb 2011; Christoph Junghans <ottxor@gentoo.org> +files/completion.bash-2,
+ +latexmk-422e.ebuild:
+ Version bump
01 Dec 2010; Fabian Groffen <grobian@gentoo.org> latexmk-418.ebuild:
Marked ~ppc-macos
diff --git a/dev-tex/latexmk/files/completion.bash-2 b/dev-tex/latexmk/files/completion.bash-2
new file mode 100644
index 000000000000..a24b7a819156
--- /dev/null
+++ b/dev-tex/latexmk/files/completion.bash-2
@@ -0,0 +1,45 @@
+#! /bin/bash
+
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2, or (at your option)
+# any later version.
+
+# bash_completion for latexmk
+#
+#
+# Author: Christoph Junghans
+# ottxor@gentoo.org
+#
+# Revision history:
+# 0.1 26-05-10 --- initial version
+# 0.2 15-02-11 --- clean up
+#
+# HOWTO:
+# source this file to enable it
+
+_latexmk()
+{
+ local cur output aopts opts prev
+ cur=${COMP_WORDS[COMP_CWORD]}
+ prev=${COMP_WORDS[COMP_CWORD-1]}
+
+ output=$( $1 -help 2> /dev/null)
+ #options with args ,pattern: ^ (-XXX) <YYYY>.*$
+ aopts=" $( echo " $output" | sed -n 's/^[[:space:]]\+\(-[^[:space:]]\+\)[[:space:]]\+<[^>]\+>.*$/\1/p' | sort -u | tr '\n' ' ')"
+ #if previous option in in $aopts
+ if [[ -n "$prev" ]] && [[ -z "${aopts//* $prev *}" ]]; then
+ #argument of $prev ,pattern: ^ -XXX (<YYYY>).*$
+ opts=$(echo "$output" | sed -n "s/^[[:space:]]\+$prev[[:space:]]\+\(<[^>]\+>\).*\$/\1/p")
+ COMPREPLY=( $( compgen -W '$opts' -- $cur ) )
+ elif [[ "$cur" == -* ]]; then
+ #all options, pattern: ^ (-XXX).*$
+ opts=$( echo "$output" | sed -n 's/^[[:space:]]\+\(-[^[:space:]]\+\).*$/\1/p'| sort -u )
+ COMPREPLY=( $( compgen -W '$opts' -- $cur ) )
+ else
+ #filenames *.tex and dirs, rest is done by '-o filenames' below
+ COMPREPLY=( $( eval compgen -f -X "!*.tex" -- ${cur} ) $( compgen -d -- $cur ) )
+ fi
+}
+
+complete -F _latexmk -o filenames latexmk
diff --git a/dev-tex/latexmk/latexmk-422e.ebuild b/dev-tex/latexmk/latexmk-422e.ebuild
new file mode 100644
index 000000000000..8241cdcf66f5
--- /dev/null
+++ b/dev-tex/latexmk/latexmk-422e.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/latexmk/latexmk-422e.ebuild,v 1.1 2011/02/15 23:07:52 ottxor Exp $
+
+inherit bash-completion
+
+DESCRIPTION="Perl script for automatically building LaTeX documents."
+HOMEPAGE="http://www.phys.psu.edu/~collins/software/latexmk/"
+SRC_URI="http://www.phys.psu.edu/~collins/software/latexmk/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~x86 ~ppc-macos"
+IUSE=""
+
+RDEPEND="virtual/latex-base
+ dev-lang/perl"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+src_install() {
+ cd "${WORKDIR}"
+ newbin latexmk.pl latexmk || die
+ dodoc CHANGES README latexmk.pdf latexmk.ps latexmk.txt || die
+ doman latexmk.1 || die
+ insinto /usr/share/doc/${PF}
+ doins -r example_rcfiles extra-scripts || die
+ dobashcompletion "${FILESDIR}"/completion.bash-2 ${PN}
+}