summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-05-16 13:11:21 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-05-16 13:11:21 +0000
commit88e3a02b935925b54bda01c96ec28a85f6b27429 (patch)
treed3d25d8979f4a95f839b2c55a240e3ca585be02c /dev-tcltk
parentStable on alpha, bug #270023 (diff)
downloadgentoo-2-88e3a02b935925b54bda01c96ec28a85f6b27429.tar.gz
gentoo-2-88e3a02b935925b54bda01c96ec28a85f6b27429.tar.bz2
gentoo-2-88e3a02b935925b54bda01c96ec28a85f6b27429.zip
Add patch to fix build on Gentoo/FreeBSD. Closes bug #270049.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/expect/ChangeLog8
-rw-r--r--dev-tcltk/expect/expect-5.44.1.ebuild6
-rw-r--r--dev-tcltk/expect/files/expect-5.44.1-gfbsd.patch19
3 files changed, 29 insertions, 4 deletions
diff --git a/dev-tcltk/expect/ChangeLog b/dev-tcltk/expect/ChangeLog
index a7804bdd34e4..f17e5fae26d3 100644
--- a/dev-tcltk/expect/ChangeLog
+++ b/dev-tcltk/expect/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-tcltk/expect
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/ChangeLog,v 1.51 2008/12/08 14:08:02 aballier Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/ChangeLog,v 1.52 2009/05/16 13:11:21 flameeyes Exp $
+
+ 16 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
+ expect-5.44.1.ebuild, +files/expect-5.44.1-gfbsd.patch:
+ Add patch to fix build on Gentoo/FreeBSD. Closes bug #270049.
08 Dec 2008; Alexis Ballier <aballier@gentoo.org> expect-5.43.0.ebuild,
expect-5.44.1.ebuild:
diff --git a/dev-tcltk/expect/expect-5.44.1.ebuild b/dev-tcltk/expect/expect-5.44.1.ebuild
index 6dc98ca08a41..89b1aa543f61 100644
--- a/dev-tcltk/expect/expect-5.44.1.ebuild
+++ b/dev-tcltk/expect/expect-5.44.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.44.1.ebuild,v 1.3 2008/12/08 14:08:02 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.44.1.ebuild,v 1.4 2009/05/16 13:11:21 flameeyes Exp $
WANT_AUTOCONF="2.5"
inherit autotools eutils
@@ -43,6 +43,8 @@ src_unpack() {
#slacky destdir support in Makefile
epatch "${FILESDIR}/${P}-destdir.patch"
+ epatch "${FILESDIR}/${P}-gfbsd.patch"
+
eautoconf
}
diff --git a/dev-tcltk/expect/files/expect-5.44.1-gfbsd.patch b/dev-tcltk/expect/files/expect-5.44.1-gfbsd.patch
new file mode 100644
index 000000000000..84f3bfeeb6fe
--- /dev/null
+++ b/dev-tcltk/expect/files/expect-5.44.1-gfbsd.patch
@@ -0,0 +1,19 @@
+Index: expect-5.44.1/tclconfig/tcl.m4
+===================================================================
+--- expect-5.44.1.orig/tclconfig/tcl.m4
++++ expect-5.44.1/tclconfig/tcl.m4
+@@ -1395,12 +1395,12 @@ dnl AC_CHECK_TOOL(AR, ar, :)
+ FreeBSD-*)
+ # FreeBSD 3.* and greater have ELF.
+ SHLIB_CFLAGS="-fPIC"
+- SHLIB_LD="ld -Bshareable -x"
++ SHLIB_LD="${CC} -shared"
+ SHLIB_LD_LIBS='${LIBS}'
+ SHLIB_SUFFIX=".so"
+ DL_OBJS="tclLoadDl.o"
+ DL_LIBS=""
+- LDFLAGS="$LDFLAGS -export-dynamic"
++ LDFLAGS="$LDFLAGS -Wl,-export-dynamic"
+ LD_SEARCH_FLAGS='-Wl,-rpath,${LIB_RUNTIME_DIR}'
+ if test "${TCL_THREADS}" = "1" ; then
+ # The -pthread needs to go in the CFLAGS, not LIBS