summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2005-07-02 15:20:41 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2005-07-02 15:20:41 +0000
commitdd99260429e2e4a3ecf10cd5fbdfe1b147c178c9 (patch)
tree297bed1d6624e14be3a3f0ac251b8f43baf0c885 /dev-tcltk/thread
parentStable on alpha. (diff)
downloadgentoo-2-dd99260429e2e4a3ecf10cd5fbdfe1b147c178c9.tar.gz
gentoo-2-dd99260429e2e4a3ecf10cd5fbdfe1b147c178c9.tar.bz2
gentoo-2-dd99260429e2e4a3ecf10cd5fbdfe1b147c178c9.zip
Initial ebuild. Bug 97357.
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-tcltk/thread')
-rw-r--r--dev-tcltk/thread/ChangeLog10
-rw-r--r--dev-tcltk/thread/Manifest2
-rw-r--r--dev-tcltk/thread/files/digest-thread-2.6.11
-rw-r--r--dev-tcltk/thread/metadata.xml5
-rw-r--r--dev-tcltk/thread/thread-2.6.1.ebuild41
5 files changed, 59 insertions, 0 deletions
diff --git a/dev-tcltk/thread/ChangeLog b/dev-tcltk/thread/ChangeLog
new file mode 100644
index 000000000000..df33738e6b2a
--- /dev/null
+++ b/dev-tcltk/thread/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-tcltk/thread
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/thread/ChangeLog,v 1.1 2005/07/02 15:20:41 matsuu Exp $
+
+*thread-2.6.1 (02 Jul 2005)
+
+ 02 Jul 2005; MATSUU Takuto <matsuu@gentoo.org> +metadata.xml,
+ +thread-2.6.1.ebuild:
+ initial ebuild. Bug 97357.
+
diff --git a/dev-tcltk/thread/Manifest b/dev-tcltk/thread/Manifest
new file mode 100644
index 000000000000..c6061b50ab7d
--- /dev/null
+++ b/dev-tcltk/thread/Manifest
@@ -0,0 +1,2 @@
+MD5 ac8214a9eee6deda0060c9e63535cc07 thread-2.6.1.ebuild 935
+MD5 9b4c86b16329dae30cdefd49b1e31f68 files/digest-thread-2.6.1 63
diff --git a/dev-tcltk/thread/files/digest-thread-2.6.1 b/dev-tcltk/thread/files/digest-thread-2.6.1
new file mode 100644
index 000000000000..fa7e479e7fdf
--- /dev/null
+++ b/dev-tcltk/thread/files/digest-thread-2.6.1
@@ -0,0 +1 @@
+MD5 ea680625659eb0a0afc354c7dadf3031 thread2.6.1.tar.gz 262963
diff --git a/dev-tcltk/thread/metadata.xml b/dev-tcltk/thread/metadata.xml
new file mode 100644
index 000000000000..20ce219711a2
--- /dev/null
+++ b/dev-tcltk/thread/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+</pkgmetadata>
diff --git a/dev-tcltk/thread/thread-2.6.1.ebuild b/dev-tcltk/thread/thread-2.6.1.ebuild
new file mode 100644
index 000000000000..98cb09d318bd
--- /dev/null
+++ b/dev-tcltk/thread/thread-2.6.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/thread/thread-2.6.1.ebuild,v 1.1 2005/07/02 15:20:41 matsuu Exp $
+
+inherit eutils
+
+DESCRIPTION="This is a sample skeleton ebuild file"
+HOMEPAGE="http://www.tcl.tk/"
+SRC_URI="mirror://sourceforge/tcl/${PN}${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="gdbm"
+
+DEPEND="gdbm? ( sys-libs/gdbm )
+ >=dev-lang/tcl-8.4"
+
+S=${WORKDIR}/${PN}${PV}
+
+pkg_setup() {
+ if ! built_with_use dev-lang/tcl threads ; then
+ eerror "dev-lang/tcl was not merged with threading enabled."
+ eerror "please re-emerge dev-lang/tcl with USE=threads"
+ die "threading not enabled in dev-lang/tcl"
+ fi
+}
+
+src_compile() {
+ econf \
+ --with-threads \
+ --with-tclinclude=/usr/include \
+ `use_with gdbm` || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc ChangeLog README
+}