summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarijn Schouten <hkbst@gentoo.org>2007-04-24 14:45:20 +0000
committerMarijn Schouten <hkbst@gentoo.org>2007-04-24 14:45:20 +0000
commit8e1dc2d8b1c6c16884b14b96e112ca27851bc9c4 (patch)
treefc56799af91a1ede33da647944700c3d19a5d0ea /dev-scheme/stklos
parentAdd ~x86-fbsd keyword. (diff)
downloadgentoo-2-8e1dc2d8b1c6c16884b14b96e112ca27851bc9c4.tar.gz
gentoo-2-8e1dc2d8b1c6c16884b14b96e112ca27851bc9c4.tar.bz2
gentoo-2-8e1dc2d8b1c6c16884b14b96e112ca27851bc9c4.zip
add boehm-gc threads use flag checking, bug 175371
(Portage version: 2.1.2.4)
Diffstat (limited to 'dev-scheme/stklos')
-rw-r--r--dev-scheme/stklos/ChangeLog5
-rw-r--r--dev-scheme/stklos/stklos-0.82.ebuild11
2 files changed, 13 insertions, 3 deletions
diff --git a/dev-scheme/stklos/ChangeLog b/dev-scheme/stklos/ChangeLog
index fb166a0eb8bc..ea9e85eba37a 100644
--- a/dev-scheme/stklos/ChangeLog
+++ b/dev-scheme/stklos/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-scheme/stklos
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/stklos/ChangeLog,v 1.2 2007/04/23 11:32:19 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/stklos/ChangeLog,v 1.3 2007/04/24 14:45:20 hkbst Exp $
+
+ 24 Apr 2007; Marijn Schouten <hkBst@gentoo.org> stklos-0.82.ebuild:
+ add boehm-gc threads use flag checking, bug 175371
23 Apr 2007; Marijn Schouten <hkBst@gentoo.org> stklos-0.82.ebuild:
add deps and use flags
diff --git a/dev-scheme/stklos/stklos-0.82.ebuild b/dev-scheme/stklos/stklos-0.82.ebuild
index 2aa25e122e78..752908c17311 100644
--- a/dev-scheme/stklos/stklos-0.82.ebuild
+++ b/dev-scheme/stklos/stklos-0.82.ebuild
@@ -1,6 +1,8 @@
-# Copyright 2007 Gentoo Technologies, Inc.
+# Copyright 1999-2007 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/stklos/stklos-0.82.ebuild,v 1.2 2007/04/23 11:32:19 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/stklos/stklos-0.82.ebuild,v 1.3 2007/04/24 14:45:20 hkbst Exp $
+
+inherit eutils
DESCRIPTION="fast and light Scheme implementation"
HOMEPAGE="http://www.stklos.org"
@@ -17,6 +19,11 @@ DEPEND="dev-libs/gmp dev-libs/libpcre dev-libs/boehm-gc
#silex and ``The Dominique Boucher LALR Package'' may also be deps, not in tree though
RDEPEND="${DEPEND}"
+pkg_setup() {
+ if use threads; then
+ built_with_use dev-libs/boehm-gc threads || die "boehm-gc must be built with threads use flag"
+ fi
+}
src_compile() {
# Inverses of options are treated like the options themselves.