summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBlake Matheny <jake@gentoo.org>2004-02-11 22:32:08 +0000
committerBlake Matheny <jake@gentoo.org>2004-02-11 22:32:08 +0000
commitbd30823990aead9f31e2dcaeefdc329ac762d8f7 (patch)
treeb9e66c0272811409903bbf8f5461b7b1ac6ae79e /dev-scheme/bigloo/bigloo-2.4c.ebuild
parentMove bigloo-lib to dev-scheme (diff)
downloadgentoo-2-bd30823990aead9f31e2dcaeefdc329ac762d8f7.tar.gz
gentoo-2-bd30823990aead9f31e2dcaeefdc329ac762d8f7.tar.bz2
gentoo-2-bd30823990aead9f31e2dcaeefdc329ac762d8f7.zip
Move bigloo from dev-lisp to dev-scheme
Diffstat (limited to 'dev-scheme/bigloo/bigloo-2.4c.ebuild')
-rw-r--r--dev-scheme/bigloo/bigloo-2.4c.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/dev-scheme/bigloo/bigloo-2.4c.ebuild b/dev-scheme/bigloo/bigloo-2.4c.ebuild
new file mode 100644
index 000000000000..c96a464dc27d
--- /dev/null
+++ b/dev-scheme/bigloo/bigloo-2.4c.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/bigloo/bigloo-2.4c.ebuild,v 1.1 2004/02/11 22:32:08 jake Exp $
+
+S=${WORKDIR}/${PN}${PV}
+DESCRIPTION="Bigloo Scheme compiler for x86, sparc, alpha, ppc and JVM"
+SRC_URI="ftp://ftp-sop.inria.fr/mimosa/fp/Bigloo/bigloo${PV}.tar.gz"
+HOMEPAGE="http://www-sop.inria.fr/mimosa/fp/Bigloo/bigloo.html"
+DEPEND=""
+#RDEPEND=""
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+src_compile() {
+ local myconf
+ local myjava=`java-config --java`
+ local myjavac=`java-config --javac`
+
+ use java &&
+ myconf="--jvm=force --java=$myjava --javac=$myjavac" \
+ || myconf="--jvm=no"
+
+
+ ./configure \
+ --native=yes \
+ --cflags="${CFLAGS}" \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man/man1 \
+ --docdir=/usr/share/doc/${PV} \
+ $myconf || die "./configure failed"
+
+ cp Makefile.config Makefile.config.orig
+ sed "s/JCFLAGS=-O/JCFLAGS=/" \
+ < Makefile.config.orig \
+ > Makefile.config
+ echo LD_LIBRARY_PATH=${S}/lib/2.4c >> Makefile.config
+
+ cp bde/Makefile bde/Makefile.orig
+ sed "s/\$(BOOTBINDIR)\/afile jas/LD_LIBRARY_PATH=\$(LD_LIBRARY_PATH) \$(BOOTBINDIR)\/afile jas/" \
+ < bde/Makefile.orig \
+ > bde/Makefile
+
+ cp Makefile.config Makefile.config.fixed
+
+ make || die
+}
+
+src_install () {
+ dodir /usr/bin
+ dodir /usr/lib
+ dodir /usr/share/doc/${PV}
+ dodir /usr/share/man/man1
+ dodir /usr/share/info
+
+ sed \
+ -e "s:^BINDIR=\(.*\):BINDIR=${D}\1:" \
+ -e "s:^LIBDIR=\(.*\):LIBDIR=${D}\1:" \
+ -e "s:^MANDIR=\(.*\):MANDIR=${D}\1:" \
+ -e "s:^INFODIR=\(.*\):INFODIR=${D}\1:" \
+ -e "s:^DOCDIR=\(.*\):DOCDIR=${D}\1:" \
+ < Makefile.config.fixed \
+ > Makefile.config
+
+ dodir /etc/env.d
+ echo "LDPATH=/usr/lib/bigloo/${PV}/" \
+ > ${D}/etc/env.d/25bigloo
+ make install || die
+}